Question about Dell WL6000 Computer Speakers

1 Answer

Subwoofer not working

Have a new Dell Inspiron 530 with these speakers... speakers light up but subwoofer has stopped working. The light won't even come on. I have checked all of the cords and everything is plugged in correctly. Please help!

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert that got 5 achievements.


    An expert who has written 20 answers of more than 400 characters.


    An expert who has answered 20 questions.

  • Contributor
  • 46 Answers
Re: Subwoofer not working

Check out is the adapter working or not an adapter is the one which is connected between the subwoofer and mains port which steps down the voltage if the adapter is not working ull not get the light just check it out if adapter is not working relplace the adapter and ull get the light and sound

Posted on Nov 21, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Logitech X-530 subwoofer stopped giving power to other speakers. The system worked fine for the last 4 years and then the power button would light up some times and others I would have to hit the...

check the drivers click stat control panel administation tools computer management deivice manager scroll to sound video and game controllers could be a yellow question exclamation mark? ! or a red X right click to re-install drivers click start control panel sounds and audio volume advanced speakers make sure you have selected the correct speakers also audio you will find 3 drop down lists make sure you have the correct settings there if you dont have a motherboard disk you will need to download the sound drivers
check the leads attached to the rear of the input plugs make sure the connection is good
or you might have to clean the dust from your computer dust causes static which causes your computer to overheat and all sorts of problems
also if you had to hit the subwoofer to get it to turn on check all power leads attached the to and around the subwoofer
hope this helps

Aug 03, 2011 | Logitech X-530 5.1 Surround Sound...

1 Answer

Dell Altec Lansing ADA 745 speakers. The computer connectors are different than on my old Dell 4550. However when I connect to my new Inspiron 580 using the cable that is connected to the subwoofer, I...

Found your problem when trying to solve the same issue.
I have just got a Dell XPS tower and am having the same issue.Given that your post was 5 months ago, did you ever solve it ?

Jan 26, 2011 | Dell ADA745 Computer Speakers

1 Answer

Center speaker isn't playing any music, when I check to see if windows is registering it I can hear sounds coming from everything but the center and subwoofer (not sure if the subwoofer is suppose to make...

The Center and the subwoofer are on the same cable so most likely it's unplugged or damaged. Replace the audio cable of the two with one of the other 4 speakers' and text again for any sound. If it works then all you need to do is replace that cable.

Jun 16, 2010 | Logitech X-530 Computer Speakers

1 Answer

Humming noise coming out of the subwoofer

sounds like a bad cable, or a loose connection between the pc and the speakers, or from the main speaker to the subwoofer.

check the connections, or try reinserting the cables to ensure a tight fit. then check the cable from the pc to the speakers. possibly replace 1 cable and see if the problem stops.

Sep 23, 2009 | Logitech X-530 Computer Speakers

1 Answer

No sound coming from ACS 48 Altec Lansing speakers

Hi janros123 - I don't know if this will help - I have a subwoofer ACS48 that needs satellite speakers (they are blown). Want to buy my subwoofer or sell your satellites? I will buy your broken subwoofer, too...thanks, and good luck! Greg illdooyoo at gmail dot com

May 16, 2009 | Computer Speakers

2 Answers

Subwoofer Speakers wont work

the speaker may have blown.
to test it look inside is there any tears in the fabric part of the speaker?
is there any loose or disconnected wires?
if thats not the case the speaker still may have blown out look on ebay for a new one

Apr 21, 2009 | Logitech X-530 Computer Speakers

1 Answer

Speaker cable installation

1.  Check the orange multipin connector for bent or broken pins.
2.  Make you have the subwoofer plugged in to a live power outlet.
3.  Check the fuse on the circuit board inside the subwoofer.
4.  Measure the output of the subwoofer power transformer.  I think I remember it as being in the range of 12-24VAC.  Inspect the rectifier diodes for signs of overload.  measure the dc output of the diodes.  I think I remember 18VDC.  
5.  Open the right speaker and verify the on/off switch is working.
6.  New Egg sells a multitude of similar speakers in the $40 to $80 range.

Apr 04, 2009 | Dell HK395 Computer Speakers

1 Answer

My speakers dont work , only my subwoofer

Check you sound properties. The computer may not have configured the speakers properly. Make sure the speakers are listed and that the correct drivers are installed. Doublecheck that you have the plugs in the proper jacks. Hope this helps.

Mar 08, 2009 | Logitech X-530 Computer Speakers

1 Answer

Can I use this subwoofer for a home theater system

yes you could but you would need to soder and take the stuff apart

Jan 04, 2009 | Dell HK395 Computer Speakers

Not finding what you are looking for?
Dell WL6000 Computer Speakers Logo

Related Topics:

313 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dell Computer Speakers Experts


Level 3 Expert

57068 Answers

Vernon Taylor

Level 3 Expert

1980 Answers

Bob S

Level 1 Expert

15 Answers

Are you a Dell Computer Speaker Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides