Question about Car Audio & Video

1 Answer

I have a Kenwood 1800wat amp with to 10" Sony kickers, I was driving to my new town when all of a sudden the subs stopped working. I reached around and pulled 1 off 2 fuses were blown and it was a 40amp fuse but I couldn't find any 40 amp fuses anywhere and the fella said 30 will be ok and it has a the amp 2x 30amp fuses so I put to brand new 30amps in and I get a red light that stays on and my brother inlaw that owned the cat before me said it should be green and he hooked it up himself. When I play music and hook subs back up, nothing iv gone threw all the wires and nothing is touching and the amp ground it hooked to the back fire wall of the ute, and after checking that still nothing and it's doing my head in... Please HELP Email at ashley_horne101@hotmail.com But do comment thanks

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Car Audio & ... Master
  • 74,211 Answers

If the fuse should blow up; there might be a reason. Shorted component at the power amplifier circuit board of the sub-woofer amp. It will be best to contact any service technician to check the set. Never insert a fuse and switch ON the set, till the fault has been detected and rectified. It might make things worse.
If you wish to get some details; check the site linked here. Pull up older posts. Surf the site with patience. http://electronicshelponline.blogspot.com/

Posted on Dec 15, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
habib_101
  • 55 Answers

SOURCE: Amp stopped working...

Has the amp been overheating lately? It's quite possible that the amp could have just blown. Smell around the outside of the amp for an electrical burnt smell. If available, see if a friend also has an amp hookup and try removing your amp and copnnecting to the friend's cables. That will tell you if it's a wiring problem or an amp problem.

Posted on Sep 13, 2006

SOURCE: sony 1200 watt amp

What kind of deck to you have? Sometimes there's a setting for the subwoofer output that has to be turned on. How is the deck hooked up to the amp? Be sure of the normal things: -Make sure the sub is connected in side it's box -Make sure the RCA cables didn't come off the deck -Check every connection! Let me know and be sure to leave feedback or I don't get paid.

Posted on Oct 03, 2007

  • 142 Answers

SOURCE: kenwood 350 w-2 amp wiring

you can simply take the input and connect it in parallel to the input of the second amplifier. The output of one amp will go to one speaker, and the output of the other amp will go to the other speaker.

The inputs of amplifiers are "high impedance" so putting more than one in parallel won't put any strain on the radio circuit.

Hope this helps.

Posted on Mar 27, 2008

  • 4 Answers

SOURCE: Amp Turns on Fine, but no Sound

have you checked the levels on the ohms? adjust them higher if need be contact me on yahoo msgr if you need more assistance

jcbproducts-always forward

ym-jcbproducts

Posted on Dec 03, 2008

  • 12 Answers

SOURCE: Jl 500/1 amplifier will not turn on

you may have burned the channel you were using..try taking the cover off the amp and checkin for burned spots or any wires that may be loose or touching within the amp.

Posted on Feb 26, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kicker dx 500.1 keeps ruining my subs


if your sub isnt blown, i'd follow your own idea and look for a bad wiring connections, also what kind of head unit do u have? check the settings on ur head unit to see if there is a seperate setting for your amp/subs if it does have one, make sure it is set properly

if it does not have a setting like above, check the rca cable from the radio to tthe amp, and make sure that the rca cable is plugged in to " input instead of the output

Jan 15, 2013 | Kicker 2010/10 Dx500.1 Car Audio Monoblock...

1 Answer

Kenwoodxw1000f shut off after 10 sec


the problem sounds like your new sub is drawing to much power and your amp can not handle it. bridging the amp is a good way to get the full power out of your amp. But it isnt always suggested, my solution is to get a bigger amp. I install stereo systems for a living, and i tell my customers that it is smart to get an amp about 100 more watts then the rms rating of your subwoofer.

Feb 13, 2010 | Kenwood eXcelon KFC-XW1000F Car Subwoofer

1 Answer

Blown amp possibly?


i have the same amp with the same problem.....your best bet is to do what i did get a better amp(audio pipe,spx,kicker,punch,etc) do not get pioneer amp or sony anything

Jun 20, 2009 | Kenwood KAC-X501F Car Audio Amplifier

1 Answer

Wiring problem for my Kicker ZX450.2 amp


wireing an amp can be tough it starts from the e.q.the e.q. must have a sub out.

Mar 02, 2009 | Kenwood Excelon KAC-X521 Car Audio...

1 Answer

Kac-8152d powers on, but no power output to subs


Well, the sad thing is, it can be a number of things. You will have to do a process of elimination. Try replacing the amp first, borrow one off a friend. Second try replacing the subs. If those don't work, read the manual to your deck. Find the audio settings, and check to see if the sub section is "on".

Jan 29, 2009 | Kenwood KAC-8152D Car Audio Amplifier

1 Answer

Kickers dont beat like they should


try to check and clean the wiring as clean as possible to avoid messing up on your connection. Check the polarity of you subs to yuor amp if you have it connected on the outher way around it would not give you a good result. check the polarity this will solve your problem. Over powering your sub will fry it easily try to tune it a 10" sub wont give you a 15" performance..

Jan 20, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Subs dont beat like they should


you've spent alot of money on **** by the sounds of it!!. you should only ever run multiple subs the same brand, power and resistance you can just connect any old subs to a system you need to wire them depending on the load that the amp needs to see. first thing is to try the amp/s on a individual sub to check your amps still work once done check the subs 1 by 1.

Jan 20, 2009 | Jl Audio 500/1 Car Audio Amplifier

3 Answers

How to wire kenwood amp to kicker cvr 12"


How you wire it depends on how hard you want drive your amp. If your woofer runs 4ohm per coil I would wile it in series (amp +to sub +1 sub -1to sub +2 amp - to sub -2) then run it for a week and see if it has enough power. the lower your Impedance (the resistance load on the amp) the harder your amp works and more THD (noise) is produced. (Dclass amps aren't know for being clean to begin with) configured like this your amp will see 8ohms and sound the clean east. if this turns out to be not enough power wire it in parallel and double the output. wire amp + to sub +1 and +2 then amp - to sub -1 and -2.

A word to the wise... start with your volume very low and work up slowly most speakers will puk up the voice coil before the amp starts to get warmed up. you would hate to have to buy a new sub.

Have fun
Rob

Dec 10, 2008 | Kicker CVR12 Car Subwoofer

2 Answers

Car sound system. only sub is giving off sound. other 4 speakers dont work at all


Could be bad outputs from the back of your head unit or also could be bad rca cables. Make sure the amp is on and powered.

Dec 13, 2007 | Kicker CompVT CVT654 Car Subwoofer

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

45 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4861 Answers

yadayada
yadayada

Level 3 Expert

76109 Answers

The Knight
The Knight

Level 3 Expert

74211 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...