Question about Hifonics Car Audio & Video

1 Answer

My hifonics Brutus 2000 watt has a dead short in it somewhere,as soon as you put power to it it blows the fuse,no lights nothing.any body got any ideas?i have it all tore apart now,but no burn spots

Everything I know.there is nothing hooked up but power,ground,and remote

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,249 Answers

Call hifonics, they do flat rate repairs on their equipment for a reasonable rate. Most likely, you have a shorted mosfet transistor module in the power supply. these are not a smple repair, most local shops won't touch them. My hifonics Brutus 2000 watt has a dead short in i - 25321271-zkea2bktkzr3q3lrmfdlr2m5-4-0.jpg

Posted on Dec 14, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a hifonics brutus 1606d 1600 watt amp it gets power green light is on lit up across the top but i cant get any sound


Your amplifier may have experienced circuit failure other than a dead short that still allows power to be applied

Dec 05, 2016 | Hifonics Car Audio & Video

1 Answer

Internal fuse


Amps getting power that's good it seems as though either you have a cross in your bridge or you fried your amp

Apr 02, 2014 | Hifonics Car Audio & Video

1 Answer

MY TAIL LIGHTS AND POWER WINDOWS BLOW A FUSE,AS AS SOON AS I TURN IGNITION ON.What could it be?


replace the tail lamps... one is dead shorting (filliment broken and grounding to the body of the bulb).

Mar 27, 2013 | Cars & Trucks

1 Answer

I have 2 12 inch jl audio w7's with a kicker crossover and a powerbass equalizer 5 bands. i wanted to know if add a hifonics brutus 2100 d class amp to my subs at 1 ohm would it over power my subs. please...


Short answer: NOPE!

The Hifonics Brutus 2100 is stated to produce 2100 watts RMS @ 1ohm load. Most amplifier manufacturers overstate their claims. The 2100 watt output is most likely at 14.4 volts and not the 12.6 volts your car will actually be providing the amp.

But, even if the actual output was 2100 watts that would be 1050 watts to each 12w7. The 12w7's are rated at 1000watts RMS and 2000watts peak. As a MECP certified installer, any system I have done using 12w7's have had a MINIMUM of 1000 watts being provided to each speaker. My personal preference is to run 1500 watts each and keep the gains adjusted lower on the amp. Thus allowing the amp to run cooler and allow the additional headroom for those "show-off" moments!

Dec 22, 2010 | Hifonics Car Audio & Video

1 Answer

I have a 2000 watt hifonics brutus amp ...it worked fine but 1 day it just stopped working..the power light doest light up but the hifonics led lights are still on...whats the problem?


there is a step up converter inside the amp that likes to come loose from the board. This may be your problem. Otherwise Check all the chips for burns or disconnect

Nov 13, 2009 | Hifonics Brutus BX 2005D Car Audio...

1 Answer

!!!red protect light is on!!!


Hello beaugarcia26,

Unless the amp itself is defective, there's a short or ground somewhere.

First disconnect the speaker wires and RCA (or high level) inputs, leaving just ground, remote turn-on and power leads connected. Then see if the amp powers up normally. If it doesn't check the ground with a multimeter and make sure it is good. If the amp powers up normally, check the speaker, speaker wires and inputs for shorts or grounds.

Hope this helps.

Sep 02, 2009 | Hifonics Brutus BX 1205D Car Audio...

1 Answer

Hifonics brutus 2000 watt help??!!??


If an RCA took a dive your amp has most likely seen a very nasty input spike and may never be the same as its circuitry has been damaged.....sorry

Mar 09, 2009 | Hifonics Brutus BXi 1206D Car Audio...

2 Answers

Hifonics amp keeps blowing the main fuse


have u tried using thicker wire from the battery to the amp u need to put a fuse in there thats a minumum 60

Jul 15, 2008 | Hifonics Brutus BXi 1206D Car Audio...

4 Answers

No sound in my Hifonics Brutus BXi 1206D amp


Have you confirmed that you have a good signal feeding the amp?

Have you confirmed that the speakers are in good working order and don't have any breaks in the wiring?

Jan 01, 2008 | Hifonics Brutus BXi 1206D Car Audio...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

79 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hifonics Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Radames Pagan
Radames Pagan

Level 3 Expert

196 Answers

Are you a Hifonics Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...