Question about Sharper Image EV-HD15 Cool Mist Ultrasonic Humidifier

1 Answer

Motor runs but no mist comes out on EV-HD15

Just turning it on . The motor works but no ;mist. It had worked the day before and for the last month

Posted by on

  • Rich Brown Mar 09, 2017

    One cause of this is buildup on the disk that vibrates ultrasonically to produce the mist. It has a little disk, usually about the size of a dime at the bottom of the well where the mist comes out. That metal disk gathers white scale on it, Clean that off. DON'T scrape at it. The best way I have found is with a Waterpik turned all the way up. They also make cleaners for ultrasonic humidifiers that works, but be very careful not to get it on your hands, clothing or countertops.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 3,368 Answers

If there is water in it, it sounds like the ultrasonic unit failed.

Posted on Dec 05, 2014

  • Dolores tiedemann
    Dolores tiedemann Mar 05, 2015

    Let me ask u this the box and instructions say Duracaft H830 yet on humidifier all it says on humidifier is Robutussin. Do u think someone switched the humidifiers. I purchased this at as yard sale

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Humidifier will produce mist for a min then stop If you look you can see it producing mist within but it will not come out of the top Walgreens cool mist ultrasonic humidifier


I have had times where my Crane humidifier won't produce mist if I haven't turned it on for several days (4+) or more. The water that sits in the reservoir may develop a film on the ultrasonic element which inhibits the creation of the mist to come out the top of your humidifier. I would lift off the tank and empty the reservoir. Then VERY GENTLY with a piece of paper towel, wipe the ultrasonic element (looks like a disk the size of a quarter at the bottom of the reservoir) to clean off any film. Then replace the tank and let the reservoir fill up the tank and try it again.

If your humidifier runs properly for a minute and then makes a whirring noise and goes silent (like the motor stopping), then it's a motor problem. The humidifier motor may have gone out of alignment due to bumping or rough handling of the humidifier when cleaning or emptying it. If that is the case, you will have to empty the humidifier reservoir, unscrew the base, and find the screws holding down the motor and check for misalignment. Loosen them a little and put it back together and try again.

Best of luck
thebqe

Feb 13, 2014 | Humidifiers

2 Answers

Humidifier not working


Mine is a SUL495 Filter Free unit and worked fine last year and the first couple of days recently, but I'm having the same issue, motor running , no mist, and trying to talk to someone @ in customer service today is a joke, I've cleaned everything but still no luck, I paid $40.00 for this unit in Jan. 2011 and have about two weeks until the warranty runs out, and the other wonderful thing is the nearest service center is about 50 miles away, I may wait until Monady to try to speak to someone, but I probably won't like the answers.

Nov 25, 2012 | Sunbeam SUL496-UM Ultrasonic Humidifier

1 Answer

I need a tank cap for my EV-HD10 Sharper Image Ultrasounic Cool Mist Humidifier. I lost ours and don't want to buy a whole new humidifier. Can I find one anywhere?


Contact SI Products @ 888-856-6781.
After a long wait I spoke with a very professional guy who ordered it for me in just a couple minutes. Totally restored my faith in the retail Sharper Image Products.

Dec 26, 2011 | Humidifiers

1 Answer

Venta Sonic VS205 Humidifier turns and has the green light, makes a buzzing sound, but no mist is coming out.


If you see mist in unit and not coming out fan motor in base of unit bad. Four screws in base and fan unplugs

Aug 20, 2011 | Venta Airwasher VS 207 3.7 Gallon...

1 Answer

I have an HM 495, the past 4 days it has been working fine. Now there is no mist coming out and it seems to be spilling water out of the back of the base. What is the problem? I have not been using warm or...


When this happened to me, I took the tank into the bathroom to look at the bottom and then I tried to turn the knob and it wasn't all the way tight. After I tightened it, I put it back on the base and the mist started right away.

Jan 14, 2011 | Holmes Products HM495-UC Humidifier

1 Answer

Humidifier not working


Ensure there is water in the tank.
  • This may be caused by mineral deposits in the water channels. Try the following: Clean the water tank, base and vapor nozzel with a damp cloth to remove any build up in the water channel.
  • When was the last time the cartridge was changed. (If it’s been over 3 months, this could be the reason why the unit is not working properly.)
  • Unscrew the demineralization cartridge and run the unit, if it starts to mist then you need a new cartridge. (insert cartridge link here)
  • The screw cap for the water tank, onto which one first screws in the demineralization cartridge, has a small rubber gasket. make sure that gasket is not too far down against the outer screw cap. If it is the spring loaded button would not work properly to let the water descend into the base tank .
    The solution: push up on that small rubber gasket so that it is as far up and away from the screw cap as it can be without falling off, and voila! you get mist!!
  • If you have changed the filter recently then take out the cartridge and run the unit without the cartridge for about 15 to 20 minutes.

May 18, 2009 | Venta Airwasher VS 207 3.7 Gallon...

2 Answers

We have a Sunbeam Cool Mist Ultrasonic Humidifier that we bought just over 2 months ago. Up until a couple of days ago, it was producing mist and running just fine. I cleaned it with the brush and got the...


I have this same problem. And cool mist humidifiers DO produce mist. I have had my humidifier for a while now (6 years) and have never had any problems. But after the most recent cleaning, it worked at first, but now seems to not be working anymore... Am also wondering if there is anything I can do to remedy the situation?

Mar 17, 2009 | Sunbeam 701 Humidifier

3 Answers

Runs, but nothing comes out


Check the filters and the fan blade it may have come loose. Do you still hear the motor running? Get me the model number on the unit. Sorry it took so long to get back to you I have been sick the past few months.

Aug 30, 2008 | Bemis 526 300 Humidifier

Not finding what you are looking for?
Sharper Image EV-HD15 Cool Mist Ultrasonic Humidifier Logo

884 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sharper Image Humidifiers Experts

ka4iup
ka4iup

Level 3 Expert

3957 Answers

Gil Shultz

Level 3 Expert

3368 Answers

Tom Chichester

Level 3 Expert

36236 Answers

Are you a Sharper Image Humidifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...