Question about Vacuums

1 Answer

Were are the brushes in the machine so I can clean them

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Vacuums Master
  • 3,368 Answers

The brushes would be in the motor and you do not want to clean them. I do not know what model or make you have hence that is the only brushes I currently know about.

Posted on Nov 29, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Brushes not rotating


here is manual > http://hoover.com/file/593/
The Hoover SteamVac's are notorious for this exact problem. There are several things that can be causing this probelm.

First, what you'll need to do is take the brush block out of the machine. To do this there are 4 clips on the brush block. You will need to turn the machine upside down, and pull down on the brush block to where it won't pull out any farther. There are 4 clips, 2 on top, and 2 on the rear of the brushes. (See picture I have circled one of the clips in red). Simply press these clips at the same time, and pull the brush block out of the machine. I'd say that 60% of the time that I see this problem, the main issue is that the brushes just need to be cleaned. If you have pets in the home, a lot of the time the pet hair will just be lodged inside the brushes, will prevent them from spinning. Use a pressurized water hose with spray nozzle is ideal) and spray each brush with water to dislodge any pet hair. You should be able to get these brushes spinning when you spray them. Spray each brush until the brushes are spinning pretty fast. Re-insert the brushes into the machine, and test to see if the cleaningicon1.png has fixed your problem. If the cleaning still fails to fix the problem, take the brushes back out of the machine.

One you have the brushes out of the machine, the first thing you should look at the brush stem that goes into the turbine inside the machine. This is the green pole pictured in middle of the brush block. Examine this pole to determine if the top of it has broken off. It should exactly how the picture shows it. Make sure that the plasticlb_icon1.png has not broken.

If the pole has broken, you will simply need to replace the brush block. If the pole is not damaged, the next thing to try is to turn the machine on while you have the brushes out. Look inside the machine, where the pole goes into the turbine (also important, make sure the switch for the brushes is turned to "Rotating Brush Speed Hi), this femaleicon1.png receptacle should spin when the machine is turned on. It is important the try this when the foot pedal is released, and the handle down, and not in the upright position, as there is an internal switch that shuts the brushes off when the machine is in the upright position.

If you notice that the female receptacle where the brush pole is inserted is spinning, then your turbine is fine. If this part is not spinning, then most likely you will need to replace your turbine.

I hope this helps you with your problem. If not, please feel free to request a repair clarification and I'd be happy to walk you through the diagnosing. I also can provide you with a blown up parts schematic to your machine, please just get the modelicon1.png number off the back of the machine and provide, and provide me with the full model number. I would be happy to provide any technical support you need, just request a clarification on the repair...

Apr 25, 2013 | Tti Hoover F7412-900 Max Extract Dual V...

1 Answer

Brushes won't rotate on hoover steam vac. I have removed them and cleaned.


The brushes turn by the airflow from the vacuum suction turning a turbine motor to spin the brushes. First try to spin the brushes by hand. If they won't turn it usually means the brushes are clogged with hair and debris or need replaced or the turbine could be seized up. If the brushes won't spin reach under the brushes and push the little tabs and remove the brush block asssembly from the machine. If the brushes spin freely after you remove them from the machine then that means that most likely the turbine is seized and will need to be repaced. If the turbine is not seized you may simply just have a clogged filter screen. Most steam vacs have a red screen filter either on top or underneath the machine. On the top it is under a little clear plastic cover that you have to pry off before you can pull the screen out to clean it. If it's underneath you can pull it out and clean it.

Jul 18, 2010 | Hoover SteamVac Carpet/Upholstery Deep...

1 Answer

5 BRUSHES DO NOT ROTATE WHEN IN CONTACT WITH CARPET


HI There,

When the brushes on a Hoover SteamVac stop spinning, it can be caused by several things. The most frequent problem is that there is debris in the brushes such as pet hair, or lint, that prevents the brushes from spinning. Usually if you remove the brushes and clean them thoroughly, this will fix the problem. This sounds to me like what is the problem on your machine, as you make it seem as if the brushes spin, but only stop spinnning when you put them down on the carpeting.

The brushes on your Hoover are driven by a turbine brush gear assembly, not a belt. Sometimes this part can go bad, but usually when it does, the brushes won't spin at all, even when they are not on carpeting.

Anyways, here a helpful guide that I've done that shows you step by step how you can diagnosis the problem with your brushes:

First, what you'll need to do is take the brush block out of the machine. To do this there are 4 clips on the brush block. You will need to turn the machine upside down, and pull down on the brush block to where it won't pull out any farther. There are 4 clips, 2 on top, and 2 on the rear of the brushes. (See picture I have circled one of the clips in red). Simply press these clips at the same time, and pull the brush block out of the machine.
d6c0881.jpg


I'd say that 60% of the time that I see this problem, the main issue is that the brushes just need to be cleaned. If you have pets in the home, a lot of the time the pet hair will just be lodged inside the brushes, will prevent them from spinning. Use a pressurized water hose with spray nozzle is ideal) and spray each brush with water to dislodge any pet hair. You should be able to get these brushes spinning when you spray them. Spray each brush until the brushes are spinning pretty fast. Re-insert the brushes into the machine, and test to see if the cleaning has fixed your problem. If the cleaning still fails to fix the problem, take the brushes back out of the machine.

Now look at the brush stem that goes into the turbine inside the machine. This is the green pole pictured in middle of the brush block. Examine this pole to determine if the top of it has broken off. It should exactly how the picture shows it. Make sure that the plastic has not broken.

adc2d4f.jpg
If the pole has broken, you will simply need to replace the brush block. If the pole is not damaged, the next thing to try is to turn the machine on while you have the brushes out. Look inside the machine, where the pole goes into the turbine (also important, make sure the switch for the brushes is turned to "Rotating Brush Speed Hi), this female receptacle should spin when the machine is turned on. It is important the try this when the foot pedal is released, and the handle down, and not in the upright position, as there is an internal switch that shuts the brushes off when the machine is in the upright position.

232c8b0.jpg

If you notice that the female receptacle where the brush pole is inserted is spinning, then your turbine is fine. If this part is not spinning, then most likely you will need to replace your turbine.

If you find that your turbine needs to be replaced, I have written a step by step guide that shows you each step on how to replace your brush turbine gear. Here's a link to that repair if you need to do it:
http://www.fixya.com/support/r4530769-diagnosis_fix_hoover_steamvacs_when

Hope this helped you, please be sure to rate my repair or leave me feedback if you found this helpful, thanks so much!

Chris Jones
GoVacuum.com

May 01, 2010 | Hoover F5866-900 SteamVac Deluxe Wet/Dry...

1 Answer

Brushes are not rotating


The Hoover SteamVac's are notorious for this exact problem. There are several things that can be causing this problem.

First, what you'll need to do is take the brush block out of the machine. To do this there are 4 clips on the brush block. You will need to turn the machine upside down, and pull down on the brush block to where it won't pull out any farther. There are 4 clips, 2 on front, and 2 in the rear. (See picture, I have circled one of the clips in red). Simply press these clips at the same time, and pull the brush block out of the machine. I'd say that 60% of the time that I see this problem, the main issue is that the brushes just need to be cleaned. If you have pets in the home, a lot of the time the pet hair will just be lodged inside the brushes, will prevent them from spinning. Use a pressurized water hose *(one with a spray nozzle is ideal) and spray each brush with water to dislodge any pet hair. You should be able to get these brushes spinning when you spray them. Spray each brush until the brushes are spinning pretty fast. Re-insert the brushes into the machine, and test to see if the cleaning has fixed your problem. If the cleaning still fails to fix the problem, take the brushes back out of the machine.

One you have the brushes out of the machine, the first thing you should look at the brush stem that goes into the turbine inside the machine. This is the green pole pictured in middle of the brush block. Examine this pole to determine if the top of it has broken off. It should exactly how the picture shows it. Make sure that the plastic pole has not broken.

If the pole is broken, you will simply need to replace the brush block assembly. The model F5914-900 uses Hoover 5 Brush SpinScrub Brush Block Part # 48437022.

Here's a direct link to this part on our GoVacuum.com storefront:
http://www.govacuum.com/hoovsteambru.html

If the pole is not damaged, the next thing to try is to turn the machine on while you have the brushes out. Step on the handle release pedal so the SteamVac handle is lowered, and not in the upright position, as there is an internal switch that turns the brushes off when the machine is in the upright position. Now look inside the machine where the pole goes in. There is a green, square shaped female receptacle. This is actually the internal turbine that spins the brush block. Make sure that the switch for the brushes on the top of the machine is turned to "Rotating Brush Speed Hi". Turn the machine on.

If you saw the female receptacle where the brush pole is inserted was spinning, then your turbine is fine. If this part is not spinning, then you will need to replace your turbine.

I hope this helps you with your problem. Please feel free request a clarification request form here on Fixya if you have any questions, I'm always happy to answer follow up questions you might have. If you found this repair helpful, please be sure to rate it helpful by clicking the thumbs up icon. Thank you.


Chris J.
GoVacuum
d6c0881.jpg232c8b0.jpgadc2d4f.jpgb64e530.jpg

Apr 14, 2010 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

The brushed on my steamvac Dual V F7227 are no longer working. We have pulled and cleaned the brushes, and the filter, but the brushes still will not come on. I saw a reply to one person that it is the...


Greetings from GoVacuum,

The Hoover SteamVac's are notorious for this exact problem. There are several things that can be causing this probelm.

First, what you'll need to do is take the brush block out of the machine. To do this there are 4 clips on the brush block. You will need to turn the machine upside down, and pull down on the brush block to where it won't pull out any farther. There are 4 clips, 2 on top, and 2 on the rear of the brushes. (See picture, I have circled one of the clips in red). Simply press these clips at the same time, and pull the brush block out of the machine. I'd say that 60% of the time that I see this problem, the main issue is that the brushes just need to be cleaned. If you have pets in the home, a lot of the time the pet hair will just be lodged inside the brushes, will prevent them from spinning. Use a pressurized water hose (garden hose2_bing.gif with spray nozzle is ideal) and spray each brush with water to dislodge any pet hair. You should be able to get these brushes spinning when you spray them. Spray each brush until the brushes are spinning pretty fast. Re-insert the brushes into the machine, and test to see if the cleaning has fixed your problem. If the cleaning still fails to fix the problem, take the brushes back out of the machine.

One you have the brushes out of the machine, the first thing you should look at the brush stem that goes into the turbine inside the machine. This is the green pole pictured in middle of the brush block. Examine this pole to determine if the top of it has broken off. It should exactly how the picture shows it. Make sure that the plastic has not broken.

If the pole has broken, you will simply need to replace the brush block. If the pole is not damaged, the next thing to try is to turn the machine on while you have the brushes out. Look inside the machine, where the pole goes into the turbine (also important, make sure the switch for the brushes is turned to "Rotating Brush Speed Hi), this female receptacle should spin when the machine is turned on. It is important the try this when the foot pedal is released, and the handle down, and not in the upright position, as there is an internal switch that shuts the brushes off when the machine is in the upright position.

If you notice that the female receptacle where the brush pole is inserted is spinning, then your turbine is fine. If this part is not spinning, then most likely you will need to replace your turbine.

I hope this helps you with your problem. If not, please feel free to email me at chris.jones@govacuum.com, and I'd be happy to walk you through the diagnosing. I also can provide you with a blown up parts schematic to your machine, please just get the model number off the back of the machine and provide, and provide me with the full model number. I do carry all parts for your machine, and would be happy to provide any technical support you need.

I tried uploading the pictures to this solution, however Fixya will not allow the pictures because they are too big. Please email me, and I'll send you the pictures.

Chris Jones
GoVacuum.com
chris.jones@govacuum.comd6c0881.jpg232c8b0.jpgadc2d4f.jpgb64e530.jpg

Mar 17, 2010 | Hoover Steam Vac Dual V w/ SpinScrub...

1 Answer

Brushes stopped spinning during carpet cleaning.


Greetings from GoVacuum,

The Hoover SteamVac's are notorious for this exact problem. There are several things that can be causing this probelm.

First, what you'll need to do is take the brush block out of the machine. To do this there are 4 clips on the brush block. You will need to turn the machine upside down, and pull down on the brush block to where it won't pull out any farther. There are 4 clips, 2 on top, and 2 on the rear of the brushes. (See picture, I have circled one of the clips in red). Simply press these clips at the same time, and pull the brush block out of the machine. I'd say that 60% of the time that I see this problem, the main issue is that the brushes just need to be cleaned. If you have pets in the home, a lot of the time the pet hair will just be lodged inside the brushes, will prevent them from spinning. Use a pressurized water hose (garden hose2_bing.gif with spray nozzle is ideal) and spray each brush with water to dislodge any pet hair. You should be able to get these brushes spinning when you spray them. Spray each brush until the brushes are spinning pretty fast. Re-insert the brushes into the machine, and test to see if the cleaning has fixed your problem. If the cleaning still fails to fix the problem, take the brushes back out of the machine.

One you have the brushes out of the machine, the first thing you should look at the brush stem that goes into the turbine inside the machine. This is the green pole pictured in middle of the brush block. Examine this pole to determine if the top of it has broken off. It should exactly how the picture shows it. Make sure that the plastic has not broken.

If the pole has broken, you will simply need to replace the brush block. If the pole is not damaged, the next thing to try is to turn the machine on while you have the brushes out. Look inside the machine, where the pole goes into the turbine (also important, make sure the switch for the brushes is turned to "Rotating Brush Speed Hi), this female receptacle should spin when the machine is turned on. It is important the try this when the foot pedal is released, and the handle down, and not in the upright position, as there is an internal switch that shuts the brushes off when the machine is in the upright position.

If you notice that the female receptacle where the brush pole is inserted is spinning, then your turbine is fine. If this part is not spinning, then most likely you will need to replace your turbine.

I hope this helps you with your problem. If not, please feel free to email me at chris.jones@govacuum.com, and I'd be happy to walk you through the diagnosing. I also can provide you with a blown up parts schematic to your machine, please just get the model number off the back of the machine and provide, and provide me with the full model number. I do carry all parts for your machine, and would be happy to provide any technical support you need.

I tried uploading the pictures to this solution, however Fixya will not allow the pictures because they are too big. Please email me, and I'll send you the pictures.

Chris Jones
GoVacuum.com
chris.jones@govacuum.comd6c0881.jpg232c8b0.jpgadc2d4f.jpgb64e530.jpg

Mar 16, 2010 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

My model F5906-900 --- problem is the brushes have stoped working... I pulled the brush assembly out by holding the two tabs, and all seems clean and the brush assembly rotates easly... onced the brush...


(1) Assure the Brush Control on the hood is NOT set to the OFF position.
(2) Remove the brush assembly by pulling/unlatching it from base on each side.
(3) Does one of the brushes have the drive pin present? It should be about ¼ inch square, and two inches long. It attaches the brushes to the drive mechanism.
(4) Remove and clean the intake filter. One the base of the cleaner, behind the brushes, squeeze the two red abs together and pull the panel down to access the screen. Clean the hair/debris off the screen and reassemble.

Mar 10, 2010 | Hoover F5906-900 Upright Steam Vacuum

1 Answer

Brushes won't turn and the water or solution runs out of machine when it is turned on. I've cleaned the screen, taken the brushes out and cleraned them.


Greetings from GoVacuum,

The Hoover SteamVac's are notorious for this exact problem. There are several things that can be causing this probelm.

First, what you'll need to do is take the brush block out of the machine. To do this there are 4 clips on the brush block. You will need to turn the machine upside down, and pull down on the brush block to where it won't pull out any farther. There are 4 clips, 2 on top, and 2 on the rear of the brushes. (See picture I have circled one of the clips in red). Simply press these clips at the same time, and pull the brush block out of the machine. I'd say that 60% of the time that I see this problem, the main issue is that the brushes just need to be cleaned. If you have pets in the home, a lot of the time the pet hair will just be lodged inside the brushes, will prevent them from spinning. Use a pressurized water hose with spray nozzle is ideal) and spray each brush with water to dislodge any pet hair. You should be able to get these brushes spinning when you spray them. Spray each brush until the brushes are spinning pretty fast. Re-insert the brushes into the machine, and test to see if the cleaning has fixed your problem. If the cleaning still fails to fix the problem, take the brushes back out of the machine.

One you have the brushes out of the machine, the first thing you should look at the brush stem that goes into the turbine inside the machine. This is the green pole pictured in middle of the brush block. Examine this pole to determine if the top of it has broken off. It should exactly how the picture shows it. Make sure that the plastic has not broken.

If the pole has broken, you will simply need to replace the brush block. If the pole is not damaged, the next thing to try is to turn the machine on while you have the brushes out. Look inside the machine, where the pole goes into the turbine (also important, make sure the switch for the brushes is turned to "Rotating Brush Speed Hi), this female receptacle should spin when the machine is turned on. It is important the try this when the foot pedal is released, and the handle down, and not in the upright position, as there is an internal switch that shuts the brushes off when the machine is in the upright position.

If you notice that the female receptacle where the brush pole is inserted is spinning, then your turbine is fine. If this part is not spinning, then most likely you will need to replace your turbine.

I hope this helps you with your problem. If not, please feel free to request a repair clarification and I'd be happy to walk you through the diagnosing. I also can provide you with a blown up parts schematic to your machine, please just get the model number off the back of the machine and provide, and provide me with the full model number. I would be happy to provide any technical support you need, just request a clarification on the repair.

I tried uploading the pictures to this solution, however Fixya will not allow the pictures because they are too big. Please email me, and I'll send you the pictures.

Chris Jones
d6c0881.jpg232c8b0.jpgadc2d4f.jpgb64e530.jpg

Mar 01, 2010 | Hoover Steam Vac Dual V w/ SpinScrub...

1 Answer

Clean inside of brushes


Greetings from GoVacuum,

The Hoover SteamVac's are notorious for this exact problem. There are several things that can be causing this probelm.

First, what you'll need to do is take the brush block out of the machine. To do this there are 4 clips on the brush block. You will need to turn the machine upside down, and pull down on the brush block to where it won't pull out any farther. There are 4 clips, 2 on top, and 2 on the rear of the brushes. (See picture, I have circled one of the clips in red). Simply press these clips at the same time, and pull the brush block out of the machine. I'd say that 60% of the time that I see this problem, the main issue is that the brushes just need to be cleaned. If you have pets in the home, a lot of the time the pet hair will just be lodged inside the brushes, will prevent them from spinning. Use a pressurized water hose (garden hose2_bing.gif with spray nozzle is ideal) and spray each brush with water to dislodge any pet hair. You should be able to get these brushes spinning when you spray them. Spray each brush until the brushes are spinning pretty fast. Re-insert the brushes into the machine, and test to see if the cleaning has fixed your problem. If your brushes still wont spin, you may need to replace the brush block itself. Check the model number on your SteamVac which will be located on the back of the Steamvac on a stick with model information. GoVacuum.com does carry ALL of the SteamVac Brush Blocks on our site if you need to buy a new brush block.

Here's a picture on how you can remove these clips;

d6c0881.jpg

If this does not fix your problem, there are a few other problems that could be causing this.

Feel free to call me, or email me if you have any questions about your SteamVac, I'm more then happy to diagnose the problem overthe phone / email.

Chris Jones
GoVacuum.com
chris.jones@govacuum.com
1-866-468-2288

Nov 27, 2009 | Hoover SteamVac Carpet/Upholstery Deep...

4 Answers

Brushes wont spin


Greetings from GoVacuum,

The Hoover SteamVac's are notorious for this exact problem. There are several things that can be causing this probelm.

First, what you'll need to do is take the brush block out of the machine. To do this there are 4 clips on the brush block. You will need to turn the machine upside down, and pull down on the brush block to where it won't pull out any farther. There are 4 clips, 2 on top, and 2 on the rear of the brushes. (See picture, I have circled one of the clips in red). Simply press these clips at the same time, and pull the brush block out of the machine. I'd say that 60% of the time that I see this problem, the main issue is that the brushes just need to be cleaned. If you have pets in the home, a lot of the time the pet hair will just be lodged inside the brushes, will prevent them from spinning. Use a pressurized water hose (garden hose with spray nozzle is ideal) and spray each brush with water to dislodge any pet hair. You should be able to get these brushes spinning when you spray them. Spray each brush until the brushes are spinning pretty fast. Re-insert the brushes into the machine, and test to see if the cleaning has fixed your problem. If the cleaning still fails to fix the problem, take the brushes back out of the machine.

One you have the brushes out of the machine, the first thing you should look at the brush stem that goes into the turbine inside the machine. This is the green pole pictured in middle of the brush block. Examine this pole to determine if the top of it has broken off. It should exactly how the picture shows it. Make sure that the plastic has not broken.

If the pole has broken, you will simply need to replace the brush block. If the pole is not damaged, the next thing to try is to turn the machine on while you have the brushes out. Look inside the machine, where the pole goes into the turbine (also important, make sure the switch for the brushes is turned to "Rotating Brush Speed Hi), this female receptacle should spin when the machine is turned on. It is important the try this when the foot pedal is released, and the handle down, and not in the upright position, as there is an internal switch that shuts the brushes off when the machine is in the upright position.

If you notice that the female receptacle where the brush pole is inserted is spinning, then your turbine is fine. If this part is not spinning, then most likely you will need to replace your turbine.

I hope this helps you with your problem. If not, please feel free to email me at chris.jones@govacuum.com, and I'd be happy to walk you through the diagnosing. I also can provide you with a blown up parts schematic to your machine, please just get the model number off the back of the machine and provide, and provide me with the full model number. I do carry all parts for your machine, and would be happy to provide any technical support you need.

I tried uploading the pictures to this solution, however Fixya will not allow the pictures because they are too big. Please email me, and I'll send you the pictures.

Chris Jones
GoVacuum.com
chris.jones@govacuum.comd6c0881.jpg232c8b0.jpgadc2d4f.jpgb64e530.jpg



Oct 03, 2008 | Hoover SteamVac F5914-900 SpinScrub...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

27 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18402 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...