Question about Utilitech 1/2-HP 9-GPM Shallow Well Jet Pump with 6-Gallon Pre-Charge

1 Answer

Why does the pump lose pressure? there are no visible leaks, of water or air

Posted by on

  • James Beiler
    James Beiler Nov 29, 2014

    I turned off the valve between the pump and the tank, so there are no leaks in the pipes. when i turned the valve off, the pump turned on and off quickly, from 20-40 psi

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

  • Contributor
  • 25 Answers

For the pump to lose pressure there has to be a leak somewhere please check and make sure you have a one way valve on the bottom of your jet pump that will not allow the water to run back into the well

Posted on Nov 29, 2014

  • James Beiler
    James Beiler Nov 29, 2014

    I have the pump suspended above the water, and there is no water dripping. Also, no air leaking anywhere. It is pushing water to the house, but faucet pressure is very low.

  • James Beiler
    James Beiler Nov 29, 2014

    could it be losing water back down the suction tube? or possibly i didnt prime it correctly.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Water appears to flow back through pump


When? When, at the time pump turns off?
or... When everything has been off for a while, and there is no more water in the pump? Or another words, loses prime during off time?
check for air leaks on pressure side of pump. If there is an air leak on suction side of pump, then the filter canister will build up air within it, and while the pump is on it is compressing the air, just like an air compressor, in the filter tank. And then at the time the pump turns off all the water will be blown back the way it came, because of the pressure that was developed and built up in the filter tank! If this is the case, locate that section leak on the suction side of the pump... Check all union connections, for bad seals/orings, or threaded connections for a bad Teflon tape or silicone sealant connection, etc. etc. any point of entry for air to get into the plumbing system is not good.

Mar 28, 2015 | Pool & Spa

1 Answer

Why is my car losing coolant?


If there are no visible leaks, and if the vehicle has 50K or more miles, it could be the water pump. Water pumps can leak small amounts of water out the "weep hole" while running (this is to indicate wear and need for pump replacement before failure), but seal up when shut down. This leaking water will often evaporate on the block or trail under the vehicle. Sometimes, if you look at the underside of the hood just above the serpentine belt, you may see a vertical discolored stripe on the paint or insulation. This may be coolant that drips onto the serpentine belt and is flung upward., but this is not always the case. Usually, if the week hole is leaking, if you can get a visual look at the bottom of the water pump pulley (often hard to do), you may see some indications of coolant seepage.

Sep 06, 2014 | 2003 Chevrolet Chevrolet Malibu Base

3 Answers

Coolant is being used up quickly and engine keeps overheating.


is there any visible leaks ,if is over heating take thermostat out see what happens ,check radiator cap for broke seal and the last thing is the water pump gone bad

Mar 22, 2011 | 1995 Pontiac Grand Am

1 Answer

I replaced old pump w/ Flotec 1/2HP FP4012 and replaced old pressure tank w new 35gal tank. Pump primed but cycles on-off every minute constantly even w/ no water turned on. Goes to 50PSI, loses pressure...


The water and therefore the pressure has to be going somewhere. If you are sure that there are no leaks in the house or outside, then the water is going back into the well. There is a check valve either in the suction line of the pump between the top of the well and the pump or down in the well.
If this check valve fails, it allows water to go the wrong way and back to the well. The result is that you lose pressure.
Secondly, you have to be sure that there are no air leaks between the top of the well and the inlet to the check valve. Leaks in that piping will make repriming difficult.
Write back with more and I'll try to help more.
Gary

Jan 22, 2011 | Flotec Corrosion Resistant Shallow Well...

1 Answer

Losing pressure after about 15 mins pool pump stars really well but then seems to lose pressureleaf catcher before pemp seems to get air in it is this pump or pipes


If the inlet strainer gets air in it, the pump will lose prime. Fill the inlet strainer basket with water, make sure the cover is on air tight. Start the pump and watch the inlet strainer, the amount of air trapped should not increase, if it does, you have a leak somewhere on the piping between the pool and the pump.

Nov 19, 2010 | Plumbing

2 Answers

95 maxima finished changing brakes/bled little press no pressure


Check your master brake cylinder for vacum leak.

Jan 05, 2010 | 1995 Nissan Maxima

1 Answer

Kreepy Krauly is not moving at all. Air bubbles are visible at return into pool, but water pressure is very low. When system is put on circulation, the return is much stronger than on filter. No visible...


If circulation is better when you pull the cleaner from the water the problem may be in your hose's. With the pump running pull the hose's from the water one at a time to see if you hear air leaking into the hose's and then replace the bad ones. Hope this helps, good luck

Dec 02, 2009 | Zodiac Pacer Pool Cleaner

1 Answer

When my pump turn on it does not want to work you hear it running but that is it, it sound like it needs to be primed or something to kick in gear


you will need to fill the pump hair/lint pot full with water before you try to start it up. If it keeps losing prime, you'll need to investigate why it's happening. A possible air leak on the suction line, a cracked lid o-ring, an extremely dirty filter, or an air leak in the multiport valve on the filter. When the pump picks up prime, check for air bubbles in the pump pot, excessive air getting into the pump indicates a suction side leak. Any other leaks on the pressure side will lead you to where it may be letting air into the system and causing the pump to lose prime while the system is off.

Nov 09, 2009 | Hayward SAND FILTER, PRO SERIES

2 Answers

Water leaking from underneath after washer drains


Hiya........... have a good look at the door seal for any visible tears... do it with wet hands... and the electric off!! If you cant see anything... Have a look at the pump couplings.. for any visible signs if leaking!

Get back with the results

regards Faggly

Mar 27, 2008 | Whirlpool Ultimate Care II LSQ9564J Top...

Not finding what you are looking for?
Utilitech 1/2-HP 9-GPM Shallow Well Jet Pump with 6-Gallon Pre-Charge Logo

Related Topics:

231 people viewed this question

Ask a Question

Usually answered in minutes!

Top Utilitech Plumbing Experts

Dave

Level 2 Expert

166 Answers

J.D. Browning
J.D. Browning

Level 3 Expert

2760 Answers

Boyet Soriano
Boyet Soriano

Level 2 Expert

293 Answers

Are you an Utilitech Plumbing Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...