Question about TYC 02-05 03 04 Kia Sedona 3.5l V6 Cooling Fan Assembly In Box 2004 2005

2 Answers

I have 02 kia sedona that runs rough at idle nd dies when i put it in gear and give it gas.

Last time i drove it it was sputtering real bad and dieing when i drove it. pumped the gas pedal repaetedly to get it to restart. then it died and woldnt start. although it would keep trying then it had a real strong odor in car after that that i cant explain. left it sit for month or so and went to tinker with it. vanstarted and was running at idle but if i give it gas it seams to want to cut out if i let of and pump it it will rev up to limit. when i put it in to gear it runs worse and will die if i keep giving it gas. but if i put it back in gear it will stay running. havent checked code will do that tommarow. step dad who use to work on cars thinks it sonds like it may need a tune up. any ideas

Posted by on

  • 2 more comments 
  • terrance
    terrance Dec 16, 2014

    just hooked the scan tool up throwing p0122 two times on same scan and p0102. which is throttle /pedel position sensor circuit a low volt and mass air circuit a low voltage

  • willy15 Dec 16, 2014

    I told you how to check the fuel pressure on this vehicle, did you do it? Is so, post the pressure.If not, do it please. Also did you change your fuel filter?

  • terrance
    terrance Dec 16, 2014

    no didnt check fuel pressure. cant find the post where you told me how to do that. nd havent changed the filter. its been in the single digits here. nd its broke down half hour from where i usually work on it. but since ive posted ive had it running twice sofar it will sit at idle nd run as long as i let it. once half hour nd today 45 mins. without dieing unless i put it in gear nd give it gas thats when it dies. did put three front spark in front. nd new coil over boots. havent taken air pheluam off yet to change the back three. but only codes are for the tps/pedal position switch

  • terrance
    terrance Dec 17, 2014

    also i was told the 02 kia sedona does not have external fuel filter its attached to fuel pump nd if i try to take it off i will damage fuel pump so should i just order a new fuel pump nd be done with it i can get a new one for under a hundered bucks nd change it in 20 mins. but i will atleast check fuel presser

×

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Filmmaker:

    Uploaded 5 video answers.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 106 Answers

Hi!
In my opinion:
1.) fuel filter
2.) spark plugs (change, or clean if clogged)
3.) fuel pump (hope not, this is quite expensive)

Hope I could help. Try it, 1.) + 2.) are not more than 50 bucks + 20 to 60 minutes, depending how experienced you are...

Posted on Nov 29, 2014

Testimonial: "the funny thing is the fuel pump is easier to get at then the rear spark plugs it has a access panel right behind the front seats. lift the door pull 4 screws and its right there. have to take air fauluam off just to get to rear plugs. thanks for advice."

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 706 Answers

Do the simple thing first, change the fuel filter, if that doesn't fix it, then you'll have to check fuel pressure to make sure it's in spec.

Posted on Nov 28, 2014

Testimonial: "not sure how to check fuel pressure. cant check it at the rail. tried that last weekend. kia didnt put a nozzle on the rail."

  • 8 more comments 
  • willy15 Dec 02, 2014

    If it has not port, then you'll have to disconnect and go thorugh the fuel high pressure side. When you unhook it, there will be residual fuel pressure, just put a shop towel over it so it doen't spray you. You should have an adapter in your fuel pressure check kit to fit the end.

  • willy15 Dec 02, 2014

    I just noticed you said it had a code stored. What is the code?

  • terrance
    terrance Dec 16, 2014

    yes po122 which was on there twice for same scan and po102. po122 is throttle/ pedel position circuit a low current and po102 mas air circuit a low current.nd week ago went nd it started nd ran rough at idle for half hour. but when i gave it gas it would almost cut immediately but if i let of nd give it gas i could get it to rev limit. but in gear itwould run worse nd die if i gave it gas nd would run at idle agian after that. also it shifts down out of 4th into 3rd. so i just drove in 3rd for few months. then reverse went out. code said under drive slinoid vale system any ideas hear its limp home mode. fluid is browner red not the bright red. was told flush would correctthat. any ideas

  • willy15 Dec 16, 2014

    First change the fuel filter, then you need to check fuel pressure. If you don't have the tools to check the fuel pressure, you'll have to take it to a shop. After you've done both, then we'll move on to the codes.

  • terrance
    terrance Dec 17, 2014

    k i will figure out where fuel filter is nd get that changed tommarow or next day. a

  • willy15 Dec 17, 2014

    The reason for this, is I stongly believe your issue is fuel related. Please let me know when the filter and pressure have been checked.

  • terrance
    terrance Dec 17, 2014

    i also wanted to add that i went over there today nd tried stsrting put but it wouldnt even try to pop nd start like it normally does so i pulled out the sparkplug

  • willy15 Dec 17, 2014

    Your commment was cut off. Was there any fuel on the plug you pulled or was it wet with fuel?

  • terrance
    terrance Dec 17, 2014

    and it was soaked with fuel and i noticed the boot under the coil over is i can see carbon marks from where the spark is jumping so im also gonna change those. also i has a bad battery in it so ive had jumper cables hooked to intrying to start it could those codes be from bad battery? but i will figure how to test fuel presser and put fuel filter in it nd get back to you. also got few questions on transmission problem but i will wait nd see if inget it running agian. i think it may be in limp mode but not sure i can tear apart nd replace anything been working on cars over 15 years just not the best at diagnostic

  • willy15 Dec 17, 2014

    If your battery is bad or has low voltage, nothing works and it will through various codes. Put your DVOM on the battery and make sure you have at least 12.8 Volts without it started. If not you're battery needs charging completely before proceding.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Car will start but put it in gear engine will die


engine starts with no problem; but, when I put in gear and ...

www.cargurus.com > Questions > Hyundai > Sonata

CarGurusNov 15, 2012 - The engine just fall dead when you step on the gas; it seems to jerk before ... My car does the same thing but i put it in neutral n it starts up. ... I have a 2004 kia optima it jerks when I go into reverse it was driving ... start and run fine butwhen I put it in drive or any other gear it dies! ... 2002 Hyundai Elantra GT.

Engine stalls when tranny put in Drive or Reverse - Kia Forum

www.kia-forums.com/kia-carnival...2002.../43407-engine-stalls-when-tr...

Feb 28, 2008 - 10 posts - ‎3 authors
Give it a little gas before putting in D or R and it will go. .... When I start the van cold and shift the tranny into drive or reverse.....the whole front ... won't run in forward gears - Kia Forum
10 posts
May 25, 2012
Intriguing problem - engine rough idle & hesitation ...
10 posts
Aug 31, 2011
2006 Kia Spectra engine stalls and bad idle, cleaning the ...
10 posts
Aug 30, 2010
2002 Kia Spectra Won't Go Out of Park - Kia Forum
3 posts
Oct 28, 2008
More results from www.kia-forums.com

Dec 17, 2015 | 2002 Kia Rio

1 Answer

My 2002 kia sedona won't idle until warms up, dies when put into gear ...any ideas??


Is the check engine light on? you could have a bad ignition fail sensor, TPS sensor, or bad o2 sensor. it could also be a bad mass air flow sensor or a vacuum leak. without a code to help pin point the problem I'd start by checking those things first. Maybe try unplugging the mass airflow sensor and start it up and see if anything changes.

Oct 03, 2014 | 2002 Kia Sedona

1 Answer

Engine stall when put into gear.


There are a few possibility on this one. If you run it out of gas or really low on gas you could of sucked junk up from the bottom of the tank and you will need to replace your fuel filter. Another is that your fuel pump us going bad and you would need to check the pressure. Your throttle position sensor may have gone bad. Your idle control valve is another. Your map sensor or mas sensor could be bad

Apr 22, 2014 | 2000 Dodge Ram 1500 Truck

1 Answer

Truck sputters and doesnt have power at lower rpms


Possible fuel pump about to die. They will work if revs kept up

Aug 12, 2012 | 1990 Isuzu Pickup

1 Answer

4.3 L will not idel


check the Idle Stop Solenoid

May 22, 2010 | 1992 GMC Safari

1 Answer

Kia sedona 2002 smell gas in the interior of car


Sounds like you might have bad O2 sensors, leaking fuel injector O rings or a bad fuel pressure regulator. Check that the vacuum hose to the pressure regulator is connected and no cracks or holes in it. Any check engine light?

Jan 07, 2010 | 2002 Kia Sedona

1 Answer

I have a 02 kia sportage and it dies on 1st start,nocodes,realwea


Repace the mass air flow meter.Its those symtoms it gives when it failes

Jul 18, 2009 | 2002 Kia Sportage

1 Answer

I have a kia sedona 2002 and it runs above tickover but dies when


its more than likley the idle conrtoll valve got a local garage and ask them to put it on the computer it will cost you about 20 pounds but it will pin point the problem but im sure thats whats wrong

Jul 17, 2009 | 2002 Kia Sedona

1 Answer

My girlfriend has a 93 olds cutlass ciera and it dies in reverse


When is the last time she had a tune up?
I would start there. Plugs, Wires, Distributor Cap and Rotor. Hope this helps you and thank you for using FixYa!

Mar 26, 2009 | 1993 Oldsmobile Cutlass Ciera

1 Answer

1991 Geo Metro Automatic/ Sputters, runs rough only in gear.


Could possible be a bad or stuck vaccum advantace mechanism. Check for operation.

Feb 16, 2009 | 1991 Geo Metro

Not finding what you are looking for?
TYC 02-05 03 04 Kia Sedona 3.5l V6 Cooling Fan Assembly In Box 2004 2005 Logo

166 people viewed this question

Ask a Question

Usually answered in minutes!

Top TYC Computers & Internet Experts

jeff5may32

Level 3 Expert

1243 Answers

Todd Arndt
Todd Arndt

Level 3 Expert

2044 Answers

Brad Brown

Level 3 Expert

15478 Answers

Are you a TYC Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...