Question about M-Audio Bx8a Deluxe Power Studio Monitors New Overstock

2 Answers

Hi i have a set of bx8a and one of them when it is on the woofer pumps out uncontrollable even when no music is playing please help

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

If the woofer is motor boating....going in and out, like a flutter,
likely a power supply issue on the power amp board, in back of the speaker. This would need to be repaired. Since these are powered speakers, if for example, a power supply capacitor were bad,
it can do that. If under warrantee, find an authorized repair center near you. Contact manufacturer.
Hope this helps.

Posted on Nov 26, 2014

Testimonial: "yes this is what its doing i have got them second hand so there is no warrantie im pretty good with repairs usaly but i see no swollen capacitors or any notable damage do u think i would have to replace the whole bord or could u help me pinpoint where the problem is exactly thanks"

  • mike_ryan798 Nov 26, 2014

    Often, there is no physical evidence of damage to a cap, or one that is passing DC into the audio circuit. It is a pretty easy fix, and think it is worth taking to a tech, they can find it in 5 minutes.

×

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

You have an amplifier problem. I,m sure we can fix it. You may try an elctronic repair center in your area

Posted on Nov 26, 2014

  • wayne beal
    wayne beal Nov 26, 2014

    do u think the amp has to be replaced?

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I need Behringer TRUTH B2092A Subwoofer service manual(circuit diagram). Please help...


You should contact Behringer customer service directly for the sevrice manual.

Sep 09, 2015 | Behringer Truth B2092A Studio Subwoofer...

1 Answer

Bx10s has a hum even with no cables plugged in.


Hello,

Would you please provide more info? Such as does it plays music? does it blows fuses? because if there's music reproduction it maybe a cold solder at power supply capacitors, if just makes a hum and produces no musical notes then you can suspect your output module went out, let me know further information to improve help.

Oct 01, 2013 | M-Audio BX10S 10" Studio Monitor Speak

1 Answer

The Simmons SD5K keeps spontaneously playing songs, even when all I want to do is play my own stuff with the metronome! I turn on the metronome, set the speed, hit the pads a few times, and the music...


Press the "click" button and then set the tempo you want, press the "click" button again this will stop the metronimoe but is also sets the tempo in memory. The next time you press the "click" button it will be ready to go.

Anytime you press the tempo + or - it thinks you are trying to use the "Tap Tempo Function".

Jun 07, 2011 | Simmons SD5K 7Piece Electronic Drum Kit

1 Answer

I have recently purchased a set of M-Audio Studiophile BX8a Deluxe studio monitors. I can't register them for warranty because I can't find any serial number on the monitors or box that they came...


Call M-Audio and ask them about it... It is POSSIBLE that your speakers are counterfeit. It has been happening with high value audio equipment. There has been some failures of this product as well. Also contact the company you bought them from. There is a lot of grey market stuff on Ebay... I hope that wasn't your source.

May 30, 2011 | M-Audio Studiophile BX8a Deluxe active...

1 Answer

Phonic S715 "15" 2way


This speaker is not an active one. This means that it hasn't integrated amplifier, so you need an external one. The cable from the amplifier goes to the speaker. Remove the woofer in order to get access at the inner parts and check these points:
  • In case that there is a crossover present there must be a burned out coil or capacitance
  • In case the cable from the female jacks at the back panel goes direct to the woofer, there must be the woofer destroyed or the cable disconnected. Check the cables, it's less expensive than to replace the woofer.
Post me back if there is a crossover in use or it is direct connected and any other points of interest you came up, in order to guide you further.
In case of a problem or clarification or further details needed, don't hesitate to post me a reply before rejecting my answer.
If you are satisfied, rate my solution with the "thumbs" or (even better) add a testimonial.

Thanks and regards
Please kindly rate this solution
Stelios
direct fixya link: http://www.fixya.com/users/technical114

May 25, 2011 | Phonic S715 15 2Way PA Speaker

1 Answer

Hi, I have a problem with both of my Mackie MR8s. They both play really quiet, like ridiculously quiet with no low end at all. They don't make that "clicking" sound when you turn them on either....


The woofers were likely the problem in the first place. DO an ohmmeter check on them.

Note that the ohmmeter often doesn't work for testing piezo tweeters, but does work for the woofers with voice coils.

Feb 05, 2011 | Mackie MR8 150W 8 Active Two-Way Studio...

1 Answer

Hi There, i have a Marshall MG100 DFX Series Guitar Combo Amp,and when i plug my guitar in i get verry little,or no sound from the guitar imput,can you please help. Thank you.


Try exceriszing the connections for input and headphone jacks ( just be inserting qtr inch connector in/out of jack ) a few times. then plug back into your input. if that didn't solve anything while amp is on move the input jack around ( up, down, left, right, ) and see if this makes the signal cut in/out to normal playing. if so you just have broken solder connections on the jack. Also you may just want to test your Speaker to make sure no problems exise there. ( Voltmeter across + and - terminals ) prolly 8 ohms but will most likely state on woofer. if not of this fixes your problem let me know and i'll throw some more steps your way.

Jan 24, 2011 | Marshall Mg100dfx 100-Watt Combo Guitar...

3 Answers

My guitar string is broken but it's on a electric guitar. please help me because my lesson is in october


does that guitar still has warranty? where did you bought it? try to go to music repair shop and consult it. they will help you bigtime. promise. i hope i helped you even a bit. thanx

Sep 13, 2009 | Yamaha Electric Guitar

Not finding what you are looking for?
M-Audio Bx8a Deluxe Power Studio Monitors New Overstock Logo

49 people viewed this question

Ask a Question

Usually answered in minutes!

Top M-Audio Music Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Vito Vacirca Jr.

Level 2 Expert

140 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a M-Audio Music Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...