Question about Hoover Vacuums

Open Question

Dismantle a hoover 5110 heritage

No suction through to dust canister, I need to dismantle to unblock.

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

ukvacfan
  • 328 Answers

SOURCE: My Hoover is picking dust , very poorly

The Telios has a bad design on the handle and it sounds like something has definately got stuck. Unfortunately the nature of the cheap European design means the handle can only be removed by someone who owns a vice in their garage without breaking the removal points. Alternatively find a long bamboo stick or pole to put inside the hose mount which connects normally from the main bin of the Telios (not the other way around up the handle) which has no sharp edges and push up and down vigourously to dislodge any clogged dirt which may have inadverntely got stuck either by the handle or in the hose itself.

Another thing to do is to check the suction from the Telios itself by removing the hose. If there is suction coming from the main dirt bag/bin door with the hose removed then there is no problem other than a clogged hose and handle. Hoover updated the handle and hose in 1999 and spares can be found by looking on Ebay.co.uk for cheaper prices.

Posted on Nov 16, 2007

reddevil6
  • 1673 Answers

SOURCE: Poor suction-need to know how

I assume this is a Hoover Bagless, if poor suction, the hose or dirt inlet by the brush roll may have a clog. The filter inside the dirt container may need replacement. Some had a screw to take out to remove the cover for the filter, the one under where hte dirt container sits. Alos the belt may be stretch and won't turn the brush roll under load. Having the model number would help.

Posted on Apr 20, 2008

  • 1 Answer

SOURCE: Dyson has lost suction and loud noise from base(?),

I had the same problem, from right out of the box. Now that I just threw mine out, I see this site that indicates there's a fix for it:
http://ths.gardenweb.com/forums/load/cleaning/msg0415060828462.html

And search for other sites isung "dyson grinding" or similar.

Since I was an early adopter (had one as soon as they came stateside), I did not have the benefit of countless others having the same problem, I just attributed it to a junky design, since so much else about this vacuum was poorly designed, like the seals, hoses, etc.

Give them a call, and good luck! I might rescue mine from the heap and do the same.

Posted on Apr 08, 2009

  • 34 Answers

SOURCE: no suction throught the hose

sounds like its blocked stick the broom handle thru it , there might be something plugging the hose under the bottom at the connection

Posted on May 22, 2009

  • 5 Answers

SOURCE: I have no suction with my Hoover Mach 5 vacuum.

I had a similar problem. Two things to try. There is a lock symbol on the canister you need to ling it up with the mark on the top (the silver part has a line on it). It can be assembles 3 different ways. Also I over looked the sticker in the back of the canister compartment indicating a filter in the top of the canister compartment. There is an orange lever there to release the filter. Hope this helps.

Posted on Jun 18, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Top filter keeps clogging up??


Just make sure the rubber gasket is secure at the bottom of the dirt cup if it rides up the dirt will go straight up to the filters

here is the hepa that should be change when it is dirty


Hepa Filter Hoover U5780 WindTunnel Bagless 93002360

Dec 07, 2015 | Hoover U5780900 Bagless Upright Cyclonic...

1 Answer

Hoover floor mate h3000 will not suction water from floor when cleaning


Your collection canister may not be positioned tight enough in its place ment site. Tip machine back using foot pedal (as if you were going tio start using machine to clean) Insert collection canister (bottom container, then insert top canister with solution. The two canisters must be flush with machine side seams and must sit in position tightly. This is sometimes very tricky and may take a little elbow grease to make it click into place. Hope this helps

Jul 08, 2015 | Hoover Floormate H3000 Upright Wet/Dry...

1 Answer

We have a dirt devil that when the canister is engaged, it no longer has suction. The canister is empty. Thoughts?


you turned the switch to blow instead of suction








remember them days .. no .. i do

Jan 12, 2015 | Hoover Vacuums

1 Answer

Dust bag was full and have changed it but not getting proper suction since bag change - why?


The extension tube is probably blocked. Check for suction with all the tubes off - if there is suction now then the tubes are blocked - be carefull not to damage them if you poke things in the unblock them.

Feb 13, 2011 | Miele Revolution 600 Bagged Canister...

1 Answer

My daughter's S3765 bagless canister has good


That means that you need to replace the belt. Here is the belt you need for your model.

Hoover Windtunnel Canister Belt

Dec 20, 2009 | Hoover S3765-040 WindTunnel Bagless...

1 Answer

I vacummed some sheetrock duct up with my hoover elite cyclonic.. i dumped the canister to empty the dirt and dust, but now theres not as much suction... is there any other area I should be cleaning... or...


do not put the filter in water, it will ruin it. if banging out the filter did not work than you should probably replace it, sheet rock dust is very fine and will easily clog most filters.

Aug 20, 2009 | Vacuums

1 Answer

I have no suction with my Hoover Mach 5 vacuum.


I had a similar problem. Two things to try. There is a lock symbol on the canister you need to ling it up with the mark on the top (the silver part has a line on it). It can be assembles 3 different ways. Also I over looked the sticker in the back of the canister compartment indicating a filter in the top of the canister compartment. There is an orange lever there to release the filter. Hope this helps.

Mar 19, 2009 | Hoover U5194-900 Mach5 Multi-Chamber...

1 Answer

My Hoover is picking dust , very poorly


The Telios has a bad design on the handle and it sounds like something has definately got stuck. Unfortunately the nature of the cheap European design means the handle can only be removed by someone who owns a vice in their garage without breaking the removal points. Alternatively find a long bamboo stick or pole to put inside the hose mount which connects normally from the main bin of the Telios (not the other way around up the handle) which has no sharp edges and push up and down vigourously to dislodge any clogged dirt which may have inadverntely got stuck either by the handle or in the hose itself.

Another thing to do is to check the suction from the Telios itself by removing the hose. If there is suction coming from the main dirt bag/bin door with the hose removed then there is no problem other than a clogged hose and handle. Hoover updated the handle and hose in 1999 and spares can be found by looking on Ebay.co.uk for cheaper prices.

Aug 12, 2007 | Hoover S3330 / S3332 Straight Suction...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

45 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18387 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1456 Answers

Brad Brown

Level 3 Expert

15441 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...