Question about Car Audio & Video

1 Answer

Installed a kdc-u359w was working great then I inserted cd in and all power went out now can't get working have checked fuses but are ok what to do now

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 742 Answers

Check your wires and fuse on the system. Well have to remove system to check fuse in back of the unit.

Posted on Nov 15, 2014

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 27 Answers

SOURCE: kenwood kdc-x891 - bettery disconnected and

http://www.manualsonline.com/

type in your model number and this will give you the user manuals

Posted on Jan 29, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have a cadi cts 03 and my radio display when out cd still works and I check all fuses and there fine what could it be?


If the cd still works then it is just a bad display in the unit , replacing the unit would be cheaper than repairing it.

Nov 02, 2014 | Cadillac CTS Cars & Trucks

2 Answers

Kdc-x993 - power to head, but no display when face is installed. the cd eject button is blinking but when i install the face, the display will not come up.


you dont have power to the ignition wire on the radio(red wire) the yellow wire should have constant power(12 volt) check your radio fuse in the fuse block on the car or on the red wire itself

Jan 23, 2010 | Kenwood Car Audio & Video

1 Answer

I turned down the volume on my kdc-mp522, when i went to turn it back up, it was off (I did not stop or turn car off.). I cannot get it to power on, i can insert and remove disc, so there must be power,...


that is kind of strange and if your getting power to put a cd in but no for it to fully power the unit you may need to check another fuse it will be not be your radio fuse but instead a mini fuse in your vehicles cabin should be on the left side under neith the dash or on the side of the dash it will most likely be a 10 or 15 amp mini fuse that supplies power from the fuse box to the reiceivers acc source ignitions source

Nov 11, 2009 | Kenwood Sirius KDC-MP522 CD Player

1 Answer

No power


blue wire goes to remote on your amp. You blew the radio fuse but also check the dome fuse and see if that went out. GOOD LUCK

Sep 12, 2009 | Kenwood KDC-MP528 CD Player

1 Answer

Kdc-422


i have the same radio and it was acting funky all of a sudden, i just disconnected the power wires to it for a few minutes and re-connected and all was ok and has been for about a year now. hope this helps.

Aug 09, 2008 | Kenwood KDC-422 CD Player

2 Answers

Power problems with my kdc-x789


It should be taken back to the installer.

Oct 06, 2007 | Kenwood Excelon KDC-X789 CD Player

1 Answer

Kenwood KDC-519 CD Player


Check ribbon cable from main board to face for breaks in the lines. Replace ribbon cable if bad.

Aug 01, 2007 | Kenwood KDC-519 CD Player

2 Answers

No Power to face plate


Hello James,You missing a Major supply to the Face,Take a Test lite and Ck to see if your getting voltage on the Memory wire Also ck Fuses ttech

Jul 20, 2007 | Kenwood KDC-2019V CD Player

1 Answer

Face plate wont move


First check the power fuse as well as the stanby or always on fuse. then if that does not work Try to disconnect the power and standby line and let the unit reset . This should be done for at least an hour or so.. Good Luck

Jul 25, 2006 | Kenwood KDC-7009

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

46 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4848 Answers

yadayada
yadayada

Level 3 Expert

75817 Answers

The Knight
The Knight

Level 3 Expert

74118 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...