Question about Sony XM-2150GSX Car Audio Amplifier

1 Answer

I have Sony XM-2150GSX amp on offset cant get it off

My amp has worked fine for while but few days ago stopped working gets power but then switches to offset and wont power subs, checked all fuses and wiring all good and proper but still cant get to work

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 113 Answers

Check for a short on one of the edges or a resistor on the edge of the board

Posted on Jul 04, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Radio quit working


Sounds like someone shorted the wires...you need to look into the entire butcher job and see what wires were touched. Disconnect everything the butcher did and then see if your battery is still drainning power.

Dec 03, 2013 | 2006 Chevrolet Malibu

1 Answer

I have an XM-2150GSX 760watt sony amp, ive gotten everthing hooked up to it, but for some reason i have power to the amp but not to the subs, i know the subs are good still (i hooked them up directly to...


If you are hooking 'blue wire' (remote turn on for amp) to the power antenna wire (usually also blue) from the radio that could be your problem since the antenna only gets power when the radio is used

try using the switched 12 volt wire you used to connect your stereo power

i will assume all other wiring is correct and if so this should fix your issue - if not write me back with as many details as you can about how you have things wired and i will try to help more

good luck!!

Apr 15, 2011 | Sony XM-2150GSX Car Audio Amplifier

1 Answer

Overcurrent lights comes on whenever my amp is on


this can only mean 2 things, either your over working the amp, which means your amp is trying to push power that it don't have, and it's getting hot which is known as thermal mode. and the other reason can be that make sure amp rms. matches the rms. of your subs.

Mar 13, 2010 | Sony XM-2150GSX Car Audio Amplifier

1 Answer

When i turn my amp up it goes into over current / offset mode and doesnt come back on until i turn the radio off and turn it back on


ive never liked xplodes it always did that to me..check youre wires make sure they are the correct gauges...if you buy an amp always buy from a dealer and make sure they install it correctly ...

Feb 21, 2010 | Sony XM-2150GSX Car Audio Amplifier

2 Answers

JBL amp, worked fine untill 2 days ago. protection light on..


might have roasted your speakers voice coils a little which may be sending the amp into protect mode throw a speaker on it that you know works and if it doesnt trigger the protect circuit then you probably have a blown or almost sub.

Jan 02, 2010 | JBL BP1200.1 Car Audio Amplifier

1 Answer

Amplifier keeps running overcurrent


sounds to me like you are overheating the amp, try down tuning the peak level of the amp, and also if there is anything around the amp clear it away, check if the fan is turning on, you may need to replace it,

May 20, 2009 | Sony XM-2150GSX Car Audio Amplifier

1 Answer

Amp doesn't come on


Hello rheabarb,

You did not say whether or not you checked the wiring going to your subs. Many times, a shorted or grounded speaker wire will cause an amp to fail. And if the amp powers up OK with the subs disconnected, I'd suspect one or more of the wires.

Hope this helps.

May 19, 2009 | Clarion APX1300 Subwoofer Mono Amp - 300W...

1 Answer

Sub cutting out


Check the 12v wire running from the battery to the amplifier. Also the sony explode is a garbage subwoofer compared to the Alpine.. sony (they say 1200w max but its more like 100w to power the thing) Amp could be going. Is the amplifier hot when running. If there is a burnt smell comming from the amp, its the amplifier

Mar 27, 2009 | Alpine Type-R SWR-1222D Car Subwoofer

1 Answer

I am trying to wire and bridge a sony marine 600w sony marine amp


as long as the speakers are wired in parallel it should be ok dont wire them in series as they will overload the amp it is designed to run at 4 ohms

Feb 13, 2009 | Sony XM-2150GSX Car Audio Amplifier

Not finding what you are looking for?
Sony XM-2150GSX Car Audio Amplifier Logo

Related Topics:

692 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

xxxxxx xxx

Level 3 Expert

4981 Answers

The Knight
The Knight

Level 3 Expert

75786 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...