Question about Sony XM-2150GSX Car Audio Amplifier

1 Answer

I have Sony XM-2150GSX amp on offset cant get it off

My amp has worked fine for while but few days ago stopped working gets power but then switches to offset and wont power subs, checked all fuses and wiring all good and proper but still cant get to work

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 113 Answers

Check for a short on one of the edges or a resistor on the edge of the board

Posted on Jul 04, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have an XM-2150GSX 760watt sony amp, ive gotten everthing hooked up to it, but for some reason i have power to the amp but not to the subs, i know the subs are good still (i hooked them up directly to...


If you are hooking 'blue wire' (remote turn on for amp) to the power antenna wire (usually also blue) from the radio that could be your problem since the antenna only gets power when the radio is used

try using the switched 12 volt wire you used to connect your stereo power

i will assume all other wiring is correct and if so this should fix your issue - if not write me back with as many details as you can about how you have things wired and i will try to help more

good luck!!

Apr 15, 2011 | Sony XM-2150GSX Car Audio Amplifier

1 Answer

Overcurrent lights comes on whenever my amp is on


this can only mean 2 things, either your over working the amp, which means your amp is trying to push power that it don't have, and it's getting hot which is known as thermal mode. and the other reason can be that make sure amp rms. matches the rms. of your subs.

Mar 13, 2010 | Sony XM-2150GSX Car Audio Amplifier

1 Answer

When i turn my amp up it goes into over current / offset mode and doesnt come back on until i turn the radio off and turn it back on


ive never liked xplodes it always did that to me..check youre wires make sure they are the correct gauges...if you buy an amp always buy from a dealer and make sure they install it correctly ...

Feb 21, 2010 | Sony XM-2150GSX Car Audio Amplifier

1 Answer

Amplifier keeps running overcurrent


sounds to me like you are overheating the amp, try down tuning the peak level of the amp, and also if there is anything around the amp clear it away, check if the fan is turning on, you may need to replace it,

May 20, 2009 | Sony XM-2150GSX Car Audio Amplifier

1 Answer

I am trying to wire and bridge a sony marine 600w sony marine amp


as long as the speakers are wired in parallel it should be ok dont wire them in series as they will overload the amp it is designed to run at 4 ohms

Feb 13, 2009 | Sony XM-2150GSX Car Audio Amplifier

1 Answer

Need a lil ore help!!!


If the overcurrent of DC offset lights are not green, the amplifier probably has blown output transistors.

To eliminate other problems, disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up normally (all lights green), the wiring needs to be checked. If it still shuts down, the amp likely has blown output transistors.

Jan 05, 2008 | Sony XM-2150GSX Car Audio Amplifier

1 Answer

My sony xplod XM-2150GSX amp has a problen whenever i turn up the volume on my radio the amp turns on the current overload LED cAN enybody help me out i opened it but i just cant seem to find the problen...


Often this is related to speaker wiring. Make sure your speakers aren't below the minimum rated impedance for your amplifier; 2 ohms per channel, or minimum 4 ohms in bridged mode. If you have two 4-ohm subs, you can't run them both in bridged mode if they're wired in parallel. If you have a blown sub, it can cause this problem also.

Jul 30, 2007 | Sony XM-2150GSX Car Audio Amplifier

2 Answers

Amp overcurrent problem


Disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If it still shuts down (overcurrent), the amp likely has blown output transistors.

Sep 20, 2006 | Sony XM-2150GSX Car Audio Amplifier

Not finding what you are looking for?
Sony XM-2150GSX Car Audio Amplifier Logo

Related Topics:

686 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4848 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Philip Rowney
Philip Rowney

Level 2 Expert

94 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...