Question about Tannoy Precision 6 Speaker

1 Answer

One of a pair of tannoy 6 D studio monitors went out with a loud buzz and now does nothing when I turn it on. No LED light ? No Sound.

Posted by on

  • qwicksand888 Jul 09, 2009

    Thanks for your help. There actually was a fuse that I found that burnt out. I was extremely happy to found replacement fuse in a little compartment in the back of the monitor. However as soon as I replaced the fuse same thing happened again. Loud buzz, the new fuze blew right out. Do you think there is a short in the power supply somewhere or possibly a blown transistor or something?

    Any more help will be greatly appreciated.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Speakers don't cause a loud buzz but amplifiers do. Is it possible that the input to the amp lost it's ground? Regardless, this is not why the speaker does nothing but you would want to correct any amplifier problem before hooking up another speaker. If as you say, absolutely nothing happens it is possible that you blew out the voice coil of one of the drivers but blowing out both the woofer and tweeter simultaneously would be unusual, not to mention that Tannoys can take quite a bit of guff. So the next possibility is that there is a problem internally with the crossover or,and I doubt that it exists, and internal fuse associated with it. Since there is an LED (and I don't know what purpose it serves) there has to be some sort of power supply (fused?) to activate it. It could be derived from the audio output of the amp but it would then pulse on and off rather than just be constantly on. Getting inside the unit with an ohmmeter would quickly determine what's going on but I don't know how this can be meaningfully diagnosed at arms length and therefore just can give you some generic ideas.

Posted on Jul 03, 2009

  • greensal Sep 10, 2009

    Sorry but I have not been back to this site since I first posted this message so I expect this addendum is to little too late nonetheless...............
    Guaranteed you have a problem in the amplifier, Not the power supply but in the specific audio channel as the other channel works. It would be folly to suggest any particular cause as it could be anything from a lifted ground to a blown capacitor to a blown transistor (or combination or multiple of the above). At this point you need a competent tech to sort it out. Depending on the quality of the unit and the cost of repair it may be advisable to get a new unit (I hate to give such advice as I'm a firm believer in fixing things but sometimes a specific situation dictates otherwise..


×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Rca grounding sound with samsung smart tv


I see you are using wireless speakers. The biggest problem with the residential grade is everything interferes with them. Make sure you are moved as far away from power sources as you can be. Direct line of site is not optimal but a fix as well. The wire you have connected for the send receive could be the issue as well. a shielded heavier AWG will help as well as grounding from the source equipment and dropping the ground on the other side.

Apr 13, 2014 | Parrot Zikmu Wireless Stereo Speakers by...

1 Answer

Monitiors are not turning on


Have you tried to use these on other devices, like a DVD Player, etc.? If you get a HUMMING noise with other devices then the internal amplifier is defective and you are not getting sound production to the speakers. If you have separate power AMP and the speakers hum when connected, they may have been damaged. If you have a speaker mismatch; they tend to buzz, thus too many conditions could represent the humming. Check that the Positive and Negative polarization of the speaker wires are correct.

Jan 14, 2014 | Numark NPM5 NPM-5 - Active Studio Monitors

1 Answer

Hi my name is Doug , I have a question for you and hope you have an answer for me. I have an old Vintage pair of Tannoy Silver 15 inch Drivers from the early 1950`s. They both sound great and perform...


The cone keeps the dust out of the voice coil, I do not see a problem with you going ahead and replacing with the newer version, the sound will keep it's original composition that you can expect from Tannoy.

Mar 10, 2011 | Audio Players & Recorders

1 Answer

My behringer b203a is making a loud muffle mono feedback sound when i am trying to use it. what could be the problem? please help!


this is normaly a wiring or amp issue. if it was the speakers they wouldnt make any sound or they would crackle or buzz

Jan 31, 2011 | Behringer B3031A 2-Way Active Studio...

1 Answer

Pop and Hissing after turning on Tannoy 6D


It happens, don't be upset. Call Tannoy and get an RMA # . They will repair under warranty. When you get it back it will be as good as new. Rob

Feb 27, 2009 | Tannoy Reveal 6D Speaker

1 Answer

I am not very technically literate with respect to audio/video. I purchased a Cambridge Audio Azur 840a V2 Integrated Amplifier last week to replace an Arcam A70. I have a pair of Tannoy DC3 speakers, as...


get an Ohmmeter, take a reading on each speaker line one at a time, on both A & B speaker lines. You should get a reading of 8+/- ohms. The speaker switch with the 6 spks will probably read almost 0 ohms when all 6 are running. That is what your amp is not liking. Try running it with one set of speakers on the switch,with the Tannoys on ch A on your amp and the switch on B. add one pair of the 6 at a time and you'll see that it won't like all 6 at once. 2, maybe 4, at a time is probably what you'll find to work.
Good Luck.

Dec 18, 2008 | Cambridge Audio Azur 840A Amplifier

1 Answer

Sound has turned into a loud buzz


check,probably you change the sound module or if you can work efficiently on the module ,u change the sound ic & the entire electrolytic capacitor within the circuit.

Oct 05, 2008 | Akai LCT3285TA 32 in. LCD Television

Not finding what you are looking for?
Tannoy Precision 6 Speaker Logo

301 people viewed this question

Ask a Question

Usually answered in minutes!

Top Tannoy Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5047 Answers

shaqsatin

Level 1 Expert

18 Answers

Rob
Rob

Level 2 Expert

62 Answers

Are you a Tannoy Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...