Question about Blenders

1 Answer

Krups blender blade stops

I have a Krups Power Xtreme VI blender that refuses to blend. While making a daquiri one night my sister noticed a burnt rubber smell so she unplugged the blender and took the jar off. The small grey rubber gear that turns the blade had stripped itself almost completely groove free. I went online and found a replacement gear and a replacement blade. I thought it couldn't hurt while I had it apart right?
As soon as the parts came in the mail I went online and got directions on how to replace the gear and the blade. After I put the blender back together I plugged it in and saw that everything was spinning as it should be. Later that night I had to try it out so I threw mix and ice in to make a drink and the blad stopped spinning. It would spin for a second then stop. I emptied the jar and turned it back on and the blade spun just fine. The gear is not stripped at all and I hear the motor running just fine. But everytime I put anything in the jar the blades stop spinning. I wonder if there is something else wrong that caused the gear to get stripped in the first place. Any ideas at all I would really appreciate. I'm dying for a drink!!

Posted by on

  • Wendi Cleveland Jul 06, 2009

    Okay, I was trying to follow this advice and take the gear back off and recheck everything when I noticed another symptom. I inserted a small screwdriver into the bottom to hold the shaft still while I turned the gear just as I had to remove the old one and put the new one on. The gear continues to move but the shaft stops. The strange thing is that the shaft moves along with the gear until any resistance is applied. Just to make sure I wasn't seeing things, I plugged the blender in and while holding the gear with a towel, turned it on. The gear wasn't moving but the shaft was.
    So here's the situation. The bottom cannot be taken off until the gear is removed. I cannot remove the gear because I can't keep it from turning. I am open to any ideas at this point because right now it is useless to me.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 245 Answers

Well it looks to me there is some thing not tight enough connection to ur blade.....as u say it works when empty but when u put soemting in its stops....this means ur blade is not tight on the shaft to the motor......or u may have done something wrong when u had the blender open........recheck ur work and make sure its tight,,,,,
if so u will have ur ice cold drink....cheers i hope so for ur shake

Posted on Jul 03, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

O RING 574


There are 4 Krups 574 models, the seal shows as obsolete for 2x of them and still current for the other 2x

Part number for the seal that is current is MS 0974091

Apr 19, 2014 | Krups 574 Power Xtreme VI Premium Work Top...

1 Answer

Part number and price


You have to contact the manufacturer for that kind of information. We do not have part numbers or prices. We do not sell any parts.

Feb 23, 2014 | Krups 574 Power Xtreme VI Premium Work Top...

1 Answer

Teeth sheared off the rubber drive gear on Krups Blender Style 572. Have ordered part and need installation instructions


take a flat head screw drive to the bottom of the blender and us it to hold the blender shaft in place while you turn the gear by hand or with a plyers (it is reverse threaded) and it should spin right off. when you get the new on it should spin right on.

Aug 12, 2011 | Krups 572 Power Xtreme VI Work Top Blender

1 Answer

Hello, I ordered a replacement coupling gear(?) and need to figure out how to replace it. This is the little grey plastic gear that attaches to the base unit causing the blade to spin. Here are some...


Hope you have solved your problem by now, but put a flathead screw driver in the bottom of the blender to hold the blender shaft in place then turn the gear by hand or with a plyers and it should just screw off, it is reverse threaded...

Jul 14, 2011 | Krups GMA1-42 Power Xtreme VI Work Top...

1 Answer

WHEN i PUSH ANY BUTTON TO TURN IT ON, IT WORKS FOR A FEW SECONDS THEN IT STOPS, i HAVE TO UNPLUG IT AND SHAKE IT, IT WORKS FOR ANOTHER FEW SECONDS THEN IT STOPS AGAIN. wHAT CAN i DO TO FIX IT?


Sounds like the brushes are not making good contact or you have a defective switch. Run the blender witout the container or blades . Free run it for 5 minutes id you can and see if that helps.

Oct 20, 2009 | Krups 574 Power Xtreme VI Premium Work Top...

2 Answers

Krups Type Blender 577


Mine did the same thing. I am ordering a new one from America for around $5.
http://www.abtecparts.com/index.htm

I am in Australia and they deliver worldwide.

Caz

Jun 12, 2008 | Krups 572 Power Xtreme VI Work Top Blender

2 Answers

Krups 572 Power Xtreme VI Work Top


Repairing the blender:
My guess: You worked the motor too hard on your last blending session and it overheated. That will cause a thermal fuse inside to cut off. The blender won't work again until you replace the fuse but otherwise it should be fine. The fuse looks like a white diode and it will be attached tightly to the motor with a nylon strap (so that it can pick up the heat of the motor). The leads to the fuse are shielded with heat resistant nylon wrap. You will need to remove the rubber drive gear in order to remove the plastic house so you can work, although if you are really handy you might be able to at least test the unit by only removing the plastic bottom on the base unit.

To remove the plastic housing, remove the little rubber feet and then remove all of the screws on the bottom of the unit. You may need to buy a bit set for tamper resistant screws (I ***hate*** those), I don't remember. When the bottom is removed, you will see that the there is a screw head on the bottom of the central motor shaft. You can use a screw driver here to hold the motor from turning, then you can carefully use a pliers to unscrew the rubber drive gear on the top of the base unit (try not to damage the rubber). With the gear removed you can get access to the wires.

To test the fuse unit, just check its continuity. Short=good, open=bad. To further test, short out the fuse with a jumper cable and your blender should work.

EPO (Electronics Parts Outlet) in Houston, TX, has the replacement fuse unit. I don't know that they like mail order.

May 13, 2008 | Krups 572 Power Xtreme VI Work Top Blender

Not finding what you are looking for?
Blenders Logo

Related Topics:

414 people viewed this question

Ask a Question

Usually answered in minutes!

Top Blenders Experts

eyecam

Level 2 Expert

87 Answers

yadayada
yadayada

Level 3 Expert

75822 Answers

Ross Keen

Level 3 Expert

1231 Answers

Are you a Blender Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...