Question about Alpine CDA-9856 CD Player

1 Answer


When i got my car from the car wash, the sound wasn't working. I tried a few things but nothing. The displays works but no sound.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: RADIO IS ON BUT NO SOUND..... - Alpine CDA-9856 CD Player Car Audio Receivers

The amp quit working on the cd player

Posted on Nov 17, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

No sound

Hi and thank you for using fixya:
If your vehicle has been stored for a year the first thing I will suggest are the followings:
1-check all fuses 2-check radio speakers connection 3-see if you have a internal fuse in radio cables 4-try with another radio
thanks, good luck

Jun 03, 2010 | Pioneer DEH-P3800MP CD Player

1 Answer

My crossfire radio with nav is working but has no sound. Any clues ?

Sorry, no answer. But you're not alone, my 2006 is displaying the same issues; everything works, just no sound. Used to take a few minutes for the sound to start after turning on car, time increased to point that it the sound just doesn't work at all. Clicking noise is noticable when system is powered on.

Nov 18, 2009 | Crossfire Chrysler &SRT-6 Navigation Radio

1 Answer

KRC-703 display does not work, sound does?

Check to make sure the right face came with your unit, I had an alpine once that did the same thing when I accidentally grabbed my friends face plate. Everything worked but the LCD. Check the model numbers to compare

Jan 31, 2009 | Car Audio Receivers

1 Answer

Attenuator light always on... no sound

That light that stays on is not for the "ATT", it is just an indication that the unit has power. The problem with your radio is most likely the power amp IC inside the radio if you are using speakers connected directly to the radio from the speaker wires on the harness. If you are using an external amplifier for your speakers the problem will be either the electronic volume control IC or a muting transistor that has gone bad or the external amplifier is defective. There is no way to know exactly what is wrong without doing a few checks on the radio with a multimeter on have the radio on a work bench to be able to open it up and check a couple of things inside of it.

If you have a multimeter and a power supply (to turn the radio on while on a work bench) I can guide you thru the troubleshooting process to help you figure it out. But you will also need to have a soldering iron, solder, and solder wick to be able to remove the bad part and put in a new part.

Let me know if you will require any more help from me.


Oct 19, 2008 | Kenwood KDC-MP7028 CD Player

1 Answer

Display not working

i have the same unit and when i bought it, the thing that caught my eye 1st was 30,000 hours of use. mine has been back to pioneer usa 3 times thus far. and that was one of the things that was fixed. fortunately, that was under the extended warranty that i purchased.

Aug 05, 2008 | Pioneer AVX-P7300DVD

1 Answer

95 ford probe wiring harness. no sound but turns on

Hey I cant help you with your problem but can you help me? i have a 95 ford probe with a metal ended square harness on it, i went to canadian tire 100 times looking for the right harness and none fit it. a couple months later I had found another harness connector a few inches don't from the other square one.Now before i found that one i cut the harness and tried manually connecting them to the new radio. The radio would turn on but now sound would play.... and i tired 9 colour codes still nothing. if you have any idea about my problem it would be much appreciated thanks.

Jun 25, 2008 | Car Audio Receivers

2 Answers

Car radio not working

Sound like you need the manual to this radio, I would have said that there are components inside that go bad that will cause a radio not to light up in the display area. But if you radio is saying tuner, and maybe cd then it would be the selector button that has a problem. Or no antenna is hooked up or come apart.

Sep 11, 2007 | Sony CDX-L480X CD Player

1 Answer

Volume, Display and FM stations missing?

This could be a bad ground on the radio, or you have serious circuit problems. if a fuse blew, the radio would not work at all. Check the installation first, replace the radio seconds. Good Luck

Jul 29, 2007 | Sony CDX-L420V CD Player

Not finding what you are looking for?
Alpine CDA-9856 CD Player Logo

Related Topics:

138 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio Receivers Experts

xxxxxx xxx

Level 3 Expert

4679 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you an Alpine Car Audio Receiver Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides