Question about Alpine Type-R SWR-1042D Car Subwoofer

2 Answers

I have a set of Alpine Type R 12 inch subs... I have a 1500 watt amp powering them but when I turn the music up, the bass cuts out. Where should I start looking for the problem?

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 16 Answers

Ground is loose(most likely amp), battery running low, subs might be damaged? feel free to keep me in touch if problem occurs more after checking grounds and power source and subs. Also might need to re-tune your head unit and amp?

Posted on Jul 03, 2009

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

How can i conect 3 alpine type r 2 ohms each at hiffonics brutus 1500

Posted on Sep 16, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What amp would be better to use with what speakers/sub? I have a KAC-7202 kenwood 920W maximum power (150wX2 RMS, 4ohms) (230wX2 RMS 2ohms) and then the other amp I have is a Alpine MRP-M500 mono power...


I'm using that Alpine right now for 2-12" subs and I have compared it to 6 or 7 other amps this month and most were 4 channel 150Watt/Channel Bridged to 300Watts x 2 and found the Alpine to be superior in both sound quality and loudness. The Alpine has also not turned off even with full volume for hours at a time, Very solid amp I was very surprised due to it's size!

Apr 04, 2013 | Kenwood Car Audio & Video

1 Answer

I have 2 12in kenwoods and a 1200 watt pyrimade amp, how can i hook these up to be the loudest


1st have your subs facing inwards towards the front of the car, not facing out the boot, This creates a better bass.

Wire 1 sub to one channel and the other sub to the other channel.

Turn down your gain as low as possible and then power everything up.

turn volume to desired loudness and then start turning up the gain slowly, if distorts a little turn in back down a notch.

avoid using bass boost, I agree it sounds great but it puts more strain on your amp and shortens its life.

after sorting out your gain, tweak all others until sound is bassy and clear with no distortion.

If you would like to use bass boost, turn on bass boost first, then up your gain etc.

Jan 16, 2013 | Pyramid PB915X 1200 Watts 2 Channel...

1 Answer

Need more bass


Bridge it. Should be marked on amp. According to specs should get u the power u need. Amp max 1500 watts. at 2 ohms. Speaker max is 2200 watts at 4 ohms. Turn amp down and adjust to your own taste. trust your ear man.

Jul 12, 2009 | Car Audio & Video

1 Answer

Settings for a Sony Xplod 1200 watt amp, with two 12 inch subs


What kind of subs are you running? Meaning what brand, what are the ohm, spl and wattage? I'll look up your amp while you get that info to me. Looking forward to helping you:) Thanks!

Apr 08, 2009 | Sony Xplod 1200W Class AB Bridgeable 2-Ch....

2 Answers

Alpine subs not hitting hard


could it be as simple as bass boost??? maybe you have the subs hooked up wrong... have to have the ohms right.....hopefully this helped

Jan 26, 2009 | Pioneer GM-X962 Car Audio Amplifier

3 Answers

Adjusting wattage on kenwood kac 9103 class D mono amp


That amplifier is 900W x 1 @ 2ohms.
If your subs are 4ohm SVC wired Parallel, resulting in a 2 ohm load, each sub will only see 1/2 of the rated power. (450W ea.)
Your gain (sensitivity) setting should be between 75% and 85% to max. You will be fine.

Jan 02, 2009 | Kenwood KAC-9103D Car Audio Amplifier

2 Answers

Amp cuts off


You may have a problem with the power source feeding the amp. You need to check the voltage across the amplifier's B+ and ground terminals when the amp is playing/cutting off. If it's dropping below ~11 volts, you need to determine why it's dropping so low.

Sep 18, 2007 | Alpine PDX-1.1000 1000W x 1 Car Amplifier...

Not finding what you are looking for?
Alpine Type-R SWR-1042D Car Subwoofer Logo

Related Topics:

270 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4885 Answers

hoyzee1

Level 2 Expert

150 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...