Question about JBL CREATURE II Computer Speakers

1 Answer

Still sounds like my speakers are in mono

I got my speakers 2 days ago and it sounds like they are in mono. One of the channels is really quiet/non existent so elements of some songs just aren't coming through.

I have checked the wiring
tried adjusting the equalizer in itunes
tried adjusting sound output in System Preferences

I use an imac G5

Please help!

Posted by on

  • adampjones Jul 02, 2009

    Thanks for your help boss! Relaunched finder with the speakers on then reconfigured output settings as suggested and that seems to have done the trick :)

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,179 Answers

Make sure that the speaker config is set to stereo or surround, depending on speaker capabilities. Once you run the speaker config in sound devices you should be all set. Hope this helps.

Posted on Jul 02, 2009

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a QSC RMX 2450 in which both channels are driven even though the amp is in stereo mode and I am only sending a signal into input channel one. It acts as if the amp is in parallel mode but I have...


My thoughts are that the amp has a poor channel separation but usually you can only hear a very quiet trace of the sound through the undriven channel. I agree with Taurus and make sure that the switch is making contact and moving all the pins to the proper points. This is a Home stereo amp, it comes with an extended 6 year warranty if you register it, I would check into getting a warranty repair before doing anything to it! Looks like a nice quality piece, those dip switches are a little bit confusing but the way it's built it is necessary to have them. It has a Dual Mono amp section so there is no way that any sound can be crossing over unless the swithches are directing it. The only way that can happen is in Parallel or in Mono. You could be in Stereo / Mono which would input both channels and output 3 settings a 1, 2 in Stereo & a Mono, Try hooking a speaker up to the Mono/ Bridge outputs and see if it's louder than just hooked up to 1 or 2. Parallel inputs will give you Mono 1 & 2 with Bridge off, and might give you Mono 1 & 2 with a bridged Mono if the bridge is on, like 3 channels all mono with one getting twice as much power as the 1 & 2 will put out. Although they have it labeled to not use it in those settings it's possible to do. I can see why you would be checking the switches.
It may actually be labeled incorrectly , as strange as it seems, many Chinese products have been made with labeling errors. Plus and minus have been wrong on Asian Made car amps so it's not that inconceivable that this may have some incorrect settings shown?

Apr 03, 2013 | Car Audio & Video

1 Answer

Have a fender squier 4 and wondering if you plug one side can you get full mano output?


What do you mean by "Plug one side"? Your guitar is mono....you plug into the channel with a mono signal cable....as long as you're panned to center on your channel strip, you would have full mono sound out...ie sound equally from both speakers. Usually you would be running your board in mono anyway.

Aug 17, 2012 | Fender Squier 4-channel Travel PA...

1 Answer

Some DVD's sound fine whilst others have background sounds but no voices. I do have an old model TV that has mono sound.Would that cause it?


" Some DVD\'s sound fine whilst others have background sounds but no voices. I do have an old model TV that has mono sound.Would that cause it? "
Hi,
I wrote a short article for someone who had a similar problem a few days ago.
I will edit it for you so that it fits. Here it is.
Your DVD player should have output connectors in the back of it to plug your amplifier or receiver into. If you have a Stereo system (no surround sound speakers, or front center speaker) connect the DVD Audio Cables on the back of the DVD player to the STEREO (or MIXED ) Output Jacks. If it is connected to the Left Front and Right Front jacks of the "Surround Sound" output jacks instead of Stereo(or MIXED) then the dialog will be sent to the CENTER channel output. If you have no center channel speaker you will not hear it. Thus no dialog.
NOTE: In your case for the TV that is mono, here is the solution.
1 Connect a stereo pair of RCA cables (red and white "male" connectors at each end) to the Mixed or Stereo Output of the DVD player (NOT ANY SURROUND OUTPUTS).
2 Purchase an RCA type "Y" connector that has 2 female to a single male connectors on it. Walmart about 3 dollars.
3 Plug the single male plug of the Y connector into the back of the TV set's single mono audio input.
4 Connect the stereo RCA pair from the MIXED output of the DVD player into the Y connector that is now on the back of yourTV.
5 Run your yellow Video output from the DVD into the Back of the Set's yellow input.
That should do it. The sound should be clear and correct with dialog, effects and music.
Hope this helps,
Best,
Mark

Jan 27, 2011 | Audio Players & Recorders

1 Answer

With a kenwood amp 1000watt 170rms x 2 ,how should i really wire these up!


You haven't supplied any model #s so its impossible to say - but Kenwoods don't normally like 2 ohm mono loads.

You're going to have to either use one channel @ 2 ohm... or use each subwoofer per channel on the amp.

For a 2 Ohm mono load - wire all positives and all negatives from each sub to the amplifier's respective (bridged) terminals.

Thanks for using FixYa - a 4 THUMBS rating and POSITIVE TESTIMONIAL is appreciated for answering your FREE question.

Oct 07, 2010 | Sony Xplod (P589) Car Subwoofer

1 Answer

There are many different "listening modes" integrated on my Kenwood VR-7070 6.1 channel receiver. But i only get both front speakers to work when in "mono" mode. Is there an easy fix?


There is not a "fix" for this selection, MONO is basically a single channel output so there is no seperation for various speakers like left or right which is a stereo effect, mono is like a single speaker sound so you are fortunate to have the sound from 2 speakers but they deliver the same sound.

Jun 10, 2010 | Kenwood VR-7070 Receiver

1 Answer

How do i install my L5 solo barics to a 2 channel amp if there is only one connection on the enclosure next to the vent? If I bridge the amp to 1x1000W will the power distribute evenly between both...


Option 1 (parallel) = 2 ohm load
Speakers wired in parallel
Recommended Amplifier: Stable at 2 or 1 ohm mono 2_4ohm_svc_2ohm.gif
Option 2 (series) = 8 ohm load
Speakers wired in series
Recommended Amplifier: Stable at 4, 2, or 1 ohm mono 2_4ohm_svc_8ohm.gif
Option 1 (parallel/parallel) = 1 ohm load
Voice coils wired in parallel, speakers wired in parallel
Recommended Amplifier: Stable at 1 ohm mono 2_4ohm_dvc_1ohm.gif
Option 2 (series/parallel) = 4 ohm load
Voice coils wired in series, speakers wired in parallel
Recommended Amplifier: Stable at 4, 2, or 1 ohm mono 2_4ohm_dvc_4ohm.gif Option 1 (parallel/parallel) = 0.5 ohm load
Voice coils wired in parallel, speakers wired in parallel
Recommended Amplifier: Stable at 1/2 ohm mono 2_2ohm_dvc_05ohm.gif
Option 2 (series/parallel) = 2 ohm load
Voice coils wired in series, speakers wired in parallel
Recommended Amplifier: Stable at 2 or 1 ohm mono 2_2ohm_dvc_2ohm.gif
Option 3 (series) = 8 ohm load
All voice coils wired in series
Recommended Amplifier: Stable at 4, 2, or 1 ohm mono 2_2ohm_dvc_8ohm.gif
Option 1 (parallel) = 2 ohm load
Speakers wired in parallel
Recommended Amplifier: Stable at 2 or 1 ohm mono 2_4ohm_svc_2ohm.gif
Option 2 (series) = 8 ohm load
Speakers wired in series
Recommended Amplifier: Stable at 4, 2, or 1 ohm mono 2_4ohm_svc_8ohm.gif
Option 1 (parallel) = 2 ohm load
Speakers wired in parallel
Recommended Amplifier: Stable at 2 or 1 ohm mono 2_4ohm_svc_2ohm.gif
Option 2 (series) = 8 ohm load
Speakers wired in series
Recommended Amplifier: Stable at 4, 2, or 1 ohm mono 2_4ohm_svc_8ohm.gif

Apr 09, 2010 | Kicker Solo-Baric L5 Car Subwoofer

1 Answer

How can i bridge a mtx 9500 using a mono amp?


You cant bridge it to the MONO AMP . You can only bridge subs & speakers to 2 CH & 4 CH AMPS that are bridgeable. Because if it appears that there is 2 channels on a Mono amp its so its convenient for you to hook up 2 4ohm subs to it easily But both channels are actually connect internally together in parallel inside the amp unlike a 2 channel they are separate.

So just connect your mtx 9500 to a plus and a minus and doesnt matter which since all the + terminals of are connected together and - are connected together already.

Whats important is on the side of the sub/box it reads 2 ohms. The lower the ohms the more power the Mono amp will put out. Mono amps are designed to handle 2ohm loads.

If it reads 4ohms The MONO amp is the wrong amp to use cause the power will be weaker. So if you have a 1000 Watt Mono amp at 4ohms the sub will only get 500 WATTS Max while a 2 ohm will get the full 1000 Watts.

If it reads 4 ohms connect it to a 2CHANNEL AMP and BRIDGE IT (connect + of the sub to 1st channels positive of the amp then connect - of the sub to 2nd channels negative of the amp) . The power will be doubled when you bridge it on a 2 channel amp. NOW if it was a 2 ohm sub and you bridged it to the 2 channel amp it will fry the subs and ruin the amp. 2 CHANNELS CANT TAKE A 2OHM LOAD BRIDGED OK.

Apr 08, 2010 | MTX (SLH-T7512X2-A) Car Speaker

1 Answer

Headphones and speakers are in mono


Sounds like the jack on the computer is worn, dirty or bent therefore not making good contact with the plugs. The solution is to replace the jack, which is labor intensive- mostly to get to it inside the case and then you need the part (jack) Soldering may be necessary.

Sep 03, 2009 | JBL CREATURE II Computer Speakers

2 Answers

Can this all be hooked up?


There was never anything mentioned about the 18 yamaha sub in the hook up process

Aug 17, 2009 | Crown CE1000 2-Channel Amplifier

1 Answer

Sounds like my speakers are in mono


Go into the control panel and choose a different speaker setup.

Jul 02, 2009 | JBL CREATURE II Computer Speakers

Not finding what you are looking for?
JBL CREATURE II Computer Speakers Logo

Related Topics:

304 people viewed this question

Ask a Question

Usually answered in minutes!

Top JBL Audio Players & Recorders Experts

Michael Edwards
Michael Edwards

Level 1 Expert

60 Answers

 Grubhead
Grubhead

Level 3 Expert

5190 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a JBL Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...