Question about Miele S548 Bagged Canister Vacuum

1 Answer

I was vacuuming and noticed that the bag needed changing. the red light with the ! inside the triangle also came on. When the bag was changed, the vacuum would not restart. The red light came on. Tried the reset button but nothing happened. Tried unplugging and re-plugging in and nothing happened. Replaced all the filters and still it wouldh't start. So I brought it downstairs and tried one more time to get it to start. it worked! Is there something wrong with the vacuum cleaner? Was it overheated because of the bag needing replacing? I can't find the manual but the vacuum says "Miele Aluminum" and it is a cannister. I have guessed about the product number below.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 75 Answers

It was overheated that is why it worked downstairs after cooling off.

Posted on Jul 02, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to fix sensor s12. red light for bag stays on even when vacuum bag is not full and the vacuum is clear


You most likely will need to change the Yoke assembly. There is a sensor built in that gets clogged with fine debris over time. This will take care of the problem.

Feb 09, 2015 | Windsor SR12 Sensor Bagged Upright Vacuum

4 Answers

I have a Windsor Sensor s12 and power shuts off after 5 min. of vacuuming. I'm wondering if it's overheating of if there is some other sensor that causes it to shut off.


Your Sensor most likely has an internal heat sensor that is shutting off the motor. Some vacuums install an external heat sensor with a reset button that you must push to re-start the vacuum. If your model does not have an external reset button it is most likely a sensor inside the motor. If it is defective the motor must be replaced to solve the problem. But first make sure the overheating is not being caused by a blockage somewhere or the bag is too full. Air must pass completely through a vacuum starting at the floor where it picks up the dirt through all the canisters, filters, bags, etc. and then is exhausted from the vacuum. Any restrictions or blockage can cause the motor to over heat.
That Vac Guy

Jan 04, 2013 | Windsor SR12 Sensor Bagged Upright Vacuum

1 Answer

I just changed my bag and now it is squealing and the red bar is in window?


It would seem that your vacuum is clogged, hence the change bag indicator. Pull the hose out and and remove at the swivel connection at the base of the hose.You can use a small flashlight to check the hose, lay the hose on the floor with the light at one end and look for light at the other end. I know the grip end is curved but you should be able to see some light. Check the rear port by removing the cover located near the base, on the rear side, close to the hose swivel. Unscrew the 2 plastic screws and lift out the cover; check for a clog here. Next lay the vacuum flat on it's front and shine the light behind the brush roll and up the short black internal hose. Facing the metal sole plate, the hose should be near the right corner. Good luck.

Jun 03, 2012 | Miele S7210 Bagged Upright Vacuum

1 Answer

The red light on my electrolux vacuum comes on and cuts power.


If the bag full light keeps coming on, you can first try adjusting the dial on top of the vacuum cleaner. If that does not work, then you need to change the control valve. This is an internal component of the canister and is directly below the dial. You will need to follow the instructions on a previous post to open the Electrolux plastic canister vacuum, and remove the bage cage. Once you remove the bage cage you can change the control valve, and this will solve your problem with the bag full indicator.

Mar 26, 2010 | Electrolux Guardian Bagged Canister Vacuum

1 Answer

Bag was full, changed it, the unit now turns off


Try dialing the control valve to the mid way position. If the unit still shuts down with the bag full light on you have a damaged control valve under the dial on the top of the vac.
This valve failure is common in this model and can only be repaired by someone with original AERUS Electrolux repair parts, generally at an AERUS repair shop.

Oct 29, 2009 | Electrolux UltraLux 2000 Bagged Canister...

1 Answer

I just notice when I went to change bag in my Kirby G4 that the whose inside was split open, which made all the dust fill up in the bag. How do I get a replacement part for this and what is that part...


You do not need a whole bag. The bag fill tube is replaceable. can be temp fixed with duct tape and new one installed at home. vacuum inside with another vac and you will be set to replace

Sep 07, 2009 | Kirby G4 Bagged Upright Vacuum

1 Answer

Sensor


There is an optical sensor inside the port where you attach your vacuum bag. Take the bag off and take a clean soft cloth and wipe inside the port to remove dirt from the sensor. Don't wet it! Do this every time you change your bag and you shouldn't have a problem.

Nov 08, 2008 | Kenmore 31912 Progressive Direct Drive...

1 Answer

Intele Clean


Every time you change the bag you should clean the eye. The eye is inside the tube behind the bag collar. Just use a lint free cloth and wipe all around inside the tube. That worked for me!

Sep 28, 2008 | Kenmore Progressive Bagless Upright with...

1 Answer

Electrolux Canister - Renaissance model


Probably a clog, because the change bag light is nothing but an airflow sensor.

Check your hoses to ensure that there are no blockages, and also check inside the powerhead behind the brushroll.

-R

Aug 07, 2008 | Electrolux Lux 5500 Canister Vacuum

2 Answers

I changed the bag and my vacuum won't turn on!!!


Try vacuuming the inside of the tank out, and see if that helps clear off the sensors.... If not call (570)326-1731 and ask for Liz adn I will be happy to try and help you aout.

Sep 06, 2007 | Electrolux UltraLux 2000 Bagged Canister...

Not finding what you are looking for?
Miele S548 Bagged Canister Vacuum Logo

979 people viewed this question

Ask a Question

Usually answered in minutes!

Top Miele Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18390 Answers

Mack Baxter

Level 3 Expert

381 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Are you a Miele Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...