Question about Profile AP600 Car Audio Amplifier

1 Answer

Strange electric outburst

The amp i have been using in my car is a Profile California 600 Watt Mosfet monoblock amplifier and when i hooked it up it works fine and hits real hard so i dont want to just trash it and find a new one but whenever i tap it on top of the amp the subs hit once as if it were in the song. I opened it up just to see if anything was melted or not connected properly and i can't really see any visible problem....Any ideas what it is??

Posted by on

  • jdwiegand Jul 03, 2009

    Well, that shouldnt be a problem because my Battery is in my trunk... so the power wire shouldnt be affecting it. My setup is complicated but not until i got this amp did anything happen like this. I checked everything. It has to be something with the amp that i just can't see.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 16 Answers

Are your cables ran seperate? run the rca and remote wire opposite side of car where power wire is. rca and remote wire can pick up signal from elctric static from power wire.????

Posted on Jul 03, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a California Profile 600 watt amp, I have multimeter and have power all the way to my 10


Power from ignition is setup to turn power On,

Check if +12V is available on "REM" terminal.

Check the speaker wirings , if speaker is connected to the

speaker output of the amp securely.

Oct 21, 2012 | Profile - California: 2 Channel 600W...

1 Answer

My pyle plmra 220 600 watt 4 channel amp blew out, pyler said it would be 50 dollars to send it in to them so i said to heck with that and oppened her up and found a capacitor blown, but when i replaced...


outputs also blown, go to ebay and buy a better amp form the same price you would have paid for pyle to fix that one, just keep playing with that one and you will get better at repairs, thats how i learned to fix amps.

Dec 13, 2010 | Pyle - plmra220 - Marine 600 Watt 2...

1 Answer

Amp keeps blowing the fuses


Serious short circuit on your output transistors, need replacing.

Sep 28, 2009 | JVC KSAX4504 MOSFET 600-Watt Amplifiers...

1 Answer

JVC 600 watt amp overheated


Yes it has a protection mode, let it cool for while then try it again, if it over heats quick make sure you're not running the amp below its stable impedance.

Aug 30, 2009 | JVC KSAX4504 MOSFET 600-Watt Amplifiers...

2 Answers

Where can I get wiring diagram?


www.pyleaudio.com/manuals/PLMRA220-420.pdf

Jul 22, 2009 | Pyle - plmra220 - Marine 600 Watt 2...

1 Answer

550x2 subs....SPL z2x-820 Amp


Hello,

The 230 watt amp is a little small for your subs. They'll work, but if you are looking for max SPL, you won't get it. To push those Audiobahn's to their potential pavement shaking max, I would recommend an amp in the range of 500-600 rms (2-channel bridged) or 1000 watts rms monoblock.

Hope this helps.

Mar 28, 2009 | SPL Dynamics Z2X-820 Car Audio Amplifier

1 Answer

I need to know what kind of fuse my amp takes...


IT MAY MEAN THAT IT TAKES (2) 25 AMP FUSES
IF YOU HAVE THEM OUT SEE IF IT SAYS WHAT THEY ARE OR OPEN IT UP IT MAY SAY IT ON THE BOARD OR THE FUSE HOLDER OR LOOK @ THE SPECS ON THE AMP SEE WHAT THE TOTAL CURRENT IS YOU CAN ALWAYS START WITH A SMALLER AMPAGE LIKE 10 -20 AMP FUSE ALWAYS GO SMALLER

Feb 15, 2009 | Sony GR-6.1m Gravity Mono Channel MOSFET...

1 Answer

California 3600 mosfet discrete 3 ch amplifier 600 watts does not work


It sounds like it's going into protect. To be sure it's not the wiring, disconnect all speaker wires from it. If the light still goes out, check the DC voltage on the B+ and remote terminals. Place the black meter lead on the ground terminal of the amplifier. If the voltage remains above 11 volts as the amp tries to power up, the output transistors are almost certainly shorted causing the amp to go into protect.

Nov 25, 2007 | Profile 600MSX Car Audio Amplifier

1 Answer

600 watt 4 channel bridgeable mosfet power supply jensen amp


Swap the wires from one speaker to the other to see if it is the speaker or the Amp/wires. 

Oct 23, 2007 | Jensen A600HLX Car Audio Amplifier

Not finding what you are looking for?
Profile AP600 Car Audio Amplifier Logo

Related Topics:

102 people viewed this question

Ask a Question

Usually answered in minutes!

Top Profile Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4844 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

The Knight
The Knight

Level 3 Expert

74106 Answers

Are you a Profile Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...