Question about American Pro VS1405 Car Audio Amplifier

1 Answer

About a week ago my subwoofer stop producing sound but the power LED on the amp is still on. by now ive checked the rms wires, power and ground, and even fooled around with the speaker wires from the amp to the woofer, nothing seems to be fried or shorted. I still have no clue what's wrong.

Posted by on

  • mtnlogistics Jul 07, 2009

    yeah, it is. by now ive replaced the amp, the rca cables and the woofer, still nothing. im thinking its an actual problem with my cd player?

  • yadayada
    yadayada May 11, 2010

    is the output power transistor ok?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,550 Answers

Maybe the audio amplifiers IC are fried and need to be replaced

Posted on Jul 02, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

IS ORION HCCAD5000 AMP ENOUGH FOR 2 ORION HCCA10.2!


No. These subs are rated at 1500 RMS each. So you need an amp that will produce at least 3000 watts RMS at 2 ohm load or if you wire each sub to a separate amp down to 1 ohm...then you will need an amp that will produce at least 1500 RMS. Those subs can handle more than they are rated though.

Sep 19, 2012 | Orion HCCA 10.2 Car Subwoofer

1 Answer

I have a orion xtr 2150 and a hcca 10.4 what is the best way to wire this combo?


Hello. Quick answer...bad sub and amp combo due to fact that your sub needs a lot more power than this amp can produce (I'll explain later). But here is how you can do it: You can wire this dual 4 ohm sub in parallel or series. Parallel wiring would be to wire two the positive terminals on the sub to each other and wire two the negative terminals on the sub to each other. Thus wiring down the sub to 2 ohm. This what the amp would see. Series wiring would be to wire the positive and negative terminals on the same side of the sub to each other. Then wire the positive and negative terminals on the other side to the amp. Thus wiring the sub to 8 ohm. This what the amp would see. Illustrations can be found here: http://www.the12volt.com/caraudio/woofer_configurations.asp?Q=1&I=42#results


Your sub specs are 1500 watts rms (how many watts your sub needs to operate efficiently or its minimum requirement. It has the a peak wattage at 3000 watts that it can accept in short duration. Your amp can only produce 300 to 600 watts at 2 or 4 ohm respectively. So you would be greatly under powering the sub which would produce a weak unfulfilled sound. You need an amp that produces a true 1200 to 1800 watts rms. There is a great selection out there.

Sep 01, 2012 | Orion HCCA 10.2 Car Subwoofer

1 Answer

I got a ppi d1000/1 amp cant get any sound out of it?


Make sure your remote wire is hooked up in the right spot, also check your rca plugs and consider replacing them, check all fuses to make sure their not blown, a loose or not good ground wire or power supply wire will also cause this problem. If a power wire has a cut in it, that will also cause fuses to blow, as well as with a ground wire cut, ur amp will not be properly grounded.

Sep 26, 2010 | PPI PrecisionPower D1000/1 Subwoofer Mono...

3 Answers

My friend jus bought 2 10 inch kicker l5s and when we hooked them up to his boss 1100 wat amp and hooked everything up they are moving but are not producing any sound. boss amp i do not know any thinbg...


it must be reversed polarity in coil voices of speakers check + - wires from amplifiers fit on coil voices of speakers try to get each speaker to 8 ohms wiring in serial the two coil voices n'd put in paralel both speakers in bridge mode output from amplifier to get most stable power ,

Nov 04, 2009 | Kicker Solo-Baric L5 Car Subwoofer

1 Answer

Blown subwoofers


Does the amp have an input 'clipping' LED? The worst thing for a speaker is to try and reproduce an unclean signal. Just make sure not to overdrive the amps input. You might also purchase higher rms rated speakers. As far as the ground is concerned, paint and/or oil, rust etc have been cleared from contact area, correct? Seems like if ground were insuffecient, power to amp would drop out.

Nov 03, 2009 | Kenwood KFC-W2512 Car Speaker

2 Answers

When i turn up the volume the base cuts out and


Check and re check the grounds. You need a good solid ground. Sound simple, but we always seem to overlook the obvious... or Possibly the deck has a high output(rms watts) and is overpowering the inputs on the amp. In this case use a line out converter.

Jun 28, 2009 | Fusion FEW12PK Car Subwoofer

1 Answer

Trying to figure out what kind of amp i got amercian pro vs-3507?


The VS3507 Is a class D monoblock.
Your optimum wiring for this amplifier is a 2 Ohm load - so it produces its full potential power of 350W RMS.

To Achieve a 2 ohm load, the most common load is one of the following...
(1) Dual 4 Ohm Voicecoil Subwoofer Wired in Parallel.
(2) 4 Ohm Voicecoil Subwoofers wired in Parallel.
(1) Quad 2 Ohm Voicecoil Subwoofer wired in Parallel/Series.
(1) Single 2 Ohm voicecoil subwoofer.

American Pro VS3507 2000W Car Audio Monoblock Amplifier
American Pro VS3507 Monoblock Amplifier Details
  • Built-In Crossover
  • Variable High/Low Pass Filters
  • Phase Shift Control
  • Subsonic Filter
  • Bass Boost Control
  • Dancing Lights at the Rhythm of Music
  • Protection Circuits
  • Gold Plated Terminals
  • Power & Protection Circuit LED
  • 1 x 250 Watts RMS @ 4 Ohms
  • 1 x 350 Watts RMS @ 2 Ohms Thanks for using FixYa - A FixYa rating is appreciated!!

Jan 29, 2009 | American Pro Car Audio & Video

1 Answer

Sub is unresponsive


unhook the orange wire and also try the remote wire, rerun that too the amp

Feb 17, 2008 | Car Audio & Video

1 Answer

Power LED lit, Servo LED lit as well, no output


check the power cables on the amp and the inputs.isome time when ground cable disconnect the lioghts will light up any way. depending on the way ur vehicle is ground ed .toyota chssis r usually posite un like the norm which is neg.rating please

Jan 21, 2008 | Infinity BASSLINK Car Subwoofer

Not finding what you are looking for?
American Pro VS1405 Car Audio Amplifier Logo

Related Topics:

118 people viewed this question

Ask a Question

Usually answered in minutes!

Top American Pro Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4848 Answers

yadayada
yadayada

Level 3 Expert

75807 Answers

The Knight
The Knight

Level 3 Expert

74106 Answers

Are you an American Pro Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...