Question about Car Audio & Video

1 Answer

Amplifier wont turn on

The amplifier's ground got loose and it sparked. Now the amplifier is not functioning.

Posted by on

  • Anonymous Apr 07, 2008

    i got the same problem, i have a HK-2000D ma amp that wont power on, if you find a way to fix yours plz let me know



1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 28 Answers


if the amp doesn't have a protection circuit you probably blew it.

Posted on Nov 09, 2007


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

I have a 2000 harley davison sporster custom i have changed the spark plugs i have no spark at all the coil is new and the module is new but someone cut my turn single wires and put in new turn singles now...

Hi Altonbaker81, the CKP sensor needs compression to send correct signal to the ICM/ECM, make sure both spark plugs are in heads and use a grounded third plug to check for spark or hold spark plug cable close to spark plug in head. If still not getting spark the usual suspects are:
1. Fouled spark plugs.
2. Battery voltage below 8.7 volts, loose or broken battery cables especially ground cable to frame.
3. Loose connection at ignition coil or plug between ignition sensor and module.
4. Spark plug cables in bad condition, shorting / leaking, spark plug cable connections loose.
5. Faulty ignition coil or ignition / electronic module
6. Failed CKP, CMP, MAP or BAS sensor.
7. Faulty ignition switch.
8. Security alarm failing to disarm.
For a prime suspect please visit the website below and good luck.
Harley Davidson Sportster error codes and how to access them

Aug 03, 2011 | 2000 Harley Davidson XL 1200 C Sportster...

1 Answer

I took my stereo out and the battert cable thouch a sertent wire and sparked. i put my stereo back in place turned my car on and now it wont turn green or red and now spark from tne batt to amp cable

electric current and voltage required for a car amplifier is the voltage of B + and ACC, commonly called the primary voltage with a mark of B + = 12Volt-13, 8 Volt and ACC from the Iginition switch, the same voltage = 12 Volt. so make sure both are available in the car audio amps. Possible loose or broken wire as you remove it, or from broken fuse, check the fuse box panel in the car for the ACC (Accecories) fuse, if broken replace with a new one (with the same Ampere)

Aug 28, 2010 | Kenwood KAC-X501F Car Audio Amplifier

1 Answer

Light on remote wont turn on and it is connected to the amplifier

neg terminal to ground, positivew terminal to 12volt and jump a wire from posiitve to remote wire on amp to see if it turns on

Apr 25, 2010 | Polk Audio PA250.2 Car Audio Amplifier

1 Answer

I have a new memphis pr 1000 and when u put power

Sounds like a grounding problem. Possibly internal.

Feb 17, 2010 | Car Audio & Video

1 Answer

Wont power on

Ssometimes the antenna wire is not enough to turn on the amp , some cars use relays in thier power antenna turn on set up which require low 500 ma 's . hit the amps turn on post with 12 volts directly from a jumper wire with alligator clips from main poower wire , if it still wont tunr on the amp the amp may be faulty , also check amps ground , metal its grounded must be free of paint , undercoating rug ect ....

Nov 17, 2009 | Pioneer Car Amplifier GM-5100T - 2CH 760...

1 Answer

Amp wont work

open the amp and look for a loose pwer or ground wire

Mar 27, 2009 | Jensen XA4150 Car Audio Amplifier

1 Answer

Protection light wont go off

try checking the ground cable it migth be loose.. this happen to me once and it was a bad contact ground make sure the area is clean and tigth

Mar 12, 2009 | Car Audio & Video

1 Answer

Ground sparking

If the ground on the amplifier is sparking, it is either -
arcing across to the power or remote terminal via a stray wire strand, or loose inside the terminal.

If it is sparking at the chassis ground (car) - the screw is loose.

It is not normal to spark, and needs attention before the spark turns into failure of the amplifier.

Thank you for using FiXya - A FiXYa rating is appreciated!

Jan 22, 2009 | Kenwood KAC-7202 Car Audio Amplifier

2 Answers

Amplifier stays in protect mode

If the positive power cable touched the ground, the fuse inline should have blown. Did it?

Sep 18, 2006 | Kenwood Excelon KAC-X541 88W x 4 Car...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

329 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4905 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers


Level 3 Expert

77932 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides