Question about Lanzar MXA422 Car Audio Amplifier

1 Answer

2000 watt american legacy amp protection ligh wont go off

I have a 2000 watt american legacy amp that worked for like 2 sec and smoked for a sec and then the protection light came on. the fuse never blew which is what i dont get, and now no matter what i do the protection light will NOT go off. i cant get the green power light to come on or get any sound out of it. im wondering is there anything i can do to fix it or am i just S.O.L on my investment and just be cheaper to buy another amp???? any help is greatly appreciated

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Same thing happened to me so I returned it for repair turns out it was an internal 25amp fuse on the output. Got it back an it sounded very weak now it does not play at all. Nothing wrong with my setup as I have now got an 800watt amp that is running great.

Posted on Jun 12, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I need to know the size of external fuses for a american legacy amp 2000 watt 2 channel 1990


25 to 30 amp fuses will work great, anything lower could possibly blow a fuse when a good bass note hits even if there is nothing wrong with the amp. Hope this helps.

Jul 09, 2010 | Legacy - American II: 2 Channel 2000W...

1 Answer

LA-1030 Protect Mode


you have an unloaded channel,so the voltage is exceeding what the protect circuit is supposed to see.you have to connect an 8 ohm resistor across the output of the unused channel.
do not drive a signal into it or you will smoke the resistor.
a 10 watt will do ok with zero signal input

May 23, 2009 | Legacy Audio LA1030 Car Audio Amplifier

1 Answer

My amp


My amp stays in protect mode i don't know whats wrong Any suggestions

Apr 05, 2009 | Legacy Audio American Legacy II LA1990 Car...

2 Answers

I have an american legacy series 2 1000watt apm


Check and see what size fuses it uses. Your watt power means nothing without good fuses. My suggestion would be to go buy 40a fuses and replace the ones you already have.

Feb 27, 2009 | Legacy Audio American Legacy II LA290 Car...

2 Answers

600w legacy amp


9 times out of 10 if your amplifire is in protect mode and evrything externaly, like speakers, fuse, voltage, etc. checks out fine then
either you have shorted out output transistors or power mosfet transistors. Basicly that just about what happens with car amps.
It's easy enough to fix IF, IF you know what your doing. First you
need to check the output transistors with a digital volt meter on diode check, If they check out then check your power supply mosfet transistors. I can almost guarantee this is your problem. Very common. I buy non working amps all the time and repair them. Listen to pbabin also he has helped me out. Good luck

Sep 08, 2008 | Legacy Audio American Legacy II LA490 Car...

1 Answer

What size fuse do i need for amp


start with a 50, may need to increase it if you are not using a large capacitor.
600 watts = 12x
x= 600 watts / 12 volts
x = 50 amps

Dec 13, 2007 | Legacy Audio American Legacy II LA490 Car...

1 Answer

Amp not working correctly goes into protection


Disconnect the speaker wires from the amplifier and see if it still goes into protection mode. If it still goes into protect with the speakers disconnected, there's a problem with the amp; if not, you may have a blown speaker or a shorted speaker wire.

Feb 22, 2007 | Legacy LA2098 Car Audio Amplifier

Not finding what you are looking for?
Lanzar MXA422 Car Audio Amplifier Logo

215 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lanzar Car Audio & Video Experts

Radames Pagan
Radames Pagan

Level 3 Expert

196 Answers

Joe Alexander
Joe Alexander

Level 2 Expert

65 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

Are you a Lanzar Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...