Question about Hitachi 60UX54B/55K 60" Rear Projection Television

2 Answers

Will not stay on


Posted by on

  • Anonymous Nov 26, 2007

    I have the same problem, with my Hitachi 60UX54B.

    The red protect led is on steady prior to pushing the power button.

    Then blinking after the power button is pressed.

    I also noticed that the green LED labled B+ 120V, never comes on, both before the power button is pressed or after the power button is pressed.

  • Gavin Curtis Nov 08, 2008

    Hitachi 60UX54B will not turn on. Red protection LED lights very dimly for a few seconds when plugged in. All 8 green LEDs are on but B+ 120V is dimmer than others.

    Power supply then shuts down and red protection LED very dimly blinks. All green LEDs turn off at the same time except the B+120V which remains on for nearly on minute.

    There is absolutely nothing in the poor service manual about identifying this problem when the protection light is dim or flashing.

    B+120V only goes to about 60 VDC during this brief power up. Front panel LED never illuminates and power button does not respond.

    All pico-fuses in the power supply are good. C703 and 702 are good. Removal of E994 do disconnect load from B+120 and powered up again. Still get +60VDC. So nothing shorting or excessive load on the B+120 rail that I can identify.

    Power to pin 5 of I901 fluctuates from +14VDC to 21 VDC. Service manual suggested testing Q901 and replacing I901 if not stable. Q901 is good and replacement of I901 made no difference.

    Verified that D949 and C929 are both good. Could problem be a bad power B+ transformer widing as the only winding that has half voltage output? Opto-isolators in power supply test good. Ordered a replacement SE120N (I905) if it is causing shutdown. All other voltage outputs are good from the transformer.

    So anomalies are:

    1) Unstable voltage (14-21 VDC) at pin 5 of I901 with blinking red LED. Replaced part and no difference.

    2) B+120V only reaches half; approximately 60 volts DC, even when E994 (good) removed to remove any load.

    Any other suggestions to keep this TV from going to the landfill?



2 Answers

  • Level 1:

    An expert who has achieved level 1.


    An expert that has over 10 points.


    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 8 Answers


So if you have a blinking red protection LED:

Turned out the pico-fuse for the -23V had 130 ohms resistance. Initial continuity test feature on my meter indicated it was good since anything under 200 ohms is continuity. All of this after many hours of frustration... and not understanding why all secondary voltages on the power transformer were at 50% for the 2-3 seconds of power up before shutting down.

The "leaky" pico-fuse turned into resistor allowed enough power to illuminate -23V LED despite voltage being 1/2.

Replaced with new pico-fuse to get true -23V. All other output voltages followed suit and TV is working perfectly.

Don't trust the green LEDs. Measure all voltages and be sure to verify 1 ohm or less for every pico-fuse.

I don't understand how a faulty -23V rail would cause this problem. Feedback is from the +31V rail which powers standby 12V safety regulator, 9v and 5v switched regulators.

Anyways it works now.

Posted on Nov 10, 2008

  • Kevin McIntire Nov 26, 2012

    I am having the same exact problem. I am having trouble locating the pico-fuse that you replaced Can you give me the letter and number so I can locate it on the board?

  • Kevin McIntire Nov 26, 2012

    I am having the same exact problem. Can you give me the letter and number of the location of the pico-fuse on the board? I am having trouble location it.


  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert who has answered 1,000 questions.

  • Master
  • 1,694 Answers

RED light is protect circuit = do not disable !
Look for C702 near flyback transformer - might be hidden in
glue = check it = if shorted, replace 102K / 2KV with 3KV =
Sony part # 1-161-754-00 and replace E994 pico fuse.....T.

Posted on Nov 08, 2007


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Why won't it turn on?

Fault to its main board. Short circuited component/s at it. Contact any service technician; or the authorized service center. If you wish to get some details; check the site linked here. Surf the site with patience. Pull up older posts. . In most cases, the main board might have to be replaced. If so, a software [firmware] update too might be necessary.

Nov 21, 2015 | RCA 42PA30RQ 42 Class Plasma TV - 1024 x...

1 Answer

We have a 2007 Sony Bravia 46" KDL-46VL130. There is not sound or picture. When we power it on the green light comes on blinking once and then the red light blinking once and then the green light stays on....

Does the front light stays green ? Or goes back to red ? The back-light going on/off maybe the problem, but it shoul return with a red blinking led (4 times ?) and if so it can be a power inverter problem.

Oct 09, 2013 | Sony Bravia KDL-46VL130 TV

1 Answer


sounds like power supply boards gone faulty.........
easy fix if you can use a soldering iron....
or check ebay for replacement p/s board........

May 03, 2011 | Televison & Video

1 Answer

55" TV keeps shutting off automatically

Green light flashes 5 and then red light flashes 6

Sep 14, 2009 | Sony KDF-E55A20 55 in. LCD Television

1 Answer

I have a Philips Plasma tv 42pf5321d/37 with sound but no picture

Thats the great sound of Exploding capacitors on either the power supply board. or another one in there. Now the set is in fault protection. It tried to warn you with the RED blinking LED that there was something amiss by shutting itself down. When you unplugged you reset the error and allowed it to do it again.

Best Regards and Smper Fi

Jun 23, 2009 | Philips 42PF9630A 42 in. Plasma Television

1 Answer

Power LED blinks red

it is a bad fan. it also could be a power supply. Quite often the real problem is dirt clogging up the fan(s) to the point that they need to be replaced. Operation of the set in a dirty environment is not a good idea

Feb 26, 2008 | Sony KDS-60A2000 60" HDTV

5 Answers

Philips 42 in. Plasma shut down

did u cheak the input cables does it do it on dvd input as well as others ?

Feb 01, 2008 | Philips 42PF7320A 42 in. Plasma HDTV

1 Answer

Philips Plasma NO LIFE

I had the same problem (with 42FD9954/17S) that when turned on the unit, the green LED turned off and came back to red again some time later. I kept turning it on and once it went to a clicking relay sound and blinking green LED with it. It did that for a while and stayed turned on. I noticed that it is temperature sensitive. Colder the room is more often does it. Used a hair dryer and blown hot air into the unit at the left bottom grills. It helped and started to tun on quicker. Later it has deteriorated so bad that I took it a part and after several ice spraying test showed that on the middle big board (power board) there was an electrolyte condenser went bad. It is the one one which is at the middle, bottom center of the board near the fixing screw. There are two of them (cylindrical objects). The left one was the culprit. However when I fixed it, it turns on immediately but goes blinking red after that. Phillips say it is a static discharge problem. I might blown something when soldering the parts. I don't know what. Any ideas?

Dec 21, 2007 | Philips 42HF7444T 42 in. Plasma TV

1 Answer

Lost power

The symptom you have needs to be looked at by a qualified technician for proper diagnosis. There are 9 LED`s ( 8 green, 1 red) in the power supply that light up under normal condition. These LED`s are used to help pinpoint the area of trouble. For example, when power is applied all LED`s but one lights up. The unlit LED may indicate the +27 volt source is bad. That will alert the technician to check components related to the +27v line. Since there are 8 green LED`s and 1 red, each having multiple suspects leads us to Mr Spock`s comment to captian Kirk." there are endless possibilities"

Nov 14, 2007 | Hitachi 50UX52B/53K 50" Rear Projection...

Not finding what you are looking for?
Televison & Video Logo

397 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hitachi Televison & Video Experts

Jaime Hernandez

Level 3 Expert

2326 Answers

The Knight
The Knight

Level 3 Expert

75025 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hitachi Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides