Question about Mitsubishi VS-5043 50" Rear Projection Television

1 Answer

Mitsubishi vs-5043 rear projection sound no picture

It has worked fine, But the all of the sudden the picture is black nothing coming out of CRT's I do see glowing near bottom of tube. I have service manual and what I have checked out seems ok. I have sound

Posted by on

  • JKDCRP Nov 19, 2007

    Yes I have tried this but nothing happens. What I have read about the diagnostic test is you turn the tv on It auto powers down then you hold down the two buttons, Sorry I don't recall which two, I'm away from home now. Anyway after tv powers down then you hold the two and it blinks the problem. But tv never powers down. Unless I turn off, but it doesn't give message when I do this.

  • old stogy Dec 09, 2007

    Dec 8, 2007 Very similar problem, Picture fine, sometimes for a few hours, then three lines RGB in an S pattern stretched accross the screen for an instant, then all black. Sound is OK. Picture comes and goes a few times with the same symptoms, then stays black. Tried lightly tapping on the components with a 2 foot piece of dowel. Even tried a little freeze spray in some areas with no luck. Would love to get it fixed for a reasonable price.



1 Answer

Have you tried the diagnostic test yet?

Posted on Nov 19, 2007


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Mitsubishi VS-5071 rear projection turns on, has audio but no video

That is a VZ3 chassis, similar to Mitsubishi models Ts-4545, Ts-5045, Ts-5545, Vs-4543, Vs-4544, Vs-5043, Vs-5044, Vs-5047, Vs-6043, Vs-6047 and has common failures in the vertical circuit, specifically vert Ic401 which is a La7845 which is usually caused by defective C402 100uf 50v and/or open 1.2 ohm 2 watt R510 next to FBT.
If not that check C268 off Q215 on signal board 22mf/50v and Ic200 on signal module Cxa2025s. However the vertical failure is more likely.

Sep 10, 2008 | Mitsubishi VS-5043 50" Rear Projection...

1 Answer


What kind of input are you using

Nov 05, 2017 | Mitsubishi VS-5043 50" Rear Projection...

1 Answer

Mitsubishi vs 5043 no picture

have the tubes checked out you may have a loose connection

Jul 15, 2008 | Mitsubishi VS-5043 50" Rear Projection...

1 Answer

Mitsubishi vs 5043

I turned the set on and everything was fine, then the screen went black and mullti-colored horizontal (arched) lines were flashing across the screen. The next day I turned the set on and everything was fine for about 5 minutes then the problem reoccures again. Haven't looked for solutions till now.

Apr 06, 2008 | Mitsubishi VS-5043 50" Rear Projection...

1 Answer

Sound no picture

Try resoldering the vertical output IC this is acommon problem with this model

Mar 20, 2008 | Mitsubishi VS-5043 50" Rear Projection...

3 Answers

Mitsubishi vs 5051 rear projection tv sound but no picture

No video but good audio Mitsubishi VS5051. Check R509 and R 519, 100 ohm resistors located on the main PCB near the flyback transformer. Also bad connections on any of the yokes and the vertical output IC will cause the same problem.

Sep 19, 2007 | Mitsubishi VS-5043 50" Rear Projection...

1 Answer

Mitsubishi vs-5043

Look for short on Green CRT board.

Aug 19, 2007 | Mitsubishi VS-5043 50" Rear Projection...

1 Answer

Black horizontal lines on mitsubishi VS-5043

Is the noise in all inputs (line, tumer) ? If it is in the tuner alone, check the coax lug to see if you knocked it loose. This could be the problem. Check you picture with a DVD player on the Video input. Let me know what you find.

Jul 03, 2007 | Mitsubishi VS-5043 50" Rear Projection...

2 Answers

Mitsubishi model vs-5043

I just had this same exact problem. I looked for an answer on here and could not find one. So I took the back off, vacuumed and cleaned everything out with the hose on my house vacuum, cleaned the bulbs and wiggled them around some. Voila !!!! lights on and all is working fine and better then ever. I hope this helps someone fix their problem. Just saved me tons of money and a morning of hassle.

Jan 06, 2007 | Mitsubishi VS-5043 50" Rear Projection...

Not finding what you are looking for?
Televison & Video Logo

Related Topics:

182 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Televison & Video Experts

matt martin
matt martin

Level 3 Expert

1213 Answers

The Knight
The Knight

Level 3 Expert

74999 Answers

Jaime Hernandez

Level 3 Expert

2326 Answers

Are you a Mitsubishi Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides