Question about Sony Xplod XM-1652Z Car Audio Amplifier

2 Answers

Sony xplode 1000 watt amp

I have a sony xplode 1000 watt amp that i recently hooked up. i followed everyting correctly and when i turned my car on my amps power protecter light will turn red and wont come on.  What could the problem be?

Posted by on

  • rkbizzle123 Nov 11, 2007

    i got it fixed. the problem was that i didnt have in grounded in a good spot. thanks for the help

×

Ad

2 Answers

Just make sure that your wiring is for 1000w or more
and check the + and - even at the speakers.

Posted on Nov 10, 2007

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 537 Answers

Make sure you don't have a short circuit somewhere. Make sure the wiring is all intact.

Also look at this link:

http://www.fixya.com/support/t132850-sony_xplod_1000_watt_car_amp_quit

Mike

Posted on Nov 07, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My stereo in 1997 chevy caviler is turning off and on when turned up to a high volume. I have a sony xplod 52 watt by 4 channel radio. With two 6x9 sony xplod 50 watt rms and 300 watt peak power in the...


Most likely cause is heat. The clearances behind the radio are often not sufficient to provde the proper air coolling that the higher power radios need. The heat sinks on the rear of the radio require a certain amount of air flow to dissipate the heat generated under high load conditions. If you add summer heat to the equation, you can have the radio going into thermal cutout to protect it circuity.

May 27, 2011 | 1997 Chevrolet Cavalier

1 Answer

I have 2 10' sony xplodes connected to a 2


If your radio is still playing and the subs are giving you music, you most likely have the amp remote wire hooked to a constant power source on the radio. Generally, this is a solid blue wire on both the radio and the wiring harness. It allows the radio to turn the amp on and off when the radio is on or, subsequently, off.

Apr 21, 2010 | Sony Xplod 1100 Watt Max 10" Subwoofer,...

2 Answers

Amp blows fuses


Are you using the correct fuse? if so,
more then likely, you don't have a good ground. Try grounding to something else that has more direct connection to your frame. If that doesnt work, try getting larger power cables.
I had the same problem with my 2500w xplodes all I had to do was get a thicker cable for the ground and battery connection. What was happening, was it was needing more power then the wire and fuse could handle, so it would blow the fuse, since the higher you have it, the more power it needs to feed the watts.
I would try grounding it directly to the frame on a good part of the frame before spending another $70 on new power cables though.

Mar 09, 2010 | Car Audio & Video

1 Answer

I hooked this 1000 watt amp up.it turns on but it


Your amp needs to be serviced. Bad protection circuit. Take it to a local car audio shop and have them bench test it first to be sure. Hope this helps.

Sep 26, 2009 | Sony Xplod 1200W Class AB Bridgeable 2-Ch....

2 Answers

How do I fix the problem so they work again.?


A 1000 WATT AMP HAS PROBABLY GONE INTO PROTECTION MODE BECAUSE YOU ARE TRYING TO RUN 1600 WATT SUBS COMBINED

Jun 08, 2009 | Car Audio & Video

1 Answer

Protection Light Comes on


your amp isnt getting enough power to it you may need to install a compacitor unit

Mar 23, 2009 | Sony NTX-2136 DHD 2Channel Car Amplifier...

2 Answers

Sony xplode 1000w amp has green light puts out no power to subs


may haveto turn sub on through the stereo itself if rca cables are good.

Jan 08, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

3 Answers

Power protector light on sony xplode 1000 watt amp


a green light is the power indicator, a red light is when the protector is in affect

May 30, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

2 Answers

Sony Xplod 1000 watt car amp quit working.


Almost all after market amps use 12v at very very low amperage to trigger the amp on. A temporary jumper from the battery plus terminal on the amp AFTER the battery and ground wires are attached should cause the amp to turn on. I would check to see if you have attached your speaker load correctly ESPECIALLY if you are bridging. Most of the blown amps that come into my shop are due to incorrect bridging loads from the speakers. Note that a 4ohm load bridged across both outputs of an amp will deliver a 2ohm load to each of the channels. When you parallel wire two 4ohm speakers together and then attached them to a bridged amp you will be putting a 1 (one) ohm load to each channel of the amp. Please don't make this mistake. It will fry your amp in about a month. Hope this helps. Good luck.

Feb 03, 2007 | Sony Xplod XM-1652Z Car Audio Amplifier

Not finding what you are looking for?
Sony Xplod XM-1652Z Car Audio Amplifier Logo

Related Topics:

297 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

xxxxxx xxx

Level 3 Expert

4915 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...