Question about Sony Xplod XM-1652Z Car Audio Amplifier

2 Answers

Sony xplode 1000 watt amp

I have a sony xplode 1000 watt amp that i recently hooked up. i followed everyting correctly and when i turned my car on my amps power protecter light will turn red and wont come on.  What could the problem be?

Posted by on

2 Answers

Re: sony xplode 1000 watt amp

Just make sure that your wiring is for 1000w or more
and check the + and - even at the speakers.

Posted on Nov 10, 2007

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 537 Answers
Re: sony xplode 1000 watt amp

Make sure you don't have a short circuit somewhere. Make sure the wiring is all intact.

Also look at this link:


Posted on Nov 07, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

2 Answers

Amp blows fuses

Are you using the correct fuse? if so,
more then likely, you don't have a good ground. Try grounding to something else that has more direct connection to your frame. If that doesnt work, try getting larger power cables.
I had the same problem with my 2500w xplodes all I had to do was get a thicker cable for the ground and battery connection. What was happening, was it was needing more power then the wire and fuse could handle, so it would blow the fuse, since the higher you have it, the more power it needs to feed the watts.
I would try grounding it directly to the frame on a good part of the frame before spending another $70 on new power cables though.

Mar 09, 2010 | Car Amplifiers

2 Answers

How do I fix the problem so they work again.?


Jun 08, 2009 | Car Amplifiers

1 Answer

Protection Light Comes on

your amp isnt getting enough power to it you may need to install a compacitor unit

Mar 23, 2009 | Sony NTX-2136 DHD 2Channel Car Amplifier...

1 Answer

Hi i have a 600 watt sony xplod amp model xm-554zr and it recently stopped working. when i turn my car on the amp turns on but only for a sec then the protection light comes on, on the amp and it wont...

sounds like maybe a speaker short, try unhooking your speakers and then powering up your amp, if it then powers up with the speakers unhooked try hooking up each speaker one by one untill the amp goes back into protection and then you have your bad speaker.

Mar 08, 2009 | Sony Xplod XM-554ZR Car Audio Amplifier

2 Answers

Sony xplode 1000w amp has green light puts out no power to subs

may haveto turn sub on through the stereo itself if rca cables are good.

Jan 08, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

3 Answers

Power protector light on sony xplode 1000 watt amp

a green light is the power indicator, a red light is when the protector is in affect

May 30, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

2 Answers

Protection light

You cannot parallel two subs AND run them on the Bridge. You must have at LEAST a 4 ohm load on the bridge, and 2 4 ohm subs in parallel equals TWO OHMS. BAD!!! Move each sub to it's own channel or your amp will soon fry.

Sep 10, 2007 | Sony XM-2002GTR Car Audio Amplifier

2 Answers

Sony Xplod 1000 watt car amp quit working.

Almost all after market amps use 12v at very very low amperage to trigger the amp on. A temporary jumper from the battery plus terminal on the amp AFTER the battery and ground wires are attached should cause the amp to turn on. I would check to see if you have attached your speaker load correctly ESPECIALLY if you are bridging. Most of the blown amps that come into my shop are due to incorrect bridging loads from the speakers. Note that a 4ohm load bridged across both outputs of an amp will deliver a 2ohm load to each of the channels. When you parallel wire two 4ohm speakers together and then attached them to a bridged amp you will be putting a 1 (one) ohm load to each channel of the amp. Please don't make this mistake. It will fry your amp in about a month. Hope this helps. Good luck.

Feb 03, 2007 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

1000 watt amp sony xplod

how do you have your system hooked? What speakers do you have? There is a lot more too it then just wattage.

Jan 23, 2007 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

Not finding what you are looking for?
Sony Xplod XM-1652Z Car Audio Amplifier Logo

Related Topics:

294 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers


Level 3 Expert

57295 Answers

Are you a Sony Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides