Question about Uniflame FG2204C Grill

1 Answer

I turn on bbq it lights, put temp settig to high but only get a low flame on all 4 burners,tank is full,what could be the problem? it has worked fine until this time i used it, it is a uniflame bbq about 2 to 3 years old.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

1 Uniflame 40,000 BTU 3-Burner Gas assembly video. where do i find the video

Posted on Oct 14, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

BBQ does not get hot enough to cook properly. All gas jets are clean as BBQ is almost new


blue flame? if flame is not blue, then air gap needs adjusting. if blue flame and burner control is on high, then could be your regulator. (assuming tank if full)

Apr 17, 2015 | Grilling

1 Answer

Uneven burner


I apologize I've not logged in for some time and do not know what "everyone else" has had issues with.
I can tell you as a grill repair company we get 4-5 calls every week from clients complaining of poor flames, poor heat. The problem has a very simple solution and the problem is not the burners or other parts and (almost never) the regulator.
There are 3 safety features in an LP cylinder. One is a check valve that gauges pressure leaving the tank. This is a swing-arm pressed up by escaping LP. When the gas fills the manifold and gas line (because the BBQ valves all Must Be Off when the cylinder is turned on) the pressure pushes this swing-arm back into position.
The problem usually occurs with newly filled tanks because with the tank full and the OPD float displacing liquid pressure the gas "hits" the check valve swing-arm too hard so instead of registering the pressure leaving the tank the swing-arm is pressed too far and the back-pressure does not reseat it correctly.
The mechanics of the tank are designed to read higher pressure leaving and lower pressure returning as a leak and shuts-down. We still get some flow because of the OPD pushing but the tank will not allow gas flow at the necessary BTU's.
Reset: Turn off everything on the BBQ and the LP cylinder. Disconnect the cylinder and turn the BBQ valves all to "high".
Wait 5 minutes.
Turn everything off again -- and be sure every valve is completely off so no pressure is released.
Reattach the LP cylinder to the regulator and turn the tank on -- very, vert slow for the first full rotation so the gas pressure leaks through slow and cannot "hit" the check valve too hard.
Once the cylinder os all the way on light the BBQ and it will be fine.

Please let us know how it goes.
If I had one dollar for every time someone contacted us to buy burners, regulator, etc only to fix their BBQ while on the telephone with us ... I would retire!

Feb 09, 2014 | Jenn-Air Grilling

1 Answer

I have a four burner CharmGlow BBQ. The two burners closest to the tank have high flames, while the two furthest from the tank have very low flames and will blow out if it is windy. I have replaced the...


Since you have done every other thing I would have suggested, try this .....

Turn the tank valve OFF and disconnect the hose from the tank. Wait 10 minutes and reconnect the hose to the tank. Open the tank valve VERY, VERY SLOWLY (Slow motion, slow) until it's fully open. Now, the light the burner farthest from the tank first and turn it to HIGH. Did the burner light and does the flame height look correct? If co, light the remaining burners the exact same way, starting with the one next to the one you first lit. Now, did all the burners light and do all the flame heights look correct? If so, you solved the problem. The problem was with the regulator, which was partially closed.

If the above didn't solve the problem, check the burner orifices of the two offending burners for clogs.

Hope this helped you to further troubleshoot & solve the problem. Happy Grilling and thanks for choosing FixYa.

Sep 19, 2011 | Grilling

1 Answer

I used our bbq a couple days ago and it was fine, now I am not getting a flame to any part of the bbq. Tried different tanks, still nothing. Do you have any ideas as to what it might be?


Betty, to solve this problem, do the following:

1. Turn the gas tank valve OFF and disconnect the hose from the tank.

2. Wait 5 minutes and reconnect the hose to the tank.

3. Open the tank valve VERY, VERY SLOWLY (Slow motion, slow).

4. Once the tank valve is fully open, light the burner farthest from the tank first and set the burner
control knob on HIGH. Does the flame height look correct for being set on HIGH? If so, light
the remaining burners the same way. Do all the burner flames look correct? If so, you solved
the problem. Remember, to always open the tank valve Very, Very Slowly.

If that didn't solve the problem, you will need to replace the grill's Hose/Regulator Assembly. It runs about $30.00 at any home center or hardware store that sells grills & accessories. If you replace it, turn the tank valve ON Very, Very Slowly.

Hope this helped you to troubleshoot and solve the problem. Happy Grilling.

Jul 09, 2011 | Uniflame FG2204C Grill

2 Answers

Burner flames don't get hot, like not enough gas.


Try this, Turn off the tank. Disconnect it. Reconnect it. Turn tank valve back on very slowly and then see if you get bigger flame size.

May 15, 2010 | Weber Genesis Silver B Grill

1 Answer

Grill lights but flame is low and goes out if control is moved from high. Burner tube is clean, spider screen is clean, and I have a full tank of LP. Grill is Q series about 1 year old and has been working...


Hello. Are you frustrated because your gas grill doesn't get hot enough lately. The problem you are having indicates that you have to go through a procedure called "RESETTING THE REGULATOR". Follow these easy steps:

1. Turn the burners on for one full minute and then off.

2. Next, remove the regulator and the hose from the tank.

3. Then reconnect the tank to the regulator and hose.

4. And very slowly open the tank.

5. Last step is to fire up the burners and start cooking with you new hot flame.

The problem began the first time you opened the valve on the tank too quickly. In the future, always turn the tank valve on s-l-o-w-l-y to prevent this problem.. Joe

Mar 22, 2010 | Weber Q Grill

1 Answer

No gas getting to bbq


I switched to the new style 20# tank with the new turn-on knob.  I couldn't get enough gas pressure to the BBQ burners for all three burners to light or to keep a strong flame on even one burner.  The new style tanks have a safety valve on the inside of the tank that shuts the gas off if you turn the knob on too fast because the safety valve thinks there is leak.  Shut everything off and then try turning the knob on real slow, especially at first, before turning it all the way on.  If that doesn't work (it didn't for me), then replace the large plastic connection valve knob (female end) that attaches the regulator to the tank.  Mine was for the old style tank and was black (low pressure).  I went to a propane company and had them replace it with a green knob (higher pressure).  Took it home and WALA!  Everything works fine now.  But it was very frustrating trying to figure why I couldn't get any gas to the burners after buying a brand new tank.  I hope this helps solve your problems.   

Sep 15, 2008 | BBQ Guys BBQ400C/G42 Grill

5 Answers

Gas BBQ - Won't light


hi Be sure the thermostat or heat dial is set properly. If the appliance has a pilot light, be sure it's working. make sure that you connected the pipeline correctly open the faucet of the tank try to fire it up ? working ? good... NO???? close everything(faucets,plugs...) your new tank that you connected is empty.... it happens.... have a good 1

Apr 06, 2006 | Barbeques Galore Turbo Classic 3-Burner...

Not finding what you are looking for?
Uniflame FG2204C Grill Logo

Related Topics:

493 people viewed this question

Ask a Question

Usually answered in minutes!

Top Uniflame Grilling Experts

paulcarew

Level 3 Expert

2460 Answers

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

yadayada
yadayada

Level 3 Expert

75744 Answers

Are you an Uniflame Grilling Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...