Question about Kenwood KAC-X520 Car Audio Amplifier

1 Answer

Amp shuts off

I have two amps, one for the interior and the other (Kenwood x520) for the sub in the trunk, I also have a capacitor. I've had this system for quite some time 5 years no problems. Now it seems there is trouble with the amp in the trunk. at times it just shuts off, although I'm not sure if the amp is still lit but if I turn the radio off then on, the amp will give power again. any suggestions will be greatly appreciated.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that gotĀ 5 achievements.


    An expert who has written 50 answers of more than 400 characters.


    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 111 Answers
Re: amp shuts off

Check your remote wire and check your power and ground, clean all connections with a contact cleaner/rejuvinator (ridox/deoxit).. many times the thin remote wire will develop breaks or conductivity issues over time, i have replaced many of these just in the last few months.

to make sure this is the problem, remove the remote wire and temporarily jump the power wire to power and remote, the amp will always be on at this point, but it should help you diagnose whether the remote wire is the problem or if it is an amp or cabling issue.

hope this helps,

Posted on Nov 16, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

I have a kenwood kac-9152d amplifer and it works just fine for about 10 minutes then just shuts off and subs dont work, about 30 seconds later my amp turns back on with the subs.

make sure it's well ventilated. If there's no air flow, then there is no way of cooling down and to protect itself it will shut off. Make sure the speakers are wired correctly as per amp specs. too many subs or subs connected improperly can draw too much current and shut the amp off, but you will notice this when you turn up the volume to a certain point and the amp shuts down.

Aug 30, 2011 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

What does it mean if my amp light dims and shuts off when the bass hits

Could be a number of things: Low power to amp, bad ground connection, faulty amp, or even speaker being overloaded or wired wrong. Check your connections and the wattage of the amp and speakers.

Dec 06, 2009 | Kenwood KAC-X520 Car Audio Amplifier

1 Answer

The base in my car kept on goin high and low for like 2 weeks and after that it worked good for 2 days and then the amp shuts off it wont come back on anyone can help me please

loose cable, bad amp, who knows what it could be, its time for you to find out if it is a simple problem, check the wiring, fuse, and anytning else that seems pissible

Jun 14, 2009 | Kenwood KAC-X520 Car Audio Amplifier

2 Answers

Running 2 amps

amps could be overheating or the subs could be requiring more power then the amps are giving off.

Apr 01, 2009 | Kenwood KAC-8452 Car Audio Amplifier

2 Answers

KAC-X520 kenwood 1000w amp

a red light indicates you got no power check your wiring you may not have a good ground, you need the green light to come on

Oct 09, 2008 | Kenwood KAC-X520 Car Audio Amplifier

1 Answer


your amp may be overheating, or you have it up too loud and the surge protector is shutting it of in fear of damage to your amp.

Apr 24, 2008 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

Kenwood KAC-6201 AMP

The Kenwood KAC would be 2 ohm stable.
I ran my sub's in parallel and the amp did not shut off and hit pretty well for long periods of time.
If you are running two dual voice coils.
Bridge amp, run pos and neg to pos and neg outside of box.
neg and pos to one side of sub
The other side of the sub run to the next sub
the other side of the sub to the inside of the box pos and neg.
pos and neg outside of box to the other outside terminals to create a complete loop.
If this isn't a good description post back and I'll email you a picture of it.

Apr 03, 2008 | Kenwood KAC 6201 Car Audio Amplifier

1 Answer

Kenwwood amp will not turn on

u need a capacitor and a new battery. the capacitor stores reserve power to power the sub and ur old battery isn't producing enough juice for the amp so get a new one

Jan 09, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

One amp dies.. then revives

I'm no expert, but the two most obious problems that come to mind would be the power supply or amp over heating.  Test your battery and alternator..

Oct 28, 2007 | Kenwood KAC-X650D Car Audio Amplifier

3 Answers


your system is not connected right take it all out and put it all bk in

Oct 27, 2007 | Kenwood KAC-X650D Car Audio Amplifier

Not finding what you are looking for?
Kenwood KAC-X520 Car Audio Amplifier Logo

Related Topics:

486 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Amplifiers Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1042 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pieter Vleeshouwers

Level 3 Expert

1315 Answers

Are you a Kenwood Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides