Question about Pyle BZDBP212 Car Subwoofer

1 Answer

Amp power I have everything wierd up but there is no power into the amp, but there is a slot in my amp that needs a fuse so im not sure if that is it any suggestions

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 15 Answers
Re: amp power

Hi there, what size output is the amp? it should have a fuse provided. the other reason might be the amp isnt correctly earthed. check all the settings against any instructions you have. if this doesnt work dont hesitate to email me on


Posted on Nov 14, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Pioneer diagrams

It seems that P151 is the "hot" wire to the transformer which powers just about everything, so that won't tell you anything. Most likely, the wrong speakers were put on the stereo which blew the amplifier circuit. Check the amplifier assembly which is the big block with a fan inside of it.

Jan 26, 2014 | Car Speakers & Subwoofers

1 Answer

I have the dual amp xpa 2500 and i ran all the wires and everything but the indicator light wont turn red nor green what can cause that problem?

Check all the wiring again. If you can use a multimeter, make sure your power wire is getting power at the amp. Also, check to make sure your ground is good. Also, check the remote wire for 0.5 amps when the radio is on. This will make sure it sends the signal to turn the amp on. Also, check all your fuses. Make sure to put the fuse in your power wire. Hope this helps.

Aug 22, 2011 | Car Speakers & Subwoofers

1 Answer

I have a sony 1000w zr1852. The power and ground cables touched at the amp. I fixed the connection but now the power save light is on. what could be wrong? thanks

Sounds like there's either some fuses blown, or a short circuit happened inside the amp. However usually they're pretty good about not shorting out. Check your connection at the battery, In-line Fuse, Cap, Distro, and Amp and make sure everything is connected fine. Check the Alternator in your car to make sure it's outputting the right voltages, and the battery to make sure it's between 12V - 14V. I've had some weird things happen over the years with my Car Audio, and it always ends up being wires or fuses.

Jul 04, 2011 | Car Speakers & Subwoofers

1 Answer

Soundstream 1.800 amp keeps blowing fuses

Check your power wire & ground wire if there is any exposed wires that is touching any surface/wires. A blown fuse means there is a short in your system. Also make sure you are feeding your car amplifier with 12v to 14v (some amplifiers can handle up to 18v).
Here is a link about fuses, also this website will give you everything about car audio.
Hope this answer your inquiry. Have a blessed weekend.

Apr 24, 2011 | Car Speakers & Subwoofers

1 Answer

The amplifier power ligh comes on but the sub woofers wont play what could be the problem. I hooked up a different amp and it worked just fine.

Even tho the power light is on doesnt exactly mean that the amp is sending signal to the speaker wires.... sense everything else is working make sure to check your fuses on the amp and also check to make sure that the amp is "receiving" an input from the RCAs

Feb 25, 2011 | Car Speakers & Subwoofers

1 Answer

My fuses keep blowing and they share a fuse with the interior lights

If you are running an amp it needs to have a dedicated power line with a fuse break this fuse break will make sure that you dont blow the amp do to a power surge. The bigger the wire the better, also make sure ground is good bare metal and clean.

Mar 10, 2009 | Car Speakers & Subwoofers

1 Answer

Kicker sub wont work

Im guessing that it is possibly blown... either you ran too much power to it, or it was hooked up wrong... you should unscrew the sub from the box and look inside to make sure that it is connected correctly.... positive to positive, negative to negative,,, if they so much as touched then the L7 could very well be blown.... smell the magnet and if you smell a burnt smell... it is blown... maybe turn your amp down a little... its possible that it is also in protect mode because you are running too many watts to the amp. Feel free to ask if you have any other questions.... Please rate! :D And good luck... i really hope its not burnt out. that stuff is not cheap.

Dec 29, 2008 | Kicker Car Speakers & Subwoofers

1 Answer

Subwoofers not bumpin, amp is still on

Check to make sure there is a good input to the amp. Next check each sub to another source to make sure they are good. Look for any reset on the amp.

Apr 26, 2008 | Kicker CVR12 Car Subwoofer

1 Answer

2 12'' cvr kickers

ya u allreadyfound ound out the problem u have factory amps there u go after market

Feb 27, 2008 | Kicker CVR12 Car Subwoofer

Not finding what you are looking for?
Pyle BZDBP212 Car Subwoofer Logo

Related Topics:

40 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pyle Car Speakers & Subwoofers Experts

Pablo Gonzalez

Level 3 Expert

733 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1128 Answers

Lawrence Oravetz

Level 3 Expert

7159 Answers

Are you a Pyle Car Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides