Question about Aqua Flo Aquaflo Flo Master Xp2 Spa Pump 1.5 Hp Two Speed

1 Answer

Hot tub pump stops and control panel says there is a flo problem

Either the pump is shutting itself down or the spa pack is shutting it down and indicating a flow problem. The motor is thermally protected and now I am suspicious that it is getting too hot and shutting down...then the spa pack indicates no flow. Or else the spa pack is shutting the pump down. I have jumpered across the pressure switch and it still shuts down. Does a thermally protected motor shut down to avoid getting damaged from too much heat? And what would cause the motor to get too hot. The pump is a 5 hp pump, but only the 1.5 hp product shows up on the list.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Habit-Forming:

    Visited the website for 3 consecutive days.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 77 Answers

Yes a pump does have a thermal cut out. When the motor gets too hot the thermal cut out will activate and the pump won't restart until the motor has cooled.


If you were an electrician, or highly confident/competent with electrics, you could test the motor with a volt meter. Run the spa and as soon as the pump stops running, check the voltage at the pump. If there is voltage at the pump, then the thermal cut out on the motor has activated. Do not try checking this yourself if you're not competent to do so.

You could also do the same test at the spa pack if it's easier to do so, just locate the output to the pump.

What spa and which spa pack have you got?

Cheers,
Ian.

Posted on Apr 28, 2017

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 246 Answers

SOURCE: I have an appolo spa explorer model...bought it

you must have a small pump call laing if you do, air picket inside the plumbing try to turn both pump on high and wait few minutes if doesn fix try to loose the nut just a little bit with the breakers off and let the air go out. try one more time. if doesn work turn on high both pump and touch if they are working then a impeller may be broken inside one of them try to turn each one separate to find wich one as t he broken impeller.

Posted on Oct 29, 2009

macdirk
  • 116 Answers

SOURCE: Aqua flo master piump is

Thermal switch should not be causing the problem. It is much more likely that the problem is the motor, or shorted wiring. If there is a thermal overload switch it will be mounted inside the tail of the motor, but you may need to completely pull the motor apart to get to it. Is the breaker tripping only when you turn the pump on? what I mean is if the pump is off will the breaker reset, and then only trips when you try and turn on the pump? check wiring closely where it comes into the motor, and look for bad insulation where it might be touching the frame or another wire. If your familiar with motors and windings, you can also disconnect the wires from the motor and check the windings with an ohm meter. How old is the pump? and how long has it been installed. Is this a new problem on an old installation? or did you just install the a new motor? Also if you still suspect the motor, might be worth taking down to a pool pump repair shop if there's one near by most will test a motor for you for free. If you need more help, post a comment and'll I'll reply asap. Good Luck!

Posted on Sep 19, 2010

adamh294
  • 310 Answers

SOURCE: I was told that the Aqua Flo Master Xp2 Spa pump

I responded to the previous question in regards to the motor only. The xp2 does not have the strainer basket that the max-e-pro has . If this was a regular hot tub, the xp2 would work great, if this is above ground, then you do need a pump with a strainer basket. Again the xp2 will not work for an inground hot tub as the set up is different than an above ground unit.

Posted on Jan 13, 2011

Testimonial: "Thank you so much. That helps alot. Do you have any other suggestions for a pump tha might be less expensive then a Max E Pro?"

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Control panel and no pumps


do you have the control box cover off? some have a safety switch that will shut the tub down if the cover is removed..find this button and tape it down.. check the rest of the switches for proper operation..either from remote or on the unit..its a process of elimination thing.. I have been doing this for 4 days on our tub.. its finally heating now..only thing is the air blower is not working..

Jan 05, 2014 | Aqua Flo 1 HP Aqua-Flo Pump: 1.5" in/out,...

1 Answer

How do you reset an imperial hot tub flo control panel? this one is 10 yrs old.


shut it off entirely .. unplug..reconnect and power it back up reset all settings..

Nov 21, 2013 | Qca Spas Dream Series Dream Master Hot Tub...

2 Answers

Power trips out when jets are switched on


I'm going on somewhat limited information here not knowing if the tub is newly installed or if this is a spa that has been working in the past and just started doing this. It would be helpful to know if this is a recently installed pump as well. That said here are a few things to check.
If it's a new install: Your electrician has more than likely wired the spa incorrectly. Be sure that the spa pack has 220V going into the pack and that the GFCI is wired correctly.
If it's an old spa with a new problem: A lot of times a bad heater element can cause a spa to trip the breaker. If you have a bad element the spa will operate normally for about a minute when you turn the power on, then trip the breaker as soon as the heater kicks in.
If it only trips the breaker when the pump is turned on to high speed, more than likely there is a problem with the wiring of the pump or the relay on the pump itself.

May 04, 2013 | Aqua Flo Aquaflo Flo Master Xp2 Spa Pump...

1 Answer

I was told that the Aqua Flo Master Xp2 Spa pump 1.5 hp 2 speed pump was the equivalent to the Sta rite Max E Pro 2 speed pump but then from another source was told that the Aqua Flo was not made for in...


I responded to the previous question in regards to the motor only. The xp2 does not have the strainer basket that the max-e-pro has . If this was a regular hot tub, the xp2 would work great, if this is above ground, then you do need a pump with a strainer basket. Again the xp2 will not work for an inground hot tub as the set up is different than an above ground unit.

Jan 12, 2011 | Aqua Flo Aquaflo Flo Master Xp2 Spa Pump...

1 Answer

Hot tub pump flo-master hp suddenly wont start. it' one year old and was working perfectly. air side started to make a squealing noise the night before. draining hot tub to check volute to make sure motor...


The fault is most likely to be the condensor. They can and do fail at an early age.

You don't need to dismantle the pump, on the rear of the pump you'll find a slot on the motor shaft which can be turned with a screwdriver.

If you've only just reffiled the hot tub it could also be an airlock.

Regards,
Ian.
http://hottub.synthasite.com

Apr 18, 2010 | Aqua Flo Aquaflo Flo Master Xp2 Spa Pump...

1 Answer

The flo, cool, and a temp of 53 but the heat indicator is not on?


Assuming that pump 1 works ok on low speed...

Try removing the filter(s) and see whether or not this clears the fault. If the fault has gone install some new filters.

Apr 15, 2010 | Qca Spas Jewel Series Topaz Plus Hot Tub

1 Answer

Pump shuts itself off


Fill the tub with water, disconnect the supply pipe to the pump and ithe head of water should push out any air

Make sure you can get the hose back on easily before you fill the tub other wise you are going to get wet

Oct 09, 2009 | Aqua Flo Aquaflo Flo Master Xp2 Spa Pump...

Not finding what you are looking for?
Aqua Flo Aquaflo Flo Master Xp2 Spa Pump 1.5 Hp Two Speed  Logo

Related Topics:

776 people viewed this question

Ask a Question

Usually answered in minutes!

Top Aqua Flo Pool & Spa Experts

Ian Kime
Ian Kime

Level 2 Expert

77 Answers

Bill Jordan

Level 2 Expert

372 Answers

Jay Finke
Jay Finke

Level 3 Expert

1338 Answers

Are you an Aqua Flo Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...