Question about Bissell 37603 Upright Vacuum

1 Answer

No suction i have a bissell lift off revolution vacuum. I have cleaned all the filters and emptied out the canister made sure that the hoses are not plugged but it will not pick up unless you use the hose. the floor brush is clean and still no suction coming from under the vacuum... could you help me please

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert that gotĀ 5 achievements.


    An expert whose answer gotĀ voted for 20 times.


    An expert who has answered 20 questions.

  • Contributor
  • 48 Answers
Re: no suction

Is there a blockage in the small hose in the bottom of the machine
take of the pod and you will see the small hose,
Is the main hose pushed into the bottom housing

Posted on Nov 22, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Very poor suction

Hi Tina. I understand how frustrating no suction can be for I have the same vacuum at home.

Dirty filters or clogs can reduce the suction. Here is a quick link to troubleshooting steps to assist you:

Mar 28, 2013 | Bissell LiftOff Revolution Pet Vac 37602...

1 Answer

No suction on the bissell lift-off revolution

I had the same problem. In the water resevoir, there is a red flap that allows the dirty water to flow back into the water tank. Lift that flap up and there is a small red screen. Pop that screen out with a butter knife and rinse it out. I have dogs in my house and that screen was blocked by dog hair. I cleaned the screen, popped it back in and it works like a new machine. You would think Bissell would address this roblem on their web site but they don't.

Mar 09, 2009 | Bissell Lift-Off(R) Revolution(R) Turbo...

1 Answer

No suction with attatchments

if you have cleaned all the filters, there are two you need to wash and the hepa on the back may need to be changed, but the hose is probablly clogged. You can usually remove the hose ( twist it where the hose connects to the machine ) and use a broom stick to try and push the clog out.

Jan 12, 2009 | Bissell Lift-Off(R) Revolution(R) Turbo...

2 Answers

Motor gets hot and stops running

Make sure all filters are clean, also check the inlet by the brush roll isn't clogged as well as the hose. If this is all ok, then there is a problem with the motor. There is a thermo protector that comes with the motor that could be bad.

Nov 29, 2008 | Bissell Lift-Off(R) Revolution(R) Turbo...

1 Answer

Bissell Lift-Off Revolution keeps clogging

Sounds like it is partially clogged. That yellow thing you are talking about, twist it and it should come out, clean or replace the filters, then re-install it. Check the hose and make sure there isn't a clog in it and clean any other filter. One problem with this bagless is the filters will clog up fast and need to be cleaned on a regular basis. Another place a clog happens is in the inlet by the brush roll.

Nov 07, 2008 | Bissell Lift-Off(R) Revolution(R) Turbo...

2 Answers

Loss of suction bissell vacume

that is normal for the vacume to shut off if the motor overheats you must keep teh dirt cup clean and empty and all the filters clean, when you empty the dirt cup if you have a lot of pet hair take the hose off and make sure that it is clean as well, and do not try to pick up any of those cleaning wipes that will stop it up real quick

Sep 29, 2008 | Bissell Lift-Off(R) Revolution(R) Turbo...

1 Answer

Hair gets stuck in upper filter basket instead of going into the lower basket that you are supposed to empty. It is a Bissell 37604 Lift-Off Revolution Pet Bagless Upright Vacuum Cleaner

Check both filters. If one or other is increasingly dirty, wash or clean it out. Also check the air waves leading to the bagless bin canister part. If one air way is blocked the remaining dirt will try and access the bin other way due to the natural vacuum suction aspect.

Apr 19, 2008 | Vacuums

1 Answer

Clogged Bissell

Something must be in the hose causing a clog, take the hose off and if suction is good where the hose hooks up, then there is something caught inside the hose.

Mar 23, 2008 | Bissell Lift-Off(R) Revolution(R) Turbo...

1 Answer

Bissell Lift Off pet revolution vacuum losing suction

You may have a clog in the hose. Unhook the hose and see how the suction is there, if ok, then check the dirt inlet by the brush roll. If suction is low at the hose, then there is a clog in it.

Mar 20, 2008 | Vacuums

Not finding what you are looking for?
Bissell 37603 Upright Vacuum Logo

Related Topics:

155 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bissell Vacuums Experts


Level 3 Expert

18259 Answers

Roger Potts

Level 3 Expert

694 Answers

Brad Brown

Level 3 Expert

13369 Answers

Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides