Question about Sony STR-DE1075 Receiver

Open Question

NO SOUND from my Sony STR-DE1075

WIthout warning my Sony STR-DE1075 stopped working. It had been fine then one day I turned it on adn NO SOUND. All the light go on but I cant get any sound at all. I have a SACD hooked up w/ optical and Multichannel. Nothing works, not even the tuner. The only way my receiver makes a sound is if I play a dvd and then hit the multichannel button. I do not know why that is the only function that works. I have a ipod connected, a XBOX 360 and my television. Only the SACD will work and now it wont work unless I select multichannel. It used to work with the optical but not any more.

Posted by on

2 Suggested Answers

  • 2 Answers

SOURCE: error 12 message on my sony multichannel av receiver str dg 510

error 12 is what you get if you autocalibrate and do not have the microphone attached.

Posted on Jan 01, 2009

  • 1 Answer

SOURCE: Connecting two mulitchannel devices into one receiver

I guess you could try y cable adapters for input on the Denon. Might get messy. Try radio shack and pick up 5 y cables for the speakers and 1 for the sub. Someone probably makes an audio switcher that handles that as well.

Posted on Mar 29, 2009

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


1 Points

Related Questions:

1 Answer

How do I connect a turntable to what input

Hi Alvan!
The Turntable should be plugged in the PHONO Inputs in the back of the unit
It is is the Eighth Set of connectors looking at the back from left to right.
Here is a link to your operating Manual.
Best of Luck
Sony STR DE1075 Operating Instructions Manual

Oct 04, 2015 | Sony STR-DE1075 Receiver

1 Answer

Problem turning unit on

it may have an internal shout somewhere causing the speaker protection relays to kick out..

Jan 18, 2014 | Sony STR-DE935

1 Answer

Need to replace volume knob

Did mine years back - need to find part RV1802 1-418-773-11 ENCODER, ROTARY (MASTER VOLUME)
Volume went up and down turning in one direction. About 2 hour job, pull both knobs off, remove cover and front plate to get to volume switch assembly, replacement part requires desoldering and solder on new part.

Nov 24, 2013 | Sony STR-DE1075 Receiver

1 Answer

STR -DE1075. I lose surround but can restore after turning up volume then reducing it.

Not sure if you can fix it, but looks like internal capacitor charging problem, capacitor leaking causes this kind of issue, raising volume is charging the driver capacitors to keep surrounded speakers up, thats my guess, however it needs careful inspection to resolve. So advice would be to show it to the mechanic.


Oct 27, 2013 | Sony STR-DE1075 Receiver

2 Answers

I have the sony str-de1075 reciever.i want to hook up a sub-woofer.but it only has 2 single port.not your reg.rca ports.what do i do..thanks..

Sorry but it's not clear enough what kind of subwoofer (passive or active) you want to use. The passive one has no power supply connection, the active one has a power supply connector and the audio connector can be connected at the "audio out" for the subwoofer, at the rear panel of your STR-DE1075. Take a look at this photo:
In case you need a user manual for your receiver, here is an official link.

In case of a problem or clarification or further details needed, don't hesitate to post me a reply before rejecting my answer.
If you are satisfied, rate my solution with the "thumbs" or (even better) add a testimonial.

Thanks and regards
Please kindly rate this solution
direct FixYa link:

Jul 22, 2011 | Sony STR-DE1075 Receiver

1 Answer

Input from IPOD - I want to play music from my IPOD through my Sony STR-DE1075. I have an IPOD line out adapter. cannot figure out which input I should be using.

Any input as AUX , DVD or Tape will work fine ..whichever you connect.and/or available...But please do not ever use the "Turntable" input...make sure volume of IPOD is half way open as listening earphones not max..good luck..

Jan 07, 2010 | Sony STR-DE1075 Receiver

1 Answer

5.1 Surround sound not working

Maybe the surround processor is having a bad day... My kenwood would do similar and a reset was necessary to correct. Have you tried resetting the system? On my Sony STR DE 597 this is accomplished by powering off. Then while holding the 2 channel button down (front face plate) power on. A reset message is displayed. Your model may be similar but check your manual or download the PDF of the manual from Sony's support website. Hope this helps

Sep 05, 2009 | Sony STR-DE685 Receiver

1 Answer

Sony str de405 receiver...was working fine, now no sound

I have a problem with vintage reciever Sony STR-11L. Power transistors were replaced and I dont know what were original ones. Sound is no good and radiator is hot-I think problem is in replacement. Can anybody help me with?

May 14, 2009 | Sony STR-DE405

1 Answer


Try disconnecting the Speaker that fell, and then turn the unit on. If the protect signal goes away, There is probably a problem with the speaker and it will have to be repaired/replaced.

Nov 08, 2007 | Sony STR-DE1075 Receiver

Not finding what you are looking for?
Sony STR-DE1075 Receiver Logo

Related Topics:

110 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Audio & Video Receivers Experts


Level 2 Expert

110 Answers

Cindy Wells

Level 3 Expert

4719 Answers

Pieter Vleeshouwers

Level 3 Expert

1315 Answers

Are you a Sony Audio and Video Receiver Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides