Question about Hoover U5753-900 WindTunnel Bagless Upright Vacuum

1 Answer

Left side of Hoover Windtunnel won't pick up dirt and hair

I have a Hoover windtunnel bagless. I empty it after everytime I vacuum and I shake out the filter.It will vacuum, but it leaves a line to the left undone - - it is like there is no suction on the left side of the vacuum. It will just leave a line of dog hair. The middle and right pick up just fine (maybe not as well as it should - but doesn't leave the lines and hair)What would be causing this?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Hoover Expert
  • 357 Answers

Take it to your local vac shop for repair. They can help you. It needs to be serviced annually anyway to perform properly.

Posted on Aug 08, 2017

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Repairman can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Repairman (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 126 Answers

SOURCE: hoover s3755 bagless windtunnel canister

Very likely it's the cord at the nozzle neck. These cords flex when you vacuum and they often break internally where the cord goes into the neck. Turn the vacuum on and wiggle the cord at the powerhead and see if the powerhead comes on and off. If this happens, then you will have to replace the cord.
On some of the early models, the receptacle in the hose, where it plugs into the top of the wands, will break away from the plastic pins it sits in, and the receptacle will slide back into the handle, which means that it will not plug into the powerhead connection when you connect the hose. You can check this by looking at the end of the hose and observing if the receptacle is sitting flush with the opening it sits in. If it is pushed back, it will not make a complete connection with the powerhead cord that is sitting at the top of the wands.

Posted on Jan 20, 2008

  • 2 Answers

SOURCE: Hoover Windtunnel

Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door manually throught the opening under the light.

Posted on Mar 18, 2008

  • 294 Answers

SOURCE: Hoover Windtunnel spits dirt back out the back

Your problem sounds to be an obstruction in the foot (lower body) of the windrummel. Most all windtunnel's have a second cavity for suction to go over the top of the roller. When you remove the bottom plate, next remobe the belt and roller, under the roller will be a removable cavity, take it out. remove the dirt and clean out any debris. also check the suction path connecting hose. if your belt has not been changed in the last 12 months, I would recommend changing that as well.

Posted on Jan 17, 2009

  • 294 Answers

SOURCE: Decreased hose suction with Windtunnel

There are very few things left to check. First verify that the filter is installed properly, in the dirt cup. second check to make sure the dirt cup lid is on and secure. Did you use water on the round dirt cup filter? if you have you will need to replace it. To verify this remove the round filter and re-install the dirt cup on the vac. do not vacuum the carpet, just turn it on to check for proper suction. and then turn it off.

Your problem has nothing to do with it in the upright position. once turned on you will always have suction, either to the floor or when hose is removed from foot for accessories.

Posted on Jan 19, 2009

juststinks
  • 98 Answers

SOURCE: Hoover Bagless WindTunnel vacuum cleaner.

very easy. you have clog. take the brush off look where the hole is thats where the clog is. it might be in there you might have to take the housing off of the motor

Posted on May 08, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have the bagless hoover windtunnel and it doesn't pick up anything and it is very hard to push. Changed the belt and The rollers are spinning and the filter has been changed. What else can I do?


It sounds like there are dirt and hair wound around the wheel axels cousing them not to spin freely. You have to remove all hair and carpet fiber. Then drop a drop of lubricant oil on the axel.
Change the filter.
You should even Check the floor nozzle for clogged dirt.

BR
Bruce

Aug 27, 2010 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Suction not working on vaccuum.


Check for a blockage in the hose, or a tear / hole in the hose between the "pleats"

Jun 13, 2010 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Hoover Bagless WindTunnel vacuum cleaner.


very easy. you have clog. take the brush off look where the hole is thats where the clog is. it might be in there you might have to take the housing off of the motor

May 08, 2009 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

My self-propelled windtunnel bagless hoover does not pick up.


Remove the dirt cup.
Remove the filter screwed in at the top of the dirt cup opening.
Remove the hepa filters on the side of the machine.
Clean all filters and re-install them.

Feb 21, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Decreased hose suction with Windtunnel


There are very few things left to check. First verify that the filter is installed properly, in the dirt cup. second check to make sure the dirt cup lid is on and secure. Did you use water on the round dirt cup filter? if you have you will need to replace it. To verify this remove the round filter and re-install the dirt cup on the vac. do not vacuum the carpet, just turn it on to check for proper suction. and then turn it off.

Your problem has nothing to do with it in the upright position. once turned on you will always have suction, either to the floor or when hose is removed from foot for accessories.

Dec 03, 2008 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

No suction


have u checked all of the filters. I know that when not all the filters r clean the machine will turn on but then it will sound louder and still have no suction. Most times there is a filter under dirt container thats sits above motor and if this filter is not clean the motor cannot breath. Thus no suction

Sep 29, 2008 | Hoover U6630-900 WindTunnel Bagless...

2 Answers

Hoover elite rewind with widepath


Check the hose and the dirt inlet for a blockage.

May 27, 2008 | Hoover U8147-900 WindTunnel V2 Bagless...

1 Answer

U5780-900 Windtunnel maintance / cleaning


http://www.hoover.com/pdfs/manuals/U5780900.pdf
Here is a link to a pdf file at hoover website.
It explains alot.

Feb 22, 2008 | Hoover U5780-900 Windtunnel Cyclonic...

Not finding what you are looking for?
Hoover U5753-900 WindTunnel Bagless Upright Vacuum Logo

Related Topics:

747 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18411 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1474 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...