Question about Lexicon Omega Pro Studio External Sound System

6 Answers

Device is unrecognised always day per day

I have a problem with computer to recognise USB device Omega Lexicon. I have to unplug and plug again power jack on the back , to be honest, 50 times when I get claud on my PC : find new hardware. Then I install Omega drivers downloaded from CD Omega and from Omega lexicon web site. I am doing that always every day on behind 6 months. Device was newer started on the ffirst moment, always unplug and plug in one hour before I get "green light". Sometimes is happen that in the middle of recording I lose connection and anfter that I strarting again to unplug and plug power jack again. I have new laptop compaq and four new cables which I changed up to mentioned that is not problem with cable.
Please help.
please write me on:

Posted by on

  • 6 more comments 
  • ronblu1 Nov 07, 2007

    Omega installs okay. After a while it disconnects and reconnects but is not recognized. Have to power off/on the Omega for it to be recognized. What the h*ll !! Too much time troubleshooting, not enough time creating...

  • 4Legacy Nov 28, 2007

    I have the same problem as these two do. I have to unplug and reconnect the Omega constantly, because it randomly stops and becomes unrecognized by my computer.

    The solution provided doesn't solve the issue. This is the first place I have found someone with the exact problem I do. I'm contacting Lexicon themselves as I write this. Hopefully I can get a clear answer, but I bet they'll tell me to send it in or buy another, because I fear it is the lexicon omega hardware itself.

  • Anonymous Feb 29, 2008

    Same here man, I have win XP SP2. No fixes for now, but you are not alone

  • Anonymous Mar 14, 2008

    I sadly did format my computer to find out the problem persists

  • zzzappp Jul 05, 2008

    Tried all off the above and nothing worked.

    After 15 minutes of sound, the silence steps in.

    Really a creative bummer, I also spend more time troubleshouting than creating.

    I also tried:

    • Reformating a system

    • install with windows xp/ updated with service pack 2 & 3.

    • Perfect BIOS/Drivers/Updates

    • Cubase LE no additional plugins

    • No other USB devices connected but the Omega

    • Removed option on powermanagement on basic All USB ROOT HUBs (Alow the computer to turn of this device to save power)

    • And I tried this list on a Fast laptop and workstation on both XP and Vista.

    At least my semi acoustic guitar and piano always work, they are made of WOOD ;-)

    Anyway Stay positive guys because I'm affraid that we have to find the solution together as Lexicon doesnot provide any help/solution/ driver update to overcome this problem.

    I am going to try to open the box and check out if this is a heating problem.

    If that doesnot work,

    I am borrowing a Macbook and will try out how it performes on that.

    If it works OK I will leave Windows behind and and take bite out of the apple ;-)

    If it doesnt work, we are all probably f*cked as we all have been troubleshouting through our warrenty period.

  • Anonymous Aug 16, 2008

    I bought this item in israel and i have the same problem,
    i changed the usb cable lentgh, reinstalled drivers, nothing workd.
    i think we all should agree that this product ****.

  • Anonymous Jan 27, 2009

    Same problem is occuring with me, but more often on windows Xp, I have driver's for windows 2000 and it was quiet stable I created 2 albums and it was ok.

    Try increasing the GB space on your recording software, maybe it drop's off because there's less space. I highly disregard it, but could be a shot.

    It was weird because all of a sudden it started dropping off aswell for me.

  • praveenohol Mar 24, 2009

    i have the same problem of new hardware found please help me



6 Answers

  • Level 1:

    An expert who has achieved level 1.


    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I've been struggling with this issue for about a week. My unit was locking up increasingly more often.

Two things I've noticed about my Lexicon interface:

1. Seems to be excessively hot.

2. The unit is not vented.

Yesterday, after reading a comment about the solder possibly being the problem, losing conductivity as the units warms up. I decided to run my Lexicon with the plastic case removed.

Since removing the the case, i have only had one instance where the sound stopped working, which i believe was a problem with Cubase in that instance.

I'm not sure if removing the case to keep the unit cooler is the solution. I may have improved a connection somewhere in the process of opening up the unit.

I can say that I went from getting a "new hardware found" message every two minutes to having virtually no problems since removing the case.

My next step will be to drill about 50 holes in the case to vent it before attempting to use the case again.

Best of luck to ya!!!

Posted on Jan 25, 2008

  • Jeff Palmer
    Jeff Palmer Nov 17, 2013

    This happens to me all the time. I thought it was my old laptop, which ran Windows Vista, causing the problem. However, I just got a Macbook Pro and this now happens all the time with Garage Band. Works perfectly, then stops. Very annoying.


  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Always make sure that the integrated sound card is disabled when you use your Lexicon Omega, otherwise you will get an "unrecognized USB device" message.

Posted on Aug 11, 2008

  • Level 1:

    An expert who has achieved level 1.


    An expert that has over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

This is for all of you that have problems with Lexicon Omega. I believe it was someone else here suggested a faulty manufactoring problem. Answer is to remove the casing and drill holes in it and put electrical tape over the transmitters. It works... I also downloaded 2.5 driver from Lexicon site. Vocals were scratchy but read the manual on page 25 to adjust the buffering. No more problems . Also make sure you have enough memory and a fast processor. The lexicon gets too hot,not good. Check internal settings on cubase also device drivers onin windows. As many times as I had to reboot because of locking up things had changed. Lexicon thought it was Lexicon mac and became the default. Quite an ordeal to fix this menopausal machine.
Janice, Myerland Music

Posted on Feb 07, 2010

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

The problem is a manufacturing defect: the ribbon cables inside the unit are resting on several FETs (large transister) that get very hot.

If your Lexicon is within the warranty, send it in for repair or return it to the vendor. If not, then unplug the unit, carefully remove the case, and re-orient the cables. Some people also put electrical tape on the transistors.

For more information, see this thread on the Lexicon discussion forum:

Posted on Jun 16, 2008

The problem is a manufacturing defect: the ribbon cables inside the unit are resting on several FETs (large transister) that get very hot.

If your Lexicon is within the warranty, send it in for repair or return it to the vendor. If not, then unplug the unit, carefully remove the case, and re-orient the cables. Some people also put electrical tape on the transistors.

For more information, see this thread on the Lexicon discussion forum:

Posted on Jun 16, 2008

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Format the whole systemfiles and instal it again freshly after instaling the os then u instal the drivers then checkout it willbe
working properly

Posted on Nov 06, 2007

1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Hello i opened my lexicon omega and the cd wont download, i have tried a number of things but it keeps coming up with stienberg softwear, i have registered but the lexicon omega will still not load onto...

The software is by Stienberg and is called "Cubase" that is delivered with the Lexicon. The Omega doesn't really have any software to speak of except for the drivers. Browse the software disk looking for the section containing the drivers. When you install it, it will create a Lexicon folder with the root of your C drive and in it will be an Omega folder. In that is a driver folder and a folder of help files. In the Driver folder folder you will find the installer file "Omega Setup". Launch that program to install the drivers. Please note I have one of these and it can be frustrating to get things working. Make sure in the PC in the control panel "sounds and devices" that under the tabs that the Omega is the device to send and receive and for voice. Once you have done the install, the Omega should be in the list of available devices to select as default.

Apr 16, 2011 | Lexicon Omega Desktop Recording Studio

1 Answer

Is there a way to reset the Lexicon Omega (power up holding down buttons?)

You can reset your Omega by powering on the unit while holding down the Mic USB button and the Line 3 USB button.

Dec 02, 2010 | Lexicon Omega Desktop Computer Recording...

1 Answer

I have a lexicon omaga drive but when i hook it up its like i need a 64 bit driver

Don't know what OS you're running. Omega has published drivers for Vista and 7 64-bit versions. They say they don't support XP 64, but when I hooked my unit up to my computer and the hardware install wizard came up the OS found and installed Microsoft published general USB audio device drivers for all inputs, midi, and mac USB channels of the Omega, and automatically set it as my default device. I hooked headphones into the Omega unit and could hear system sounds. So far so good. Went to My Music and fired up an audio file. Windows Media Player started up and the song started playing but I couldn't hear anything. Opened the same file with Audacity, could see the VU meters bouncing, but still no sound in my headphones. Went in to the preferences of Audacity, and manually set the speaker default to the Omega mac USB device. Hit play again and voila! I had sound. Closed the file, started WMP manually, went in to options, and again set the speaker default to Omega mac USB. Opened the same audio file and this time it played just fine. The driver files Windows used for my card were
C:\\WINDOWS\SysWOW64\, C:\\WINDOWS\System32\drivers\ks.sys, C:\\WINDOWS\System32\drivers\ksthunk.sys,
all version 5.2.3790.1830
Hope this helps everybody else with this problem.

May 21, 2010 | Lexicon Omega Pro Studio External Sound...

1 Answer

I have just tried to instaall my Omega on windows XP service pack 2. The PC recognises a new USB device and the wizard launches but fails to find a suitable driver. I cannot get to the point where I run...

Forget the wizard. Put the diver disc in that came with the lexicon. If all fails take it all out and start again after rebooting. Make sure you have a faster processer and plenty of ram.

Sep 12, 2009 | Lexicon Omega Pro Studio External Sound...

1 Answer

LG GSA E 40 L External dvd writer not recognised

you may be having conflicts with usb devices. try temporarily removing all unnecessary devices from the usb ports. unplug and then plug the drive back in. you could try another port. if all ports are in use, then unplug another device, like the mouse and plug in to that port, then plug the mouse into the writers port. i had a similar problem with a wireless usb lan that stopped another device from being recognised. when i removed the lan and replugged the unrecognised device, windows recognised it. i obviously had to use the wireless lan, so i swapped that with the mouse and it worked.

Jul 19, 2009 | LG GSA-E40L Burner

1 Answer

Omega Studio won't record to computer

The omega is like an external sound card. It has to be connected via your computer with a device driver,the software that came with the lexicon. Then you record on a software program such as Cubase.
Go to the guitar center for more help or go to google .com and type in lexicon omega. Lots of sights to look for answers or better yet go to lexicon omega's home site.

Feb 28, 2009 | Lexicon Omega Desktop Computer Recording...

2 Answers

Lexicon Omega will not play any sound on Windows XP

one of several install steps (the steps seem to vary depending on which manual you can find) mention checking your sound device setup in control panel. ON one machine I installed the sound devices were not affeted. On a 2nd PC they were changed from drivers installed with PC to the Lambda driver

Win XP settings->control panel->Sounds and Audio Devices then select Audio tab. Make sure the three areas are set up to use your PC's default drivers and not lambda's.

You may need to verify this again when reconnecting the Lambda USB cable. Sort of new but ran into this "issue" as well.

Found info in Lambda Studio Software Installation Guide I downloaded, step B following driver install.

Nov 21, 2008 | Lexicon Lambda Usb Desktop Recording...

2 Answers

Usb problem

absolutely no idea but mine does the same ok on my sisters non dell computer.......

May 02, 2007 | Tatung Elio Photo JukeBox MP3 Player

1 Answer

Installing omega lexicon desktop recording studio

Yes it's extremly tempramental, just keep repeating the proces it' will work eventually!

Feb 17, 2007 | Lexicon Omega Desktop Computer Recording...

Not finding what you are looking for?
Lexicon Omega Pro Studio External Sound System Logo

1,408 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lexicon Computers & Internet Experts


Level 2 Expert

247 Answers

aftab Nawaz
aftab Nawaz

Level 2 Expert

68 Answers

Alun Cox

Level 3 Expert

2678 Answers

Are you a Lexicon Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides