Question about Sony KDSR50XBR1 50" Projection HDTV

1 Answer

Sony KDSR50 - TV comes on then goes to a black screen - sound is fine. In the 2 or 3 mins of TV visual time, the color looks a bit off - lacking red - could this be a bulb problem? Bulb does not look blown.

Posted by on

  • scatanzaro Jun 27, 2009

    Thank you, I'll buy a new bulb.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 10,594 Answers

Hi
Its symptom of weak lamp so TV needs new lamp.
Lamp replacement procedure is written in user manual and lamp part number is as follows..
F93087600 Lamp Block XL-5100
Available in Sony Accessories Store, please buy Sony Original Lamp for TV safety.








Posted on Jun 26, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

TV comes on stays on for a short time than goes black with loss of sound green flashing light untill TV comes back on. takes maybe 2 min.


TV comes on stays on for a short time than goes black with loss of sound green flashing light untill TV comes back on. takes maybe 2 min.

Jul 11, 2010 | Sony Grand WEGA KDF-55WF655 36" Rear...

1 Answer

Sony wega kdfe55a20 screen goes black, no sound


You can pull the lamp and have a look at it. I have a tutorial on these lamps if your interested. It has a bit of detailed explanation of how it works and how you can identify damage. To view it, look at my Tips & Tricks "Kitchen Table Investigation, Projection...". I hope this was helpful.

Mar 30, 2010 | Televison & Video

2 Answers

Sony kf 50e200a screen goes black and sound turns off for min...


TV has gone into "protect mode" to do just that to protect against the damaging failure that has been detected, you will need a servicer to diagnose the failure. Good luck and Merry Christmas!

Dec 25, 2009 | Televison & Video

1 Answer

TV..everything works...but screen goes red...I smack it, it goes back to normal, but then back to red.


it soinds like a convergence problem, i would try haveing someone take a look at it

May 20, 2009 | Hitachi 65F59 65" HDTV

1 Answer

Screen goes off black...


your console might be over heated . if you continusly try to play it, stop leave it alone for around 10 minutes. get a soda watch some tv and make sure that consule is completly disconnect from the wall.

Jan 17, 2009 | Sony PlayStation 2 (PS2) Console

1 Answer

Sony kv35s66: No picture, just sound and red blinking


This should be a quick fix. Try resoldering the vertical IC. This is a small flat IC attached to a heat sink with about 11 pins. It should be marked LA7837 or something similar. That should resolve the problem.

Keep us posted.
Dan

Sep 08, 2008 | Televison & Video

1 Answer

I have a 1993 Sony Trinitron 32" TV, mod.# KU32TS46. It started with the screen going black but sound still working every 30 mins for 3mins and then it would come back on and work fine. Now it works...


This could be as simple as bad connections on the main board or the beginning of the CRT failing. Try opening up the set and carefully turning the screen control clockwise just a bit. This control shuold be the top knob on the flyback transformer (part with large red wire coming out the top). If that "fixes" the problem, then your CRT is starting to fail and you just bought time to get a new set. If that does not fix it, try looking for poor solder connections on the board.
Keep us posted.
Dan

Apr 15, 2008 | Televison & Video

1 Answer

Sony Wega Rear Projection TV, Red light flasing


I had the same problem, it because of heat buildup, and the inside is fried, you need repair

Jan 02, 2008 | Sony Grand WEGA KDF-55WF655 36" Rear...

1 Answer

Sony kv35s66: No picture, just sound and red blinking


The most common problem (I have fixed lots) is the Vertical amplifier has developed a loose connection. It probably just needs resoldering. As things expand it makes and looses connection you picture goes in and out. The vertical chip is a large black chip that gets hot, over time it degrades the solder until a connection is damaged. Most newer sets have a protection circuit that senses the lack of height, and shuts down the picture tube to save it. When the picture dropped to a line on older TVs and left that way too long it would burn a line into the face of the picture tube. You then had to have the picture tube replaced along with the vertical amp. it's kinda like a screensaver for your TV.

Nov 21, 2007 | Sony FD Trinitron WEGA KV-32FS120 32" TV

2 Answers

No Picture


Did you have color problems in past? Most of these sets have convergence problems. Amps goes out. But you should have seen some type of distortion from color, red,blue, green. If no color problems then maybe vertical ouput out or horizontal output bad.

Sep 09, 2007 | Hitachi Director's Series 65XWX20B 65"...

Not finding what you are looking for?

Open Questions:

0 Answers

Sony KDSR50XBR1 50 black screen, no faults! Lamp working, fans OK Sony KDSR50XBR1 50" HDTV: The light engine was working fine before the fan quit starting on it's own. After disassembly, cleaning and lubrication of the fan, I have no errors but the input display or menu options will not post on the screen. The lamp is on but seems to either be projecting a solid black picture, or not be at full brightness and there are no faults. I have a solid greed LED on top, but can get no picture. Sound is fine. What should the lamp voltage be at operating mode? I have tried reseating connectors and pushing on the wires to make sure the connectors seat. This is baffelling because the lamp fired fine for 1 second before the stuck fan issue was corrected and I have no faults now after lubricating the fan. I'm going to check connectors again today as a triple check; as I did remove the power supply. The TV has been reset per instructions in the book. Any advice would be much appreciated but I cannot believe it's the OB as it worked fine before the fan quit and it's about 14 months old. I'm thinking something may not be assembeled correctly, but everthing seems to be pretty idiot proof for re-assembly. Also the menu or input banners will not post. I have 2 new lamps, so it's not that.It seems to be stuck in somne black screen mode. The large fan does start by itself now after cleaning and lubrication, therefore no fault blinks. Please help!!!

Mar 01, 2017 | Sony KDSR50XBR1 50" Projection HDTV

Sony KDSR50XBR1 50" Projection HDTV Logo

Related Topics:

188 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Televison & Video Experts

The Knight
The Knight

Level 3 Expert

75767 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Jerry Greenberg
Jerry Greenberg

Level 3 Expert

1689 Answers

Are you a Sony Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...