Question about Electrolux Centralux Vacuum

1 Answer

Filtex central vacuum

Not much suction--think i need an new motor

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 50 Answers

Check suction at main unit. If it is not good and the unit is empty you might need a new motor. If good there and one of the inlets is open, connect and disconnect the main line at the main unit. If it labors each time the line is connected, there is an obstruction in the line. If it doesn't labor you have a leak in your line.

Give me feed back.

Posted on Jun 27, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Upon powering up suction is low. Needs to be primed with hand on hose intake; then full suction comes back.


Turn the vacuum on without the hose.If this continues the motor may need armature brushes or the motor itself may be burned out...motors are not too expensive,I usually put "Lamb" motors in for around 139.00....Chris

May 12, 2015 | Electrolux Central Vacuum

2 Answers

Central vac not sucking


Check for a plugged tube in the wall by listening to the motor when it's running. If it sounds like it's running too fast then there's an obstruction. If it sounds ok, then there's a disconnected tube somewhere in the system.

Sep 11, 2014 | Broan-NuTone CV353 Central Vacuum

1 Answer

No suction


Use the guide at builtinvacuum.com/flowchrt.html to find the issue and solution. Most likely you need to test it without any filter and be sure the bottom of the unit is attached :) To get access to the motors you need to unbolt the very top sides.

Jul 28, 2010 | Broan-NuTone CV350 Performance Bagged...

1 Answer

Have a nutone CV-450. Suction is gone at the


The first thing to do is to disconnect the pipe coming into the unit. If there is suction there than you probably have a break in the line. If there is no suction when you disconnect the pipe coming into the unit than it is most likely the motor gasket. This gasket can sometimes get sucked into the motor causing problems. Remove the lid to the central vacuum, than disconnect the motor, you should be able to tell if maybe the gasket has been off center or if it has been sucked up in the motor.

Dec 13, 2009 | Broan-NuTone CV450 Central Bagged Central...

1 Answer

Central vacuum with new motor shuts off and throws switch


Your mini breaker is probably bad if its a new motor. Its found on the relay board and they can weaken over time, especially if you had a bad motor before that tripped it a lot.

Oct 31, 2009 | Vacuums

1 Answer

I need a new motor for my electrolux 1590 machine. What is the difference between a 2 stage & a 3 stage motor?


If you haven't got the new motor, the three stage has more suction. The 1590 CV had the three stage motor untin they changed to the two stage not long ago. You can get either one for your unit. The two stage should be a little less expensive.

Aug 06, 2009 | Electrolux Central Vacuum

2 Answers

No suction on my Electrolux central vacuum in all outlets even though motor is running and there is no clog in the hose.


go to the main unit,you have a blockage where the suction originates.can you disconnect the main suction line to the unit?do that and turn it on.if you have suction then then the main suction tube is blocked.a towel or rag of some sort got sucted in and got caught before it made it to the dirt tank please leave feedback

May 05, 2009 | Electrolux Central Vacuum

1 Answer

NO SUCTION


If you have no suction, there are only a couple of things that could cause it. As you have checked for blockage, and changed your filters, you may have a vacuum motor with bad bearings, or broken fan blades (inside/on the vacuum motor). Either symptom points towards a vacuum motor being bad and needing replaced.

Jan 21, 2009 | Electrolux Central Vacuum

1 Answer

CENTRAL VACUUM SYSTEM


Disconnect the inlet piping from the unit and check the suction there. Be sure that the utility inlet on the unit is closed. If you have good suction, you have an open/broken pipe somewhere, or possible an inlet valve or vacpan that is not sealing when closed. The easiest way to find it would be to install your tubing back into the inlet of the unit, turn the unit on, and walk around the house listening for air leaks. Good Luck!!

Jun 29, 2008 | Broan-NuTone CV353 Central Vacuum

Not finding what you are looking for?
Electrolux Centralux Vacuum Logo

Related Topics:

206 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrolux Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18390 Answers

yadayada
yadayada

Level 3 Expert

75744 Answers

Mack Baxter

Level 3 Expert

381 Answers

Are you an Electrolux Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...