Question about Gem Sound GEMSOUND EXA-3800 POWER AMPLIFIER 1600 WATTS Car Audio Amplifier

1 Answer

Gem sound exa-3950

Unable to get sound from amplifier. receiving signal but no output . the amp is a gemsound exa-3950. i have the speakers hooked up with wires

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 113 Answers

Check the rca's for a short

Posted on Jul 04, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

The amp doesn't output anything. When it is turned on the power light, left signal, and left clip light light up immediately. A few seconds later both Fault lights light up. I unplugged ever thing...


What is the make and model, it sounds like its going into overload protection, if the speakers aren't hooked up you have some bad components in the output section.

Jan 31, 2018 | Gem Sound EXA 3955 2Channel Amplifier

1 Answer

Gem sound exa-3950


You could check the 115/230 switch. If you are getting power to the unit no fuse or circuit breakers tripped, and you have 8 ohm speakers connected, and a signal in you should get a signal out. Level controls should be up. If all of those things are true, then the amp is broke and needs an electronic technician to repair it.

Jan 01, 2018 | Gem Sound GemSound PA-585 2-Channel...

1 Answer

PyLE PT2000 Power Amplifier' { is it worth it??}


People talk alot of **** about Pyle amps, all I can say is that,
I have two PT-2000 & PT-1800 power amps that I have set in bridge mode, one for each speaker and they are powering two Altec-Lansing 18" inch subs, one amp per speaker, no hiss, line noise or anything and the system kicks. I tried the Pyles on a whim because I got tired the trouble I was having with the QSC and Crown power amps, could not go a year without having something go wrong always sending back to dealer for some kind of fix! So now I have 2, QSCs, 2 Crowns & 4 Pyles driving my system

Apr 27, 2009 | Pyle PT-2000 Amplifier

1 Answer

Gem sound exa 3950 amp


Hi...
If it's a straight-up power switch then it will need to be replaced if it works off a relay then the relay is gone.

website

http://www.gemsound.com/contact.html#


Mar 24, 2009 | Gem Sound GemSound PA-585 2-Channel...

2 Answers

Gem sound 3950


Dc problem in amplifier (short circuit) needs to be serviced

Jan 05, 2009 | Gem Sound GemSound PA-585 2-Channel...

1 Answer

Boost volume of computer


HI...
Connect the "line-out" of the sound card to the "Line-in" of the GEM amp

Dec 26, 2008 | Gem Sound GemSound PA-585 2-Channel...

1 Answer

Gem Sound clipping problem


First of all the EXA-3940 is rated at 350watts per channel in to 8 ohms. The 1400 watts is bridged into a 4 ohm load. Second, the speakers can handle 1000Wats peak with an average of 600 continuous (i'm guessing). That tells me that the amp is underpowered for the speakers. The sensitivity of the amp is such that the mixer is overdriving the input stage. That is what is causing the clipping. If you are looking for more volume, you are probably better off purchasing another amp and running them in bridge mode, 1 per speaker cab. Be careful though, not to overdrive the speaker cabinets either.

Dan

Sep 21, 2008 | Gem Sound GemSound PA-585 2-Channel...

1 Answer

Manual


Contact Gemsound thru their email.

Sep 04, 2008 | Gem Sound GemSound PA-585 2-Channel...

1 Answer

Very low sound


It looks like you are taking your output off of a line level source, being that it isn't amplified.. Try the speakers on a known amplified source, if the work then just add a powered source to your system...

john



Aug 20, 2008 | Gem Sound GemSound TR-8 Speaker

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

191 people viewed this question

Ask a Question

Usually answered in minutes!

Top Gem Sound Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4979 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Marvin
Marvin

Level 3 Expert

81342 Answers

Are you a Gem Sound Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...