Question about Anthology Solutions Yellow Machine P400 (250004001) 250 GB Hard Drive Array

2 Answers

Hello! I have a YM P400T machine. It has worked great thus far. Recently the red fault light came on and the data became unaccessible. I went through and updated the software through the original install disk. It gets to the end where it says it is updating modules and gets stuck every time. I know there is a work around for this, but I'm not a RAID guy and I don't want to take the risk of blowing up a perfectly good system by tinkering. Any advice you can provide? Thank you! Ken

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 9 Answers
Re: Hello!


I have had mine running for 3 years without problem. Then about a week ago it was inaccessible. I thought it was my computer. NOT. I access my YM P400T from UNIX and Windows systems. I could not access it with NFS from UNIX either. So I logged into it as root (if you can ping it then you probably can telnet into it)...

telnet <your ym p400t ip address>

user: root
pw: sos1234 (this is the factory default)

Anyway, I found that samba was not running (which is the smb and nmb services needed to support windows file sharing). It looked as though the box had crashed and rebooted. It was in run-level 2 and should have been in run-level 3. You can see which runlevel it's in by typing

runlevel <press enter>

It will show you a 2, or 3, or "2 3" if it has come through runlevel 2 and 3.

Here's the steps:

  1. as root run mount /mnt/disk1
    1. /mnt/disk1 is the raid array, to get a status on it run mdadm -Q /dev/md2
      1. it will show: tekfs01:/etc# mdadm -Q /dev/md2 --detail
        /dev/md2: 461.74GiB raid0 2 devices, 0 spares. Use mdadm --detail for more detail.
        /dev/md2: No md super block found, not an md component.
        tekfs01:/etc# mdadm --detail /dev/md2
        Version : 00.90.00
        Creation Time : Sat Feb 4 18:58:39 2006
        Raid Level : raid0
        Array Size : 484166656 (461.74 GiB 495.79 GB)
        Raid Devices : 2
        Total Devices : 2
        Preferred Minor : 2
        Persistence : Superblock is persistent

        Update Time : Mon Dec 15 22:03:08 2008
        State : dirty, no-errors
        Active Devices : 2
        Working Devices : 2
        Failed Devices : 0
        Spare Devices : 0

        Chunk Size : 64K

        Number Major Minor RaidDevice State
        0 9 0 0 active sync /dev/md0
        1 9 1 1 active sync /dev/md1
        UUID : 6fb50c26:8e798528:e5f0f73b:f6582c08
        Events : 0.3

    2. There are 4 disks, 2 each are stripped and then the striped pair is mirroed to the other striped pair (in my setup)
  2. Then I had to change from runlevel 2 to runlevel 3
    1. as root run init 3
    2. you can check the runlevel by running runlevel
  3. The nfs service was running and so was RPC so I didn't have to do anything with that
  4. I verified that the /etc/passwd file was good
  5. Then as root the "samba" services need started to support windows file sharing
    1. cd /etc/rc3.d
    2. ./S20samba start
    3. Then a ps -ef should show one or more smbd and/or nmbd processes.
  6. Then the web interface needed to be brought up
    1. cd /etc/init.d
    2. ./ymm start
  7. Then turn on raid monitoring:
    1. cd /var/adm
    2. nohup mdadm --monitor /dev/md2 -m <your email address> &
All set. Should be able to connect from NFS and Windows.

Since this time I have had no errors and have used it extensively. I see the fault light come on once in a while and I log in and check the RAID and it says no erros. The syslog shows nothing. No idea why the fault light is randomly coming on. Anyway, I think I'm going to get a micronet raid and copy all the data over there before this one dies completely.

BTW, AnthologySolutions closed their doors without warning. One day all the employees showed up and the doors were literally chained/padlocked shut. I have obtained a copy of the core software and some other items.

There was a usergroup still active in march of 2007 but they appear to be gone now.

Good luck,

Posted on Jan 07, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers
Re: Hello!

I saw on ebay they had some Brand New Diskless versions and One Used Working one. I know it is not a fix but a lot cheaper than the $1200-$1500 they used to be.

Posted on Mar 25, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Yellow machine power out won't restart

You will have to get a disk recovery specialist to retrieve your data. The internal YellowBox system is Linux. The specialist will remove the disks and attach them to translation and recovery technology. It will cost money.

Dec 19, 2013 | Anthology Solutions Yellow Machine P400T...

1 Answer

I'm looking for software for my yellow machine p400t

I have the last update disk 3.3 and would be happy to upload it to a file sharing site for you.

Jun 04, 2010 | Anthology Solutions Yellow Machine P400T...

2 Answers

I lost the driver disc , did you know where can I ...

I have the last update disk and would be happy to upload it to a file sharing site for you.

May 20, 2010 | Anthology Solutions Yellow Machine P400T...

1 Answer

Step by step instructions to setting up a yellow machine P400t

Documentation is available at:

You configure it through the web GUI.

Good luck!

Apr 18, 2010 | Anthology Solutions Yellow Machine P400...

1 Answer

I have a yellow machine p400t and i need to give it a static IP address and do this through a linksys router. how do i go about this? do i need to attach it to a computer?

Yes, it must be attached to the network 0. Install the yellow machine software on the PC 1.Log on to the Yellow Machine Manager. Go to “Logging On To Yellow Machine Manager” on page 8. 2.From the Yellow Machine Manager, click Network > Network Interfaces. The Network Interfaces window appears. 3.Click Edit. 4.Select Yes to Enable LAN Interface. Default: Yes (Enabled) • If you select No, all other LAN option fields are blocked. • If you disable the LAN Interface, the only access to the Yellow Machine appliance is through the WAN port. Anthology Solutions does not recommend this configuration. 5.Check Enable DHCP Service if the DHCP service is needed for the PCs attached to the Yellow Machine appliance’s LAN ports. This setting makes the Yellow Machine appliance the DHCP server for your LAN (or sub-network), providing IP addresses dynamically for the clients connected to the LAN ports. Default: Checked (Disabled) 6.Select either Obtain IP Address Automatically from DHCP Server, or Static IP Address. Default: Static IP Address • Choose Obtain IP Address Automatically from DHCP Server if your Yellow Machine appliance connects to either a router that has DHCP service enabled or to a cable modem. This setting makes the Yellow Machine appliance a DHCP client on your network. • Obtain IP Address from ADSL provider is greyed out. • Choose Static IP Address if your network is locally defined and controlled and does not use DHCP services. Type the IP address manually. 7.Specify IP address and Subnet mask if you selected a Static IP Address, and click Apply. 8.Click Yes to confirm, No to abort. The changes takes affect within five seconds after the network interface change notice appears.

Jan 26, 2010 | Anthology Solutions Yellow Machine P400T...

1 Answer

Unable to acces yellow machine p400t

Set your PC networking to Obtain IP Automatically and see how you go

Nov 26, 2009 | Anthology Solutions Yellow Machine P400T...

1 Answer

Yellow machine server.

Is it just the fault led, let the machine run for a while and see if it starts rebuilding the drives, if it is NEW and you have just installed the drives and never installed the software then you will get a fault I have the q400t which is the platnum version tho they still call it the p400t if you have just received the server then what u must do is power off the server plug in the netcable into one of the 8 lan ports run the install till it tell's you to turn it on then hit next then follow the instructions to setup the server

Dec 30, 2008 | Anthology Solutions Yellow Machine P400T...

1 Answer

How do I set up the P400T Platinum to be used as a Domain Server?

You can configure it through the web GUI.

The unofficial support website is:

The manual there will give you the info. I'm not sure it will do ddns.

Good luck,

Mar 25, 2008 | Anthology Solutions Yellow Machine P400...

1 Answer

Shows drive is full but there is almost nothing on it

Ths is possibly caused by a FAT / TOC error and it may be possible to resolve this using a chkdisk or perhaps scandisk or whatever management tools come with this item.

Jul 18, 2007 | Anthology Solutions Yellow Machine P400T...

Not finding what you are looking for?
Anthology Solutions Yellow Machine  P400 (250004001) 250 GB Hard Drive Array Logo

527 people viewed this question

Ask a Question

Usually answered in minutes!

Top Anthology Solutions Network Storage Systems Experts

Gareth Cockram
Gareth Cockram

Level 3 Expert

657 Answers

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Are you an Anthology Solutions Network Storage System Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides