Question about Soundstorm F2600 Car Audio Amplifier

1 Answer

Amp has Red LED light on.

When I was turning my volume up. My subs died. I have a F2600 pushing 2 10"subs. The green power LED is not on, but the RED Protection LED is on. Can you Helf

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

Disconnect all speaker wires and signal cables from the amp. If it powers up, the wiring needs to be checked. If it still shuts down, the amp likely has blown output transistors.

Posted on Nov 05, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Cadence 400 watt active sub green light on, no sound from the sub. whats wrong?




proceed according and fix it. However yi\ou must read the diode LED for diagnose. God bless you

Mar 26, 2013 | Exercise & Fitness

1 Answer

Tv turns off on its own. power light now blinking red, tv not on


Unplug,replug,push the popwer buton couples time,see if stable green LED light,should get tv pic& suond back, not replaced the backlight video board it some how die.

Nov 26, 2009 | Televison & Video

1 Answer

Csa300.1 bazooka 500 watts


sounds like you may have blown your sub...sheck the spyder inside of it and see if it is stiff..if the speaker doesnt seem too responsive when you press on it, its probably blown...

Aug 01, 2009 | Bazooka ELA300.1 Car Audio Amplifier

1 Answer

Pyle dryver amp light protection stays on not green light stays red i have tried to disconnect everything and plug it back up but light stays red


check your subs disconnect them the try to power the amp up if it powers up the the subs have died and it could be a problem with that amp i suggest you get a better amp

Jul 09, 2009 | Pyle Dryver PLAD213 Car Audio Amplifier

1 Answer

Green power light comes on for a split second, then red.


The power supply (AC adapter) is bad. It has enough power to light the red LED, but not enough to power the TV.http://shop.ebay.com/?_from=R40&_trksid=m38&_nkw=12+volt+5+amp+power+supply&_sacat=See-All-Categories

May 23, 2009 | Proscan 19LA25Q 19 in. LCD Television

1 Answer

1000 w sony xplode works at low volume then red lights at volume5


Most likely one of your subs are blown, or the Ohm's are too low for the ampliphier. Try hooking up one speaker at a time to the amp and see if it does the same thing. If it shuts off on one of the two speakers, that speaker is most likely blown.

Apr 19, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Fusion amp . the green light is on but when i turn the volume up the red led light is flashing but gleen led is still on and sub goes a quiet bass sound .


First your need to make sure that the amplifier is grounded properly. And verify that all other connections are as well. Unfortunatelly, i wouldn't be able to help you because i need to be in front of it to troubleshoot. Hope you fix it.

Nov 11, 2008 | Car Audio & Video

1 Answer

My "Power Acoustik OV2-420" has a problem. Some advice please!!!


It appears that the output transistors have failed. To eliminate other possible causes, read through the following page. Let me know if you have any other questions.

Amp in Protect Mode - Troubleshooting

Oct 04, 2008 | Power Acoustik GOTHIC OV2-1200 Car Audio...

4 Answers

Red light


something is shorted in the circuit, or your subs. unhook the subs first and try it again, if it is still in protect then it is most likely the output transistors.

Feb 22, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Power light


This could be a DC offset condition. Check you manual for what this means. Or other condition. First Disconnect the Subs and try it. If it still goes red then disconnect the RCA's and try it again. If the Led continues to go red after the click then the Amp is hosed. The Click you hear is an internal relay that cuts the subs in after a dely so you do not get the turn on THUMP of the radio at your subs.

Jul 08, 2007 | Hifonics Titan TX 8805 Multi-Channel Amp...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

169 people viewed this question

Ask a Question

Usually answered in minutes!

Top Soundstorm Car Audio & Video Experts

hoyzee1

Level 2 Expert

150 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Jim Goldsmith
Jim Goldsmith

Level 3 Expert

2005 Answers

Are you a Soundstorm Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...