Question about Hoover Power Scrub Upright Carpet Washer - FH50150

Open Question

I bought this carpet cleaner today. Suction works fine. When I plug in the hose there is no suction at all. What am I doing wrong?

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
reddevil6
  • 1673 Answers

SOURCE: Problems with the Hoover Steam vac Heated carpet cleaner

This happens when the filter on the inside of the lid for the dirty water tank is pushed all of the way up. You need to leave a 1/4 in. gap from the top to the top of the filter.

Posted on Jan 10, 2008

Ad
  • 12 Answers

SOURCE: Problems with the Hoover Steam vac Heated carpet cleaner

You'll have to go into the turbine assembly and check the bearings. Mine stopped spinning and this solved that problem. I simply began working the seized bearing until it rolled again, packed it in grease and reassembled.

Posted on Feb 09, 2008

  • 13 Answers

SOURCE: plugged hose on Hoover Windtunnel

you will have to remove the bottom cowling under the vaccum cleaner there are 4 phillips head screws one at each corner when you turn over the vaccum cleaner, take this off and remember how it goes back on. in the area where the hos is there will probably be a clog at that point. remove this and pull hose off and make sure it is not clogged farther up the hose, reinstall and check

Posted on Dec 31, 2008

  • 4088 Answers

SOURCE: brush spin,good suction at hose, no suction at

Air passage from back of brush head, through the joint, and up to bag, may be blocked.

Posted on Jul 12, 2009

USSWisconsin
  • 2 Answers

SOURCE: My cleaner does not have any suction and I clean

Have you cleaned the filter in the top of the unit?

Posted on Oct 14, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does my machine vacuum has very little suction while the there is no solution come out of the hand hose?


Make sure you have the hoses hooked up properly. Also check that there is no obstruction/blockage in the hose. Otherwise, contact your friend.

...

Apr 26, 2016 | Vacuums

2 Answers

Mt dyson has too much suction


Hi there, it's Jack at Dyson.

I'm sorry to hear you feel your DC40 has too much suction. This sounds unusual, and in order to help you resolve things we would need to take some further details about your machine, and the particular flooring type you're having difficulty with.

When you have your machine to hand, please call us directly so we can talk you through some simple troubleshooting checks to make sure everything is correct with your DC40. You can reach us on 0800 298 0298 (UK), 1-866-693-9766 (US), 1-877-397-6622 (CA) or 1800 239 766 (AU).

We'll look forward to speaking with you.

Sep 27, 2014 | Dyson DC40 Animal Upright Vacuum -...

2 Answers

Plenty of suction from the hose pipe itself but no suction when vacuuming the carpet


Hello Can,

Go through this guide to help find the issue www.builtinvacuum.com/flowchrt.html. You should have suction without a filter. The bottom is on the unit, right? It needs to be air tight.

Apr 21, 2011 | Vacuums

1 Answer

I have a dyson 07. Vacuum works fine, great suction using the hose. How do I switch to using the carpet vacuum. (I lost my instruction book) Thanks


If this unit has a suction hose built in to the handle, the carpet vacuum should start working after you return the handle hose to the proper position.

Dec 01, 2010 | Dyson DC07 Bagless Upright Cyclonic Vacuum

1 Answer

TOO MUCH SUCTION


Clearly no one read the question problem is not low suction but too much

Sep 24, 2009 | Dyson DC07 Bagless Upright Cyclonic Vacuum

1 Answer

I have a Kenmore Progressive Inteleclean Upright vacuum cleaner (with Bag) . It has good suction only through the hose now and none through the bottom for cleaning carpets. and, there is a noise like it...


Theres a little bendable neck that hose with suction plugs into. Thats the one thats clogged. You will have to fish it out by taking off the roller and clearing the clog.

Sep 22, 2009 | Kenmore Progressive Bagless Upright with...

1 Answer

No suction for upholstery hose


http://www.hoover.com/pdfs/manuals/F5914900.pdf try priming your hose

Before using tool
It may be necessary to remove air from
the system (“prime the pump”) so the
clean solution will flow to the tool. Follow
these steps:
1. Attach tool to hose and turn the carpet
cleaner ON.
2. Put the tool on a hard surface or
against your hand to block off the suction.
3. Wait a few seconds (can take up to
15 seconds). Then squeeze the trigger
and begin cleaning.
Follow the instructions on pages 14 and
15 for the appropriate cleaning task.

Godbless

Jun 18, 2009 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

I have a u3450 1500w hoover, suction on hose works fine, but carpet suction has never worked, how can i fix this?


There must be a restriction or blockage in the carpet suction pipe. Look at the port where the hose connects to the machine and check for any accumulation of debris or blockage. The same motor drives both suction inlets so it can only be that there is an obstruction.

Nov 02, 2008 | Hoover Vacuums

1 Answer

No hose suction with replacement bag


The Bag must be blocking the port it connects to. Remove the bag and close it up. Test it again with no bag in it. If you have suction now, the bag is blocking the port. Maybe it is the wrong type, or installed wrong.

Feb 24, 2008 | Kenmore 28075 Bagged Canister Vacuum

1 Answer

Sudden loss of suction.


Check the inlet down by the brush roll to see if it is clogged. Also check the belt to be sure it is ok. Is there suction at the hose? If not then it is still clogged.

Oct 30, 2007 | Kenmore 33721 Upright Vacuum

Not finding what you are looking for?
Hoover Power Scrub Upright Carpet Washer - FH50150 Logo

Related Topics:

60 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Heating & Cooling Experts

Paul Carew

Level 3 Expert

2557 Answers

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

Donni Steen

Level 3 Expert

659 Answers

Are you a Hoover Heating and Cooling Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...