Question about NEC Versa Gold Submersible Pump

1 Answer

Running pump stopped

Pump was running in the water but was taken out and left unplugger for a day now will not run. impeller is fine what else can I check

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

I assume that the plug in is working properly. Always check power supply first. Is there a GFCI circuit that it is plugged into. Then check the pump to make certain it us turning. How long had it been on before unplugging it. It could be worn out. Sometimes it takes a jolt to start the motor again. How big is the motor. Possible bad capacitor. Could be a solid state motor, then it's bad. Is it a magnetic motor, that could be turning the wrong way.

Posted on May 18, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Intex impeller


replace whole pump

Apr 19, 2017 | Pool & Spa

1 Answer

Intex impeller


The motor is not able to produce enough power to move the water and it is probably overheating when it tries. The cracking is secondary to the real issue. I would replace the whole pump.

Mar 02, 2014 | Pool & Spa

2 Answers

Intex pool pump runs for five minutes and then shuts down and service light comes on. What could be the problem as it was running fine the day before?


We don't have a service light on our pump, but usually when our is playing up it's because the pump is struggling to push enough water through - for example if the filter needs changing or if the skimmer isn't receiving enough water/water level is too low.

Nov 04, 2013 | Intex Automatic Salt Water System for ...

1 Answer

Water not pumping


Is the pump running? If so I would say you lost your impeller. If not running I would check for a circuit breaker for the motor.

Apr 10, 2013 | Intex Automatic Salt Water System for ...

1 Answer

Overheats. runs fine when idiling.holding the fan off, and a/c on still cant make it overheat but once driving for 5 mins starts to overheat. replaced thermostat, water pump looks to be fine. cleaned rad....


Water pump. The impeller will slip on the shaft. As you said runs fine at idle, but when you run it harder the impeller doesn't spin fast enough (slips). Causing it to over heat. replaced to many for this problem. Also The pumps that have the metal impellers will be tight when cold, don't let this fool you. when they heat up they slip.

Jul 20, 2011 | Mazda B-Series Truck Cars & Trucks

1 Answer

I have- starite pump it was working fine last night but this morning there was no pressure at all i wonder if is the water tank the pump is running fine but there is no water


It sounds like you have blown your shaft-seal. When this happens the pump runs dry. If you know that you have water but it will not pump, and all the cover and housing o-rings are good, it is the shaft seal. (unless the internal impeller is just broke, but this is unlikely)
Fix: Turn off power. Remove V-clamp holding wet end together. Remove diffuser inside wet end (need flathead screwdriver).
next remove rear electrical panel on the motor. Using s 7/16" wrend, hold the end of the motor shaft by the electrical end (where you removed the cover) while turning the impeller counter clockwise (note: some impellers have an impeller screw inside which unthreads CLOCKWISE) untill impeller is off. Replace carbon shaft seal inside. Reverse and prime and then restore power and start.

Oct 20, 2010 | Sta Rite StaRite DuraGlas Pump 34 HP...

1 Answer

Our pump was running dry for at least a day because a leak dropped the water level below the skimmer. it runs on 220 and sounds like it's running but no water movement in or out. i need a new pump, right?


not necessarily if running may need to be bleed[air bound and need to let out air ]or may need to be primed if there is a bleeder on pump housing un- screw to release air until water runs out --- if still no water pumping may have damaged the impeller depending on ur pump may have to only replace impeller or pump housing

Jul 20, 2010 | Hayward Sp2607x10 Super 1 Hp Swimming Pool...

1 Answer

Hi, I have a Triton Power shower, it has worked fine for the last few years but today the water stopped. The pump is still running but nothing is coming out. Would you have any ideas. Thanks, Gary


Hi Gary, Sometimes things like pieces of worn out faucett washers get in the shower head water line and clog things up. The only alternative is to disconnect the plumbing starting from the shower head back to the wall and start removing the pieces of rubber. There could be a problem with the impeller in the power shower pump but again you would have to gain access to the pump impeller and inspect it for damage. An impeller can fail in may ways... most of the time it is either broken blades of a broken hub of the impeller. Other times the housing for the impeller can be broken and water bypasses inside of the pump vs exiting the pump.

Thanks for using FixYa.

Kelly

Jun 03, 2010 | Home

1 Answer

My kenmore washing machine fills with water but will not wash..it sounds like its doing something then it stops after a while i hear it drain and then stops again..water doesnt spray..I let the dishwasher...


Often these work by reversing the motor which has two pump impellers. One direction will pump the water out and the other will pump it through the spray bar. IF the one pump impeller has broken then that would explain your symptoms.

If this is the type you have, verify that the motor is running reversed from when it is draining. If it is not running during wash time, then the timer is probably at fault. If it is running, check for broken pump impeller for the was direction.

Sep 29, 2009 | Kenmore 24 in. 16193 Stainless Steel...

2 Answers

Mariner 25hp 2stroke outboard. runs fine when


With what you said.get the water pump done.A little bit of rubber is cheaper than metal.If the motor has a few years on it,the pump does need to be replaced.If the motor overheated after a few minutes,the pump needs replacing now.Yours sounds like it's on it's way out.A bit of sand etc. can do a fair bit.Hope this helps

Sep 09, 2009 | Boating

Not finding what you are looking for?
NEC Versa Gold Submersible Pump Logo

123 people viewed this question

Ask a Question

Usually answered in minutes!

Top NEC Garden Experts

Dennis Key
Dennis Key

Level 3 Expert

2478 Answers

roeb

Level 3 Expert

603 Answers

john h

Level 3 Expert

12650 Answers

Are you a NEC Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...