Question about Garden

1 Answer

Victa trimmer Hi there, the trimmer start well but loose power when I press accelerator.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 194 Answers

Have you contacted the manufacturer? Here is their website with product support assistance. They should have the best information.
http://www.victa.com/au/support-centre/

Posted on May 16, 2014

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad
  • 124 Answers

SOURCE: My hedge trimmer looses power when I accelerate

This could be several things but most likely the engine has low compression which reduces the suction pulling gas through the carb or the carb might just not be able to supply the gas the engine needs. If you can adjust the carb open the high speed needle a quarter of a turn to see if that helps. If you can not adjust the carb you will need to take it to a dealer for the adjustment.

Posted on Sep 20, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kia Sedona cold start problem


Have the automatic idle system tested. It could be that the control valve needs a cleaning.

Jun 17, 2017 | Kia Sedona Cars & Trucks

1 Answer

My hedge trimmer looses power when I accelerate


This could be several things but most likely the engine has low compression which reduces the suction pulling gas through the carb or the carb might just not be able to supply the gas the engine needs. If you can adjust the carb open the high speed needle a quarter of a turn to see if that helps. If you can not adjust the carb you will need to take it to a dealer for the adjustment.

Sep 20, 2009 | Garden

1 Answer

Toro String trimmer will not start; good spark; getting gas


Hi this would be the only possible solution , The flywheel may have come loose causing the keyway to sheer off this is a common problem the only way to tell is to remove the flywheel and have a look.

Jul 14, 2009 | Poulan 25cc 2-Cycle Gas Powered String...

1 Answer

Weedwacker stalls when accelerating


Check the fuel lines for cracks/breaks. If they are o.k., then:

You willneed to disassemble the carburetor and spray with carb.cleaner. Makesure the small screen is free of debris.(Should be able to see daylightthrough it.)

Use a Den Tek Brush, (http://www.drugstore.com/products/prod.asp?pid=165357&catid=1152),to clean the small portals in carb. These portals can become blocked. Reassemble and start.

If the carb. parts are more than 4 years old, you may have to replace them.

If you need further assistance, just let me know.

Jim

Jun 21, 2009 | Craftsman 25cc Gas Line Trimmer

1 Answer

Husqvarna 323L gas trimmer runs & starts great but looses power after 10-15 min and if you give it gas it dies. let it cool and it runs great for another 10-15min. trimm has less than 5 hours


You have a clogged gas cap. Try this: The next time you run your trimmer and it starts to die, loosen the gas cap. It should start running again. It sounds too good to be true, doesn't it?! Well, give it try. Clear the breathing holes form debris, or buy a new gas cap.

Jim

Jun 07, 2009 | Husqvarna 28cc Gas Line Trimmer

1 Answer

Please help me to stat this thing I have no manuel


When I first got my brand new RYOBI LIne Trimmer the *** thing just would not start. I was following the exact guidelines in the maual. First thing is, ensure you get right is fresh fuel correctly mixed accurately with 2-stroke oil. Some machines are more temperamental about the mix. 2. Set choke to COLD, press bulb 8 times (once you see fuel enteing the clear bubble reservoir) 3. Switch on power. It's amazing how often I've pulled the cord with that red button off. Dont think you cant do it to. 4. Pull the cord gently until you feel resistance. Let it gently recoil, then in one non-aggressive move, holding down the unit with your other hand, pull it out at constant speed. Do not yank! If (or rather when) it doesnt start, pull the accelerator trigger a couple of times only, and repeat procedure "4". Don't press bulb again too often or use the trigger too early or you will flood the engine. When I couldnt get my strimmer to start at all, I got this advice from an online engineer, it fired up *first pull*.

If it's not starting after a winter rest, did you store it empty of fuel because that is always wise. Discard old petrol mix and start with new. Hope that has helped.

Mar 04, 2009 | Ryobi 15" Electric Factory Reconditioned...

Not finding what you are looking for?
Garden Logo

Related Topics:

80 people viewed this question

Ask a Question

Usually answered in minutes!

Top Garden Experts

Dennis Key
Dennis Key

Level 3 Expert

2478 Answers

roeb

Level 3 Expert

666 Answers

john h

Level 3 Expert

13735 Answers

Are you a Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...