Question about Karcher 1750 psi Electric Pressure Washer

2 Answers

Craftsman 1800 psi pressure washer won't start

Brand new unit will not run. We have followed directions carefully. The pump made noise for about 3 seconds but never generated any pressure then it shut off. Have not been able to get it to come back to life. This is an electric unit and the pump is not supposed to start until the water reaches it. I know the external lines are clear and the power supply is fine, so I am thinking that there is some internal blockage. Just wondering if anyone has experience with a similar unit.
Thanks.

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 32 Answers

Disconnect the hoses to and from the machine and the try it.
the machine might have a blocked nozzle in the lance, of so get a paper clip and clear the jet backwards

Posted on Jul 04, 2009

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

These have a saftey devise on the nozzel. you need to pull the trigger, then push/pull the nossel forward. h2o will come out, then pull it back to the original location for more pressure.

you can turn the nozzel back and forth for a more narrow or more wide spray.

I just pulled mine out this afternoon and had the same problem, but was able to figure it out.

Also, make sure on the plug that you have the correct button pushed in (a light will come on).

Let us know if this solved your problem.

Posted on Jul 12, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ingersoll Rand Compressor won't start with more than 90 PSI in tank


Hello Nils,

I have resolved very similar issues with a 3 phase line filter.

In short, if there are any computer and/or solid state components involved in your circuit (beyond simple relays), they can be unusually sensitive to line noise.

Here is an example of such a filter and how it is wired:

http://www.transcoil.com/Public/Documents/Brochures/KRF-Brochure.pdf

Ps... Because the noise can be generated from the motor, I would install the filter into the circuit _past_ the motor. Alternatively, you can isolate the motor from the rest of the circuit. However, this could involve complete rewiring. I nevertheless suspect your problem is line noise generated by the motor.

Hope this helps...

Sincerely,
Gregg

May 18, 2015 | Ingersoll Rand Air Tools & Compressors

1 Answer

Have a 2.0kva-fr/26119 onan genorator which runs for 5 minutes and stops can you be of any help


If it stops after 5 minutes whether under load or not, and assuming the air filter, plugs, and fuel filter are new and or clean. The fuel pump is suspect. If it is in a motorhome try conencting it to an external fuel source that is at the same height as the generator. Then higher than the generator. If the problem persisits replace the fuel pump. Or just check fuel pump pressure with a gauge. BE CAREFUL do not use an automotive fuel pump Onan have special low pressure pumps, so use OEM part

Nov 13, 2012 | Onan Cummins 300-5332 Generator Switch and...

1 Answer

Brand New Heat Pump Compressor fan turns on then off after only seconds.


What is the model number of the outdoor unit?

If you need further help, reach me via phone at https://www.6ya.com/expert/thomas_092728000e6acb79

Jun 09, 2017 | Heating & Cooling

1 Answer

Brand new LG LDF6920 makes a whistling/high pitch squealing noise even during 1st test run, no dishes no contaminants added. It is during the wash motor cycle once the wash pump gets up to speed *screech*....


I had a brand new Dishwasher do that, it wasn't an LG it was a Frigidaire i think, turned out to be some bits of plastic from the manufacturing process that were in the pump. I had another one that made thumping noises and turned out to be a little piece of the tape, you know all that blue or green tape they hold everything in place with when its new. Did you run it through a few cycles and see if the noise quit? Believe it or not when i called about the one that was squealing their customer service said to run a couple cycles to remove anything that might be in the pump from manufacturing, sure enough midway through the second wash cycle it just went quiet and never made another noise again after two years.

Jan 11, 2018 | LG Dishwashers

1 Answer

Fuel pump not working. Followed your directions to reset theft device. Replaced relay (not sure which one it was...i guessed). Replaced fuel pump. Mother-in-law said she heard a noise from under dash then...


The relay only operates after the engines oil pressure is at operating PSI. If the relay was replaced and the fuel pump is not heard working when the ignition key is switched to the ON position for 5 seconds, replace the engines oil pressure switch. That switches 3rd wire connects to the fuel pump to run it for 5 seconds to prime the engine. That switch can be tested without the engine running. Just turn the key to the on position and listen for the pump to run for 5 seconds

Jul 19, 2010 | 1996 Buick Skylark

1 Answer

Onda generator engine starts and then 3 or 4 seconds later stall


Oil pressure switch. Check it and make sure oil level is correct. The oil switch will cause this

If you need further help, I’m available over the phone at https://www.6ya.com/expert/craig_3fa289bf857b1a3c

Aug 31, 2009 | Electrical Supplies

1 Answer

No fuel delivery from the Brand new fuel pump and filter. 1988 Ol


The pump is only suppose to run for 3 seconds if the engine is off. It will only stay pumping if the engine is running so the circuitry seems to be just fine. You prabably just got a bad pump again. Its common for repair shop to put 2, 3, and 4 pumps sometimes before they get one that works. We find it very common that a gauge will malfunction and the real problem is you just ran out of gas.

Aug 30, 2009 | 1988 Oldsmobile Delta 88

1 Answer

Brand new husqvarna 445, won't start


Try not giving any throttle when first starting. The newer trimmers are this way many times. (Maybe the newer chainsaws are this way now.)You prime the carburetor, set the choke and pull, but don't throttle until it runs for 10 or 15 seconds.

Jim

Jun 03, 2009 | Husqvarna Garden

Not finding what you are looking for?
Karcher 1750 psi Electric Pressure Washer Logo

2,009 people viewed this question

Ask a Question

Usually answered in minutes!

Top Karcher Garden Experts

John Trevino

Level 3 Expert

1388 Answers

Harold Baxter

Level 1 Expert

4 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Karcher Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...