Question about Bissell Cleanview Helix Vacuum

1 Answer

The light turns on but not the vacum - Bissell Cleanview Helix Vacuum

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

  • Expert
  • 39 Answers

Chanses are the motor is out or locked up with dust.
Try taping around the motor with a rubber mallet. Do not take it apart just turn it on and tap it. Hard as you dare without breaking it. Tap around the motor case. It may jar the carbon brushes lose.

Posted on May 14, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The bristles will not turn when vacume is on and I try to vacume


Alot of those vaccums have a little drive belt on them. You might look for that. Also some string might be caught on the side of the brushes.

Sep 13, 2014 | Vacuums

1 Answer

No suction


hey, how are you ?

here are a ew things that could be causing you sorrow

1.) Check your vacume to ensure that it isnt clogged anywhere

2.) before your compressor and after the filer, this part is where the suction takes place, check to see that it isnt clogged or that it isnt broken...

3.) check your packing (diapharam) in the vacume oto see if it ruptured(has a hole or broken)

4.) Check for lears on the vacume, basically run a pice of paper all over it and see if it is pulled to the vacume.

Once air is coming out the back, it means the compressor is working, but it alos means that the vacume is clogged, or a compartment that is u\supposed to be sealed is broken, or it has a leak somewhere..

My bet is that it is clogged somewhere, take it apart you will find it..

Jan 09, 2008 | Hoover F6020-900 SteamVac Upright Vacuum

2 Answers

Electrolux Unirapido not working green light flashes when start button is pressed!


I have the same problem with this type of vacum. I have tried a lot of things but the problem is with the software included in a 20 pins chip on the pcb so it can not be repaired. But, if you look in the back of the vacum there is a rubber stopper wich hides 2 pins. Maybe those pins can be used to reset the vacums pcb. I really dont know because in can't test it any more. I solved my vacum bypassing the vacum mainboard (pcb). Now my internal battery is directly connected to the 2 motors using a simple switch to powering on and off. The original pcb is conected only to the batery, recharghing wires and led wires so i can recharge the batery as usual. Sorry for my english, hope you understanded what i was trying to explain. good luck

Apr 15, 2013 | Vacuums

1 Answer

When the power head is turned on it goes from green light to red light and stops. The belt is fine and there is no obstructions in the brush to stop it from turning.


this will happen only when the brush or motor does not turn the right speed
make sure to pull the end caps off the brush and clean any hairs or fibers from it
the motor you can try and turn it by hand with out the belt on and see how free it is

Oct 19, 2010 | Fantom Vacums Lighting Canister Vacuum

2 Answers

Vacum not sucking the dirt and the light is not turning on


loss of vaccum brush head not spinning check belt turn over remove bottem plate check belt assmble. remove any string or hair build up sear is the best bet for the belt

Mar 31, 2009 | Kenmore 34923 / 34925 Progressive Bagged...

1 Answer

Oreck XL 21


My old vacume had the same problem - the wire had a 'plug' on both ends. 1 to the wall outlet and 1 to the vacume, which you could pull out of the vacume. It was making poor contact at the vacume and eventialy burned out (melted)
See if the plug/wire to the unit is removable, if so is it damaged?,
could need a cleaning, or it may not be pushed in all the way.

Good Luck



Mar 22, 2008 | Oreck XL21 Bagged Upright Vacuum

2 Answers

My vacum power head wont work


fan belt might have snapped.  take off top by snapping out plastic over light.  good luck!

Apr 18, 2007 | Kenmore 23313 Whispertone Bagged Canister...

2 Answers

Vacums


check belt not broken - could have happened when you caught tassle in head

Apr 18, 2007 | Kenmore 23313 Whispertone Bagged Canister...

Not finding what you are looking for?
Bissell Cleanview Helix Vacuum Logo

Related Topics:

39 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bissell Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

Brad Brown

Level 3 Expert

15628 Answers

Jim Thurston

Level 3 Expert

670 Answers

Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...