Question about SPL Dynamics CRM300-2 Car Audio Amplifier

1 Answer

Need more power and build a great systems

I have 2kenwoodmax240 2 6x9max240 1 12sub 2,600amps
xplod deck

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 578 Answers

Garbage amp poor performance get rid of it

Posted on Jun 26, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Radio cuts out


Did the xplod deck work correctly before you installed it? When it cuts out does it loose all its memory and setting and go back to factory defaults? It is possible that the deck is faulty.

Nov 15, 2013 | Dodge Neon Cars & Trucks

1 Answer

Sony xplod stereo wiring diagram


Yes you need to turn on the BOSE amplifier in the car to hear the sound. The wiring diagram is actually on top of the factory radio
You will need a 12v trigger to turn the amp on. this is assuming you have all the speaker (inputs) connected to the output from your new deck.

Sep 09, 2013 | 2001 Audi TT

2 Answers

I bought a sony deck to replace the bose stock deck on my 1996 nissan maxima. I purchased the wiring harness and antena adapter also. I hooked everything up right and getting power but im not getting no...


each speaker in your car runs the wiring thru an amp. So each spkear has its own amp for the bose system. You can not hook up a none bose radio If you do you will need to run new wires and replace all the speakers. Sorry.

Jul 02, 2011 | 1996 Nissan Maxima

1 Answer

I have a sony xplod gt200 The truck is a 1999 Dodge Dakota R/T The deck beeps as I scroll through the menus and volume controls but will not play music in AUX, TUNER or CD. But I get Beeps. Thi sis...


the beeping can be turned off for AUX to have sound u need to have something hooked to it if there is no sound it could be blown or incorrectly connected speakers or even a blown fuse also try RESETTING the unit

Oct 13, 2010 | Sony XPLOD CDX-GT200 CD Player

1 Answer

Will the sony Xpod car audio CDX be able to power a subwoofer


no not at all a deck can never power a subwoofer you need an amp the only speakers a deck will power is your fronts and rears aka mids and highs. you will need an amp to run a subwoofer. I hope I answered your question, if so please vote and leave high marks. Thank you very much

Aug 03, 2010 | Sony Xplod Car Audio CDX-F7810 - CD/MP3...

1 Answer

Sony Xplod stereo reset problem


My xplod deck wen I click on source it doesn't have aux anymore? How do I fix it so I can use my aux once again

Mar 01, 2009 | Sony CDX-540RF 10-Disc CD Changer

1 Answer

Subs sound terrible (Ive tried so many things)


NO it won't be your battery. Sounds more like your deck.

Jan 22, 2009 | Jl Audio 12W3 Car Subwoofer

1 Answer

Reseting the time


http://www.xplodsony.com/support enter in info and get support or buy a new deck at wholesale at this address:
www.godspeedaudioheaven.com

Jul 12, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

2 Answers

Sony Xplod 500w green power light no sound


try running the system with a cross-over configuration.

So your left + will be left + and your right + will be in the right + but put the right (-) where the left (-) is and left (-) where the right (-) is. If that doesnt work, then that means that you shorted out your audio out channels. the only way you can fix that is if you have good soldering skills. But other than that I'de say scrap it, unless you have the high outputs and then buy another amp, some mids and highs and connect the mids and highs to the xplod

Feb 23, 2008 | Sony Xplod XM-1652Z Car Audio Amplifier

Not finding what you are looking for?
SPL Dynamics CRM300-2 Car Audio Amplifier Logo

Related Topics:

25 people viewed this question

Ask a Question

Usually answered in minutes!

Top SPL Dynamics Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4862 Answers

yadayada
yadayada

Level 3 Expert

76164 Answers

The Knight
The Knight

Level 3 Expert

74251 Answers

Are you a SPL Dynamics Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...