Question about Brute Garden

Open Question

Help me with my Brute 650 power washer

I did ask a question, as to why I'm not getting water from the gun only for the first 3 seconds then it goes to a small flow.I have plenty of water to the machine, and the burst out of the gun is normal then stops to a tiny flow. I have trouble shot everything except talking the gun apart. New water supply hose, new nozzle, water supply lines to the gun are fine checked both, fitting and gaskets are in good condition, and fits are tight. Took off the auto cool down valve. It was releasing water at first now it is not. After 5 to 6 shots with the wand the water is warm. Any help, I did make the stupid mistake of leaving it outside all winter, covered, but cold in N.H. It always has gone inside. It only gets used a couple time a year and has always performed very well.

Posted by Anonymous on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where is the thermostat located on a 650 brute force


Hi, James for more information about your question and valuable "FREE" downloads that you will need please visit the websites below. Good luck and have a nice day.
Thermostat location 07 650 brute
Brute thermostat
kawasaki 650 brute force thermostat location Google Search
http://www.naturalatv.com/manuals/KVF650_08-09_Manual.pdf

Mar 25, 2016 | ATVs

1 Answer

HOW TO FIX A 2006 BRUTE FORCE NO POWER WHEN TURN ON KEY


Check fuse link under the seat. Look for the main 30 amp fuse. Also, could have shorted wire in the key housing where the key goes into the ignition. Put ohm meter on and check for continuity. this will tell if there is a short in the wiring. Hope this narrows it down for you.

Aug 31, 2014 | kawasaki 2006 Brute Force 650 4x4

1 Answer

Why does my 650 brute force pa pa at low speed or down hill


Sounds like bad gas or water in the gas. Could be needing rebuild in the carbs. Start by trying some sea foam in your gas tank.

May 28, 2014 | kawasaki 2008 Brute Force 650 4x4i

2 Answers

650 Brute Pressure washer, wayer comes out of nossle for about 3 seconds with the correct pressure, then stops, after a few times wayer is warm from wand


Leaving it outside may have broken something inside as water freezes, it expands a lot. The wand is unlikely to be the problem. Your problem is indicative of a water supply problem. Some hose fittings has a non-return valve in the middle, and I have seen these foul the fitting on the power washer and cut off the flow. The pump is a simple centrifugal pump that spins very fast. This is why the water is getting warm because of friction. In normal circumstances, the water running through it cools all the parts.

Mar 01, 2017 | Brute Garden

1 Answer

I get hose pressure from my Brute 2600 psi, 6.75hp power washer when the engine is not running, but when I start the engine, I get no additional motor pressure.


The pressure you have when the motor is not running is supply pressure through the unit. When you start the motor it will build up pressure then shut the pump action down until you pull the trigger of the gun. When you release the trigger the pressure drops to zero . This happens through a relief valve that the pressure hose is connected to. If what I stated is not happening then there is a problem with insufficient water supply to the machine or a problem in the relief valve.

Sep 28, 2013 | Yamaha Kawasaki Genuine Kvf750 Brute Force...

1 Answer

I have a Clarke King 100 hot wash with a wiring problem please can you help with the 3 connections from the pressure switch ?


the pressure switch is so the burner goes off when you stop squeezing the gun, there are only 3 different combinations wire1 and wire 2, wire 1 and wire 3, wire 2 and wire 3, it does not matter which way you connect them. You will know when it is correct as the burner will only work when the gun is squeezed and water is coming out of the lance nozzle at high pressure.

Jul 26, 2011 | Simpson King Brute 3030 Hot Pressure...

1 Answer

Water goes thru. have hydrulic oil to level. gun semas to stick on. NOT GETTING ANY PRESSURE AT NOSSEL.


Hydraulic oil?
Is this a pressure washer?
Pump should be half full of SAE20 or SAE30 non-detergent motor oil.
Engine should have 10W30 motor oil.

If you have a pressure washer ... and not water is coming out end of gun:
Take all hoses off machine.
Look at incoming water hose connection.
The should be a filter washer.
Clean or replace filter washer.
Hook up water and turn on water.
Water should come out other side of pump.
Turn on power washer and see if water coming out of pump is pressurized.
Now hook up pressure hose without gun.
Turn on pressure washer and see if water comes out of hose and is pressurized.
Finally, the gun may be bad.
We used to replace guns when they went bad.

Oct 24, 2010 | Dewalt 3800 PSI Pressure Washer

1 Answer

Coleman 1210 power washer no water comes out of gun


I've never used it before what plugs in where, the 1210 powermate, Pictures would help

Jun 01, 2009 | Coleman Pressure Washer PW0881800

1 Answer

2006 Kawasaki Brute Force 650, no power when key is on?


i have the same thing with my brute force what is it ??????

Mar 15, 2009 | 2005 kawasaki KLR 650

Not finding what you are looking for?
Garden Logo

Related Topics:

32 people viewed this question

Ask a Question

Usually answered in minutes!

Top Brute Garden Experts

Vernon Taylor

Level 3 Expert

2910 Answers

Jesse Walters
Jesse Walters

Level 2 Expert

275 Answers

Andrew Taylor
Andrew Taylor

Level 3 Expert

14548 Answers

Are you a Brute Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...