Question about Ovens

Open Question

Frigidaire stove My new Frigidaire oven CFEF 3005 LWE does not heat up. The burners and all lights etc. work fine? Any idea why?

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: My Oven and broiler won't heat but stovetop burners work

I have a Frigidaire Model Number GLGF377ASF. The stovetop burners work just fine but the oven and broiler do not work.

Posted on Dec 08, 2008

  • 22 Answers

SOURCE: KENMORE GAS STOVE OVEN LOWER BURNER WON'T WORK

Most likely a hot-surface ignitor has failed. If it doesn't consume enough current, the gas valve won't open. It's usually a fairly easy fix, once you gain access to the ignitor and have a new one to replace it with. Make sure you unplug the range...

Posted on Apr 25, 2009

jumptrout51
  • 3361 Answers

SOURCE: Frigidaire Oven - lights are on but no heat from oven or burners

You must check your incoming power for 220 volts. You have lost one leg of your power. Either a bad breaker or bad wall outlet or bad range cord.

Posted on Jun 26, 2009

TheMobilian
  • 8220 Answers

SOURCE: I have a gas stove - Frigidaire model FGF326ASA.

You probably have a weak ignitor. To operate properly it should draw 3.5 amps or better. The ignitor must be bright. If it is dim it is weak.
Some repair pix

Posted on Aug 29, 2009

Testimonial: "Thanks for the help, much appreciated. Ignitor was coming on but not pulling full amperage. Am going to replace ignitor."

  • 1 Answer

SOURCE: Frigidaire Gallery Professional Series - No clock/oven functions

i have an old model of the fridgedare gallery professional series stove. After self cleaning, the ignition sparks for the burners will not come off, they keep clicking and only stops when i pull out the plug. can you help me with this situation?

Posted on May 31, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The oven will not heat. The stove, oven light work fine. Just that the oven will not heat.


Probable cause of that is an open heater - no connectivity. As you know the heater is the one that produce heat in the oven. So when it has a problem even when the light oven light up, expect there be no heating happening. Also the wiring that connected to it.
I hope my advice give you an idea.

Mar 23, 2011 | Frigidaire GLEB27S7A Electric Single Oven

1 Answer

We have a frigidaire self cleaning oven . It made a bang and now there there is no power to my oven. Clock does not work , Burners on stove still work.


According to your symptoms, it appears that you will need a new electronic oven control board. If nothing on the range heats, you could have a tripped breaker on the 120 volt L2 leg of 240 volt power. This would prevent the cook top burners and the oven elements from heating.

Jan 21, 2011 | Frigidaire 30" Self-Cleaning Freestanding...

1 Answer

Stove top want heat up


the bulb i am sure is ok . but you have had a power failure to the burner . it could be the burner itself . if all the burners do not work the power to the range may be the problem .. ck the main fuse and make sure the 220 power is ok mm

Jul 12, 2010 | Frigidaire 30" Self-Cleaning Freestanding...

2 Answers

Frigidaire gallery stove, oven not working,


Morison,
The same thing happened to me about a week ago. I was preheating our electric oven, heard a very loud bang/pop. Checked and the oven had PF (power failure) I went downstairs and the breaker was tripped. Came back upstairs and to look at stove, the burners are working fine so I continued to preheat oven after a half an hour the oven was only slightly warm. Did you ever find out what was wrong?

May 04, 2010 | Frigidaire 30" Self-Cleaning Freestanding...

2 Answers

Frigidaire gas oven not heating


replace the bake ignitor its getting weak

Jul 01, 2009 | Frigidaire FGB24T3A Gas Single Oven

1 Answer

Frigidaire Oven - lights are on but no heat from oven or burners


You must check your incoming power for 220 volts. You have lost one leg of your power. Either a bad breaker or bad wall outlet or bad range cord.

Jun 26, 2009 | Frigidaire Ovens

1 Answer

Electric warming drawer will not heat


Found that there is an electrical connection at the point the main electric enters the back of the stove. There is a connector for the element that was not connected. Now it works!

Feb 18, 2009 | Frigidaire 30" Self-Cleaning Freestanding...

2 Answers

My Oven and broiler won't heat but stovetop burners work


I have a Frigidaire Model Number GLGF377ASF. The stovetop burners work just fine but the oven and broiler do not work.

Dec 08, 2008 | Frigidaire 30" Self-Cleaning Freestanding...

1 Answer

Frigidaire Gallery Professional Series - No clock/oven functions


i have an old model of the fridgedare gallery professional series stove. After self cleaning, the ignition sparks for the burners will not come off, they keep clicking and only stops when i pull out the plug. can you help me with this situation?

Nov 01, 2008 | Frigidaire FGB24S5A Gas Single Oven

Not finding what you are looking for?
Ovens Logo

Related Topics:

23 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ovens Experts

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

ashburton

Level 3 Expert

417 Answers

yadayada
yadayada

Level 3 Expert

75817 Answers

Are you an Oven Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...