Question about Traxxas 1/10 4WD Rally Racer Brushless RTR w/TQi 2.4GHz Radio

1 Answer

I have a two week old traxxas rally (1/10). It was working like dream one day, the the next time I used it (running both types of batteries LiPo's and standard), it was sounding like it was struggling, it was sluggish, at full speed no where near usual top speeds. I stopped the car checked it and noticed smoke coming out the back. I took of the top gear box cover to have a look. I should smell something burning but no visual signs in any of gearing. It all looked fine. Can anyone suggest what might be the issue.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Try tightening your slipper clutch. tighten nut all the way, then back it off aproxamently 1/3 turn. also check all electrical connections. a loose wire, especially your ground wire, can cause excessive heat and smoke

Posted on May 19, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Using lipo s it goes to low voltage shut off


the packs may need to be balanced..most good chargers have an option to balance your packs out..one cell may be stronger so it is running off that cell then acting dead

Apr 08, 2013 | Traxxas Toys

1 Answer

Old Pride Rally won't charge or run


The batteries may be too old to take a charge. They are gell cell types and can be had at any battery shop. You can get them on line too, but shipping will be high.

Dec 19, 2012 | Pride Rally 3 Wheel Scooter

1 Answer

Traxxas bandit vxl doesn't work i left my traxxas bandit vxl for 1 day and came back and drove and when i got outside and drove pass my sidewalk to go on the road the esc started flashing red slow


Are you running a lipo or nmhi? You could have the lipo cut off turned on and the battery is too low. Or it could have a bad motor. Try hooking up another motor an see what happens. Or try to turn off lipo mode.

Mar 13, 2012 | Traxxas Bandit Vxl Brushless Buggy

2 Answers

Problem with my traxxas stampede xl5 just stopped working.


It sounds like the battery is defective, that causes it to lose it charge very quickly.

Jan 26, 2012 | Traxxas Stampede Monster Truck Rtrw/Xl 5

1 Answer

The light, on the XL5 turns red when you turn it on.


thats probably because you are using a nimh battery and lipo low voltage detection is off

Sep 23, 2011 | Traxxas Stampede Monster Truck Rtrw/Xl 5

1 Answer

How do you change modes between lipo and nicac


push switch to turn on truck then Hold down the esc switch for approx ten seconds. You will hear a chime and then the led should change from either~ red to green ( Lipo mode) or from green to red ( Nimh mode)

Aug 22, 2011 | Traxxas 110 Slash Truck Mike Jenkins

1 Answer

The LED on the XL-5 is solid red after programming. The model operates normally, but the light is supposed to be green. What is wrong?


Press the ez-set button on the esc (the one with the heatsink) for ten seconds until it changes color and gives a beeptone,green is low voltage detection on for use with lipo batteries,if they are fully discharged they are dead,the detection system cuts power beyond 3v per cell so that the lipo isnt dameged

Dec 25, 2010 | Traxxas Rustler Vxl Rtr

3 Answers

Vxl-3s velineon problem with speed control


This problem is very common with the traxxas vxl 3-s speed control. If you were previously running it in 70 degrees or above without a cooling fan, hobbytown is correct. If you have a fan, or it is cool outside, try your best to return the speed control for a new one.

Jun 21, 2010 | Traxxas Toys

2 Answers

Traxxas stampede eletric r/c


The first thing to check is whether or not your speed controller is in Lipo mode or NiMH. If you are using NiMH, and the ESC is set for Lipo, it will not work properly. If the ESC is in NiMH mode, then try reprogramming the speed controller, as this has been my problem a couple of times. Good luck, and have fun. Hope this helps.

May 05, 2010 | Traxxas Stampede Monster Truck Rtrw/Xl 5

Not finding what you are looking for?
Traxxas 1/10 4WD Rally Racer Brushless RTR w/TQi 2.4GHz Radio Logo

99 people viewed this question

Ask a Question

Usually answered in minutes!

Top Traxxas Toys Experts

cwradio73

Level 3 Expert

1162 Answers

kakima

Level 3 Expert

102366 Answers

Mike Darragh

Level 1 Expert

8 Answers

Are you a Traxxas Toy Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...