Question about Hifonics Zeus Z400 Car Audio Amplifier

1 Answer

Sub making horrible thumping garbage sounds

I just bought a hifonics zeus z400 2-channel amp and the green light comes on but the sub is making a constant rumbling, thump, heartbeat even with the volume turned all the way down. i checked the power and its getting 12 volts on both + and remote....i didnt switch rca wires but im not sure what this is.....im wondering if the speaker terminals could be bad or something...it does it in both channels and hooked up bridged

Posted by on

  • howdoiuhhhh Jun 23, 2009

    how much would you say is cheap like 20 bucks ........and iive delt wth way bigger amps that never did this.......i remember a couple years back my buddy's did something like this but i forgot....ive just never used a noise filter, im not sure if it would really help

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 77 Answers

You need an noise filter in line. It's been a few years since I've had a system but I had the same problem. High power amps like the one you have can actually pick up on the electric pulses from your ignition system. I think I got mine at walmart, or auto zone, somewhere like that. Their pretty cheap too. I don't remember how its hooked up, but If you know how to hook and amp up, this should be no problem.

Posted on Jun 23, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Protect light amp


Thanks for using FixYa - a 4 THUMBS rating is appreciated for answering your FREE question

would definitely look at getting it repaired. These new amplifiers can't hold water to an old school Zed audio hifonics Zeus.

Jul 31, 2013 | Hifonics XX-Zeus Car Audio Amplifier

1 Answer

Ive got a 5channel zeus z7oo & im hooking up


if i were you i would put the switch to 4ch and the run one sub from ch1-2 bridged and then ch3-4 bridged. I would have to bet this amp is stable only to 4 ohms bridged with so many channels

Mar 19, 2010 | Hifonics Zeus Z700 Car Audio Amplifier

1 Answer

Hifonics zeus z400 red diagnostic light blinks on a bench test ? whats that mean any one know.


yes you have a internal fault of the amp. the circuit that puts it into safe mode is bad and or a channel or power supply and that is a very small chip on the board know as a op amp. needs to be repaired.

Jan 12, 2010 | Hifonics Zeus Z400 Car Audio Amplifier

2 Answers

Car AMP from subs making noise and only from AMP


There may be a cracked solder joint on the main PCB.
also - check the wiring.
There should be no noise if the radio is off.
When it's on - remove the RCA cables... and see if the noise persists.

Thanks for using FixYa - a 4 THUMBS rating is appreciated for answering your FREE question.

Dec 11, 2009 | Hifonics XX-Zeus Car Audio Amplifier

1 Answer

Is my amplifier giving my subs the full power they need?


no sony has like 400 rms on that amp. eventualy u will blow the subbs. buy the hifonics 1608d amp to power thees subbs connect them all positives together at amp terminal and all negative together at negitive on amp terminal. this will make it a 1 ohm load with around 1400 true rms so around 500rms each sub.this amp on ebay runns like 250 and is worth every penny

Jul 20, 2009 | Alpine CDA-9884 Car CD/ MP3 Player

1 Answer

I have 3 hifonics zeus Size: 12 inch Impedance: Single 4 Ohms Peak Power Handling: 800 watts RMS Power Handling: 400 watts Sensitivity: 89.9 dB Aluminum Cast Basket American Spider For Reliable Performance...


Hello king3132,

Three 4 ohm subs can be wired parallel for a 1.34 ohm final load or series for a 12 ohm load. If you have the channels of the amp bridged, I hope that the subs are connected in series because the Sony XM-2200GTX is NOT rated for or stable at 1.34 ohms. It's only stable down to 4 ohms.

You definitely will not get the maximum potential of the subs from that amp. They can handle 400 watts RMS each (total 1,200 watts) and the amp is only capable of 500 watts RMS into 4 ohms (less at higher impedance), so each sub could only be getting a maximum of 166.6 watts RMS.

Hope this helps.

Jul 20, 2009 | Digital Audio Car Audio & Video

1 Answer

HiFonics txi4008 not working, partially lighting up


Sounds like your amp has some power supply compents shorted out. Maybe some of the power mosfets are shorted and your only getting a little bit of power. That why only the H is lighting and as far as the green light, it don't take much for it to turn on. If it was major it would go into protect mode but it is'nt. I repair amps for a living and I'm the cheapest you'll find. But if you know about electronics and think you can take a crack at it, check it out. Becareful you could do more damage. Let me know if your interested. skinnman33@gmail.com

Jun 06, 2009 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Make the sub pop and hum and no rca wire are hooked in?


first off nice choice on the amp check ur power and ground connections make sure the main battery to bady ground is good if questionable add a new one cant hurt to have extra grounds from the batt to the body make sure the amp ground is as short as u can make it make sure its grounded to bare metal if any of these dont work u may have a prob inside ur amp 

May 06, 2009 | Hifonics XX-Zeus Car Audio Amplifier

1 Answer

Problem!


you have a foulty amp i wtake it bk and change it

Dec 27, 2007 | Hifonics Brutus BX 1505D Car Audio...

1 Answer

Power light


This could be a DC offset condition. Check you manual for what this means. Or other condition. First Disconnect the Subs and try it. If it still goes red then disconnect the RCA's and try it again. If the Led continues to go red after the click then the Amp is hosed. The Click you hear is an internal relay that cuts the subs in after a dely so you do not get the turn on THUMP of the radio at your subs.

Jul 08, 2007 | Hifonics Titan TX 8805 Multi-Channel Amp...

Not finding what you are looking for?
Hifonics Zeus Z400 Car Audio Amplifier Logo

259 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hifonics Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Radames Pagan
Radames Pagan

Level 3 Expert

196 Answers

Are you a Hifonics Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...