Question about Car Audio & Video

1 Answer

I installed my amp to my pioneer sterothe protection light come on

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 2,509 Answers

Check for shorts on the speaker circuits

Posted on May 09, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a pioneer gm-354 amp and the power indicater light on the front has changed from solid to flashing and no sound from the amp to the subwoofer it used to power any idea's


If it is flashing it went into the protect mode.Check that a speaker wire hasn,t come off, Or that the ground cable conection is good end all other hook up wires to it.

Oct 27, 2012 | Pioneer GM-X354 Car Audio Amplifier

1 Answer

My protection light keeps turning on.


i'm almost positive that your amp is overheating. i would either buy another one or bring it in to the geek squad. but i'm 99.9% sure it's overheating

Apr 28, 2010 | Kicker ZX10001 Car Audio Amplifier

3 Answers

Pioneer VSX-1019 with a flashing red MCACC


you can "release" the error by pressing the "down arrow" and the "zone 2 on/off" for 2 seconds.

Mar 11, 2010 | Pioneer VSX-1019AHK A/V receiver

2 Answers

I have a pioneer gm-d8400m the amp isnt working


flashing light could mean a few different things. 1- constant power may not be there. check with a test light or multimeter. should read around 12 volts. it would be a good idea to check all the power and ground leads. make sure u have a good ground. 2- bad sub. im assuming sub since its a monoblock amp. you can meter the subs. make sure the total ohm load is no less than 2 ohms. any lower the amp will go into protect mode. 3- bad amp. power supply may be bad. the newer pioneer amps are full of protection circuits. ive been a professional installer for a shop about 8 years and we sell pioneer. hope it helps.

Dec 25, 2009 | Car Audio & Video

1 Answer

Protection mode on my amp


YEA CHECK THE OHMS ON THE SUB TO MAKE SURE THEY MATCH UP TO THE AMP JUS SOUNDS LIKE THE WIRING IS OUT OF PHASE.

Jun 15, 2009 | Pioneer GM-7200M Car Audio Amplifier

1 Answer

I have the pioneer sub and a sony 600watt 4


it has a detector that kicks in it will usually shut off your amp and it keeps you from blowing your amp the speaker may have to much power and amp may not push it it will start to protect itself

Jun 07, 2009 | Pioneer TS-W307D4 Car Subwoofer

1 Answer

Red light showing up on amp ( pioneer 800 watt GM 7200 amp )


it could be the amp it could be the way you've installed and if you have a sub in an enclosure the wires could be touching the postive and negetive speaker wires what ever the problem is the amp is in protection mode i hope this helps hope its not the amp i hope its just the wiring

Jun 05, 2009 | Pioneer GM-7200M Car Audio Amplifier

1 Answer

Pioneer 800w mono issue


It can be many things it possible the amp cannot handle the 4 ohm load and simply goes into power protection mode. Also make sure your using the correct gage wire to run power from your battery to the amp to thin and it wont have enough power to perform.

May 09, 2009 | Pioneer 800W Class-D Mono Amplifier With...

2 Answers

Protection light keeps coming on


Check the wiring between the sub and the amplifier. That's seems to be the only thing left that could cause a problem. If it's shorted to ground or pinched so the conductors are shorted together, it could cause the symptoms you listed.

Oct 01, 2007 | Sony XM-2002GTR Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

24 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4848 Answers

yadayada
yadayada

Level 3 Expert

75822 Answers

The Knight
The Knight

Level 3 Expert

74136 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...