Question about Swisher Zt2350 Zero Turn Radius Tractor

1 Answer

Have azt2350a that the blades wont start

When you start the engine then pull the knob up to engage the blades they don't start

Posted by Anonymous on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 16 Answers

Probably a blown fuse in system.

Posted on Jan 03, 2015

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
pippall
  • 1486 Answers

SOURCE: my p.t.o. wont start my blades

Belt needs tightening or its brocken.Check first.

Posted on Aug 09, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Husqvarna LGT 2554 deck hung up on high spot mowing. Turned off deck & mower pushed by hand. Engaged deck,started to mow, wound to stop. Belts fine. Pull up on knob to engage, you get nothing.


The engine runs but the blades do not engage? Make sure the wire connecting the electric clutch is still plugged in. If all is connected and the belt is really fine, there is a problem with either the electric clutch or PTO switch.

May 21, 2015 | Husqvarna Garden

1 Answer

I replaced belt now blades wont engage when i pull knob please help


recheck the way you ran the belt. if you are on the wrong side if the engagement pully, the blades will not engage.

Mar 19, 2015 | Garden

1 Answer

What causes fuse to blow every time I try to engage blades?


To engage the blades is it a knob to an electric switch that you pull?
If so does the wire from the switch activate a electric clutch?
Is the wire damaged and shorted to the frame, is the clutch shorted. If you provide the brand name and model number I might be able to find a schematic for your mower.

Video shows an electric clutch but yours may be different but this should give you an idea of where to look. Riding Mower Electric PTO Clutch Won Engage When Hot Problem Fix

Oct 02, 2014 | Garden

1 Answer

Bladesdoturnwhenengaged


your belt has most likely jumped out of it's intended route, or has broken, check with engine NOT running keys out switch off, pull engage knob and try to manually move blades if they move while knob is engaged, belt is broken or off track

Mar 21, 2014 | Husqvarna Garden

2 Answers

Scotts L2048 lawn tractor deck wont engage


You need to check the wires from the clutch, with the ignition on pull the pto switch out there should be a 12 volt supply at the wires if not replace the pto switch, if you have 12 volts then it is the clutch itself, they are not realy repairable, so may need a replacment.

Jul 16, 2013 | Garden

1 Answer

The blades begin to engage when i try to start the engine and the clutch is off!! The engine wont start as a result! please help!


your engine probably sheared the flywheel key replace it but the blades engageing on there on is a big problem check blade clutch make sure its not stuck in the on position engaged

Jul 09, 2013 | Garden

1 Answer

Stalls When engaging the blade clutch


Check that the blade brake is disengaging. Slip belt off blade spindles and check that they spin freely. Check underside of deck for clogged grass, ropes, wire, etc.

May 07, 2012 | Husqvarna Riding Lawn Mower Yth24v48ls 48...

1 Answer

Belt. came off... pulling up blade engagement knob nothing seems to happen.....I have trackter up on blocks with blade cutting height at 1 with engine runnig the blade engagement knob switch ...


sounds like a bad PTO, that is the electrical gizmo on the bottom of the engine's driveshaft which engages the bottom pulley, running the deck. you might luck out and find the fuse is blown so follow the wire from the PTO back until you find the fat part in the wire. the fat part is an in line fuse holder with a fuse in it. if the fuse is bad and blows again, you need a new PTO

Aug 19, 2011 | Husqvarna Riding Lawn Mower 42 Inch Cut...

1 Answer

I had just started cutting grass with my John Deere L120 riding mower when the blades stopped turning. I thought the belt had broke or come off so I pulled into my garage to investigate. I turned the mower...


You have several safety switches on your unit. The engine should not start if the PTO safety interlock is engaged. Be sure PTO switch is off.
If the sarter Does Not Work Or Will Not Turn Engine Brake pedal is not depressed.
or the PTO is engaged.
Battery terminals are corroded. or Fusible Link in starting circuit is blown - (Not likely unless bad wires) Here is a link to your wiring diagram (maybe your model)

http://www.postimage.org/image.php?v=Pq1tOfiS
Notice how the starting circuit goes through the brake pedal (must be depressed) and the PTO switch (must be disengaged) and that the PTO only works with operator present. Print that page while link still works.

Aug 11, 2010 | Garden

Not finding what you are looking for?
Swisher Zt2350 Zero Turn Radius Tractor Logo

66 people viewed this question

Ask a Question

Usually answered in minutes!

Top Swisher Garden Experts

lnbn1975

Level 2 Expert

203 Answers

Jim Parker
Jim Parker

Level 3 Expert

1041 Answers

Tim Whalen

Level 3 Expert

3074 Answers

Are you a Swisher Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...