Question about Safety 1st PRISM Color Camera

Open Question

Can I somehow access the video feed from my Safety 1st Prism HD Video Camera on something other than the provided monitor?

I purchased this camera second hand from a thift store thinking it was a webcam but was pleasantly suprosed to find out it is actually a pretty darn good baby monitor. I however did not get the monitor i am to understand is boxed with this brand. Do I have to use the provided monitor or is there another wasy to access the feed?

Posted by on

Ad

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 419 Answers

SOURCE: Safety 1st Video baby monitor - replacement wires?

Hi,

I would suggest that you contact the manufacturers (Dorel UK), the link is below:

http://www.dorel.co.uk/safety-1st/

Posted on Sep 14, 2009

Ad
  • 1 Answer

SOURCE: add a camera to safety 1st baby monitor

1. Place camera and handset no more than 1 foot apart.
2. Select "Device" on handset and highlight "Add."
3. Press and hold button on camera. When green light starts to blink rapidly, press right on handset while continuing to hold camera button in.
4. When handset says "Please Wait," camera button can be released. "Successful" will display on handset screen when camera has been added.

Posted on Sep 18, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Our cameras were unplugged and then reinstalled (only partially uninstalled) and now we cannot get them to "reboot" We are getting an error of "video loss" I can not figure out how reboot the cameras so...


If your monitor is showing 'video loss' on each of the eight camera windows then the problem lies between the camera connections on the back of the Recorder and each camera. Without knowing what partially uninstalled means the troubleshoot process would be:
1. Use a voltmeter and check the camera power supply(s) line adapter where it splits to feed the cameras for full voltage- your unit should show 12Volts DC. Lack of voltage here and the cameras will not have power and cause 'no video' to the recorder.

2. Check the recorder menu to make sure that all camera inputs are turned on and are set to record. 'Covert' or hidden screens may not be viewed on a monitor but might show 'loss of video'.

3. It's highly unlikely that all cameras would fail at the same time so 1) if there is power and good video cable connections at the cameras, the next check would be to : 2) check each video connection into the back of the recorder and make sure that they are on camera "input", and not on a 'loop out' terminal by mistake.

If the above checks do not determine the fault, you would have to somehow feed a known good video signal into one of the camera inputs on the recorder and then troubleshoot the recorder.

If you repost what you have confirmed working we can re-assess.

Jan 25, 2013 | Night Owl Optics 8 CHANNEL H264 DVR WITH 8...

1 Answer

I have a safety 1st video monitor, model no. 08280. Since yesterday, the hand held parent unit displays a white screen when trying to view the baby. I have unplugged, checked batteries, charged them up...


Good Evening

The light on the camera unit not being illuminated indicate this is where the problem lies.

Ensure that the camera unit is plugged in and press the power button on the camera unit. If the camera unit does not switch on this is what has failed and you require a replacement - please contact your retailer. If the camera unit switches on and the parent unit is unable to establish a connection follow the instructions in the user manual to add a camera.

May 09, 2011 | Safety 1st Digital Video Monitor

1 Answer

Cant see the video the screen just goes blue with a circle picture around the monitor


This indicates the camera is not linked to the parent unit. Hold down the button on the camera until the light around the on/off switch flashes green. It is now linked to the parent unit.

Apr 14, 2011 | Safety 1st Digital Video Monitor

1 Answer

How do I get a replacement battery for my safety 1st true view color video monitor?


I went on Amazon last week for the exact same issue. Mine was an older model though so I couldn't get replacement parts. I did however see a link under their Safety 1st products for replacement parts for video monitors. Try there. Good luck!

Apr 04, 2011 | Safety 1st True View Video Monitor

1 Answer

Add a camera to safety 1st baby monitor


1. Place camera and handset no more than 1 foot apart.
2. Select "Device" on handset and highlight "Add."
3. Press and hold button on camera. When green light starts to blink rapidly, press right on handset while continuing to hold camera button in.
4. When handset says "Please Wait," camera button can be released. "Successful" will display on handset screen when camera has been added.

Sep 04, 2009 | Safety 1st Hi-Def Digital Monitor

1 Answer

My camera's monitor/screen is black with no picture


My AIPTEK 1080p was powering on but the screen was turning off within one second of turning the unit on. I verified that the camera was still working and just the output onto the screen failed. I was able to resolve this by hooking the camcorder up to the TV and viewing the menus on the TV and then turning the camcorder off with the power button. I think this problem happened because I didn't do a "clean" shutdown the last time I had my aiptek hooked up to the TV. It is now working perfectly!

Jul 27, 2009 | Aiptek Video Cameras

1 Answer

Tearing at top of MT-1564R screen


There is a possibility that you have a weak video signal. You can boost this with a small video amplifier. This is most commonly seen in set-ups that have multiple monitors or when you have long video cable runs like you would see in an RV back-up camera system.

Sep 24, 2008 | Emerson MT-1564R Car Monitor

2 Answers

Minolta XG-1 Film Camera View Finder has Door Seal Foam stuck in it.


jrbw123,

the top cover must be removed and the flex circuit on top of the prism must also be removed. then remove the prism to access the fresnel lens. the lens is extremely fragile and very difficult to clean.i would try to replace it with a good used one if possible. unless your a intricate instrument repair person i would let a camera repair person do this.

Nov 05, 2007 | Olympus Stylus Zoom 140 35mm Point and...

Not finding what you are looking for?
Safety 1st PRISM Color Camera Logo

Related Topics:

69 people viewed this question

Ask a Question

Usually answered in minutes!

Top Safety 1st Baby Care Experts

Dorel UK
Dorel UK

Level 3 Expert

1629 Answers

Cindy Wells

Level 3 Expert

5187 Answers

masud
masud

Level 3 Expert

572 Answers

Are you a Safety 1st Baby Care Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...